[GW1] Old games not launching and eating 100% of the CPU on Windows 7 — Guild Wars 2 Forums

[GW1] Old games not launching and eating 100% of the CPU on Windows 7

TheQuickFox.3826TheQuickFox.3826 Member ✭✭✭✭
edited June 29, 2019 in Account & Technical Support

There seems to be a major foul-up with Windows 7 and older games. The game does not launch, and instead an instance of Rundll32.exe is started which hangs with high CPU usage. This also may affect Guild Wars 1.

Solution: add this to a .reg file and add it to the registry:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\GameUX\ServiceLocation]
"Games"="127.0.0.1"

I just had a case of several of my old windows games refusing to start while the CPU would saturate doing nothing (Win 7).

After investigating a little, I found out that the cause for this was the Game Explorer (gameux) who meddled as soon as the game got started. It would try to connect to the Microsoft servers to collect infos. But it seems that the MS server (https://games.metaservices.microsoft.com/games/SGamesWebService.asmx) is dead now. So it loops indefinitely doing nothing, and all these game won't work anymore.

This bug affects all games listed in the windows registry at this location : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\GameUX. Others are unaffected.

This is totally silly, but can be easily solved. Some did it by deleting some dlls, but it is better to just change a registry key.

EvilEdDead explained it well here (thanks man !).
Just open Regedit, got to HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\GameUX\ServiceLocation and change the server address contained in the "Games" chain value to 127.0.0.1 or localhost (do a backup first if you wish).

This will solve the problem once and for all for all the games which had it.


Alternative method : copy-paste the text below to a txt file and rename the extension as .reg instead of .txt, then double-click on the file to apply it.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\GameUX\ServiceLocation]
"Games"="127.0.0.1"

And to undo the changes, do the same with this instead :

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\GameUX\ServiceLocation]
"Games"="https://games.metaservices.microsoft.com/games/SGamesWebService.asmx"

Source:
https://www.gog.com/forum/general/old_games_not_launching_and_eating_100_of_the_cpu_on_windows_7/page1

Ascalon Will Prevail!

GW Wiki user page | GW2 Wiki user page

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.