Game is chrashing on startup, even after a reinstall — Guild Wars 2 Forums

Game is chrashing on startup, even after a reinstall

Not really sure what to do
--> Crash <--
Exception: c000001d
App: Gw2-64.exe
Pid: 11908
BaseAddr: 00007FF70B390000
ProgramId: 101
Build: 97999
Module: d3d9.dll
When: 2019-07-28T16:54:58Z 2019-07-28T18:54:58+02:00
Uptime: 0 days 2:18:59
Flags: 0

--> System <--
Name: ed1e302f
IpAddr: 192.168.1.11
Processors: 8 [GenuineIntel:6:12:3]
OSVersion: Windows 10.0 (64 bit)

--> System Memory <--
Physical: 18923MB/24514MB 77%
Paged: 21886MB/28098MB 77%
Virtual: 134174909MB/134217727MB 3%
Load: 22%
CommitTotal: 6211MB
CommitLimit: 28098MB
CommitPeak: 10150MB
SystemCache: 13887MB
HandleCount: 74027
ProcessCount: 175
ThreadCount: 2250

--> Process Memory <--
Private: 1494MB
WorkingSet: 1163MB
PeakWorkingSet: 1163MB
PageFaults: 347918143

--> Memory Category Usage (Inclusive) <--
[Category] [Size(MB)] [Count]
Root 457.60 277894
Programmer Data 362.97 150180
VRAM 257.35 20756
Game 233.83 122520
Content 211.88 27941
VRAM - Gr Postproc 124.71 17
Collections 80.21 480
Dictionary 80.10 155
Uncategorized 68.43 126678
VRAM - Composite Tex 54.66 41
VRAM - DDI Shader 32.78 19104
VRAM - DirectX Geo Buffers 30.56 1520
I/O 27.46 1830
Archive 26.16 1395
Art Assets 19.75 281
Character Models 18.19 71
Composite Models 18.19 71
Composite Tex Pool 17.84 42
Composite Tex 17.84 42
Engine 16.36 24395
Composite 11.51 1752
VRAM - Cinema Tex 9.56 38
Audio 8.11 428
Audio FMOD 8.05 345

--> Memory Category Usage (Exclusive) <--
[Category] [Size(MB)] [Count]
Content 211.88 27941
VRAM - Gr Postproc 124.71 17
Dictionary 80.10 155
Uncategorized 68.43 126678
VRAM - Composite Tex 54.66 41
VRAM - DDI Shader 32.78 19104
VRAM - DirectX Geo Buffers 30.56 1520
Archive 26.16 1395
Composite Tex Pool 17.84 42
Composite 11.51 1752
VRAM - Cinema Tex 9.56 38
Audio FMOD 8.05 345
Collide Havok 6.45 755
Game 4.97 31778
Text 4.46 354
Debugging 4.00 2
VRAM - Gr Texture 3.56 26
Gr Material 3.38 19420
Gr 3.04 129
File Service 1.24 12
VRAM - Instance Buffers 1.00 1
Game Animation 1.00 60687
Uncategorized Tex 0.99 23
Gr Umbra 0.62 12

Comments

  • Nokomis.5076Nokomis.5076 Member ✭✭✭

    You're using any kind of shader/exploiter which is in need of d3d9.dll.

    Remove that file and try to check, if your game runs vanilla. Maybe the shader/whatsoever is outdated.

    Was I able to help you or give you a hint? Click on Helpful and/or Thumbs up, I would appreciate it alot!
    When you encounter a bug ingame, at first you should file a ticket via the ingame command /bug, as only this way the devs will know exactly where you were, when the bug happened.

  • @Nokomis.5076 said:
    You're using any kind of shader/exploiter which is in need of d3d9.dll.

    Remove that file and try to check, if your game runs vanilla. Maybe the shader/whatsoever is outdated.

    The issue right now is that that's the crash dump I got after I did a fresh reinstall of the game, nothing was left of the old install. I haven't had shaders installed for GW2 for years

  • Toolbox.9375Toolbox.9375 Member ✭✭✭

    How long has it been doing this? Did anything on the computer change prior to the issue, such as installing new programs or games that might have messed with d3d9.dll, updating Windows/drivers/GW2, moving folders around, etc.?

  • @Toolbox.9375 said:
    How long has it been doing this? Did anything on the computer change prior to the issue, such as installing new programs or games that might have messed with d3d9.dll, updating Windows/drivers/GW2, moving folders around, etc.?

    It started happening today after I updated to KB4505903 (Windows 10)

  • Had the same issue. It is KB4505903. After removing it, the crashes where gone!

  • @raubvogel.5071 said:
    Had the same issue. It is KB4505903. After removing it, the crashes where gone!

    Glad to hear it wasn't just me

  • @raubvogel.5071 said:
    Had the same issue. It is KB4505903. After removing it, the crashes where gone!

    Same here. But 24 hours later, WIn 10 is insisting it's going to reinstall it. How do we get round that?

  • Aaralyna.3104Aaralyna.3104 Member ✭✭✭

    https://support.microsoft.com/en-us/help/3183922/how-to-temporarily-prevent-a-windows-update-from-reinstalling-in-windo

    Here you can find to stop an update from installing and returning every time to be installed.

    Source: Windows themselves.

  • crepuscular.9047crepuscular.9047 Member ✭✭✭✭

    is that a mandatory update? i think I've had my update set to critical only, and that may be the one sitting in the optional bucket last week when my machine checked for updates

    [RIP Fashion Wars 2005-2018]     [TTS] [KA] [SI]     [RIP Fashion Wars 2005-2018]
    Praise the Inevitable Eternal Transcendent King Palawa Ignacious Joko, the Beloved and Feared Undying Eternal Monarch of All !!!
    ... til Aurene ate him for dessert 😭
  • Doghouse.1562Doghouse.1562 Member ✭✭
    edited August 5, 2019

    @Aaralyna.3104 said:
    https://support.microsoft.com/en-us/help/3183922/how-to-temporarily-prevent-a-windows-update-from-reinstalling-in-windo

    Here you can find to stop an update from installing and returning every time to be installed.

    Source: Windows themselves.

    For info - when I allowed the update to install for the second time, things got even worse - couldn't launch the game at all without a crash.

    HOWEVER. I normally run Comodo Firewall, and I noticed that THAT was also glitching regularly between claiming to be working fine and some fault state that wasn't letting any traffic through (cause or effect? it wasn't obvious). But having (temporarily or otherwise) uninstalled that, suddenly things seem to be working smoothly again, and I'm at least back in game.

    Although for some reason the launcher now triggers an account control prompt every time I run it. ((And... now that's cleared as well. Weird.))

    (Hmm. I did nothing to re-engage the WIn 10 firewall, and it's definitely running, so it seems likely that my machine was trying to run with both active - which is probably not a great idea... I wonder whether the Windows update simply turned the default one back on without telling me? Must go back and try with Comodo on and the Windows one turned off, when I have a few minutes...)

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.