Strange lag when in squad — Guild Wars 2 Forums

Strange lag when in squad

wefal.8426wefal.8426 Member ✭✭
edited August 7, 2019 in Players Helping Players

A little background is needed:
About a month ago I joined a guild and started to do raids with them. For the first and second week everything was alright ping-wise.
Then about two weeks ago, during raid, I started to get massive lag spike (MLS). We do raids almost every day starting at 6:30 pm UK time.
At first I thought this was due to rush hour/holiday so I joined less and less to raids.

So, today I was minding my own business doing daily in Desert Highlands (completely lag-free with healthy ping) when guildies prepared for another raid.
At that time I thought "well it's that time of the day again so lag incoming". I decided to join but warned if I lag - I'm out.
The second that I joined the squad, MLS. So I told my guildies I'm out. It was unplayable.
I went back to doing daily when I noticed lag is gone. I thought "ok this is strange, maybe lag spike?" so I asked to join squad again. Literally the second that I joined, MLS.
I talked with my guild about this strange occurrence and they suggested maybe it's an addon I installed. I use Arcdps and thought maybe this is the catalyst for this MLS.
There was slight improvement after uninstalling Arcdps. But then again, when I joined squad and into raid lobby/wing, lo and behold, MLS.
I left the squad/raid and went back to doing PvE dailies. Lo and behold, the lag persist! Restarting PC/router didn't work.

Why joining a squad makes my ping skyrocket? Does anyone else had this? How do I fix it?

____UPDATE:____
I deleted cache at %TEMP% and bin64 folder. Still no change.
It seems this lag also has something to do with entering raid map itself. The lag spike there is insane.
What's worse? This strange lag PERSIST even when I left squad/raid map.
Even after leaving squad/raid, deleting cache and bin64 AGAIN, I still have high ping.
Help? Any ideas?

Comments

  • Loosmaster.8263Loosmaster.8263 Member ✭✭✭✭
    edited August 2, 2019

    Did you remove/rename the Arcdps .dll file in the bin folder? As of yesterday that file is still out of date since the Festival patch.

    Also keep in mind that when joining party/squads you are reading everyone's data, so you have increased traffic.

    Fàther - Create a mount then kill it until it's more useless than PvE. "Smart"
    Tactical Killers
    Server(DR)

  • wefal.8426wefal.8426 Member ✭✭

    The problem happened even before Arcdps.
    Just in cases I deleted all Arcdps files.
    I'll have to check tonight if I still lag.

  • rng.1024rng.1024 Member ✭✭✭✭

    You could try deleting the games cache, as I ran into a similar problem in my previous account where after opening thousands of loot bags everything started to lag/rubberband - sounds like a client stress issue since it only happens when you join squads.

  • wefal.8426wefal.8426 Member ✭✭

    @rng.1024 said:
    You could try deleting the games cache, as I ran into a similar problem in my previous account where after opening thousands of loot bags everything started to lag/rubberband - sounds like a client stress issue since it only happens when you join squads.

    How do I delete games (plural? or you mean GW?) cache?

  • Khisanth.2948Khisanth.2948 Member ✭✭✭✭

    @wefal.8426 said:

    @rng.1024 said:
    You could try deleting the games cache, as I ran into a similar problem in my previous account where after opening thousands of loot bags everything started to lag/rubberband - sounds like a client stress issue since it only happens when you join squads.

    How do I delete games (plural? or you mean GW?) cache?

    Close GW2, Open a File Explorer window and put %TEMP% in the location bar, press enter, delete the folders with names that start with "gw2cache-"

  • rng.1024rng.1024 Member ✭✭✭✭
    edited August 3, 2019

    @wefal.8426 said:

    @rng.1024 said:
    You could try deleting the games cache, as I ran into a similar problem in my previous account where after opening thousands of loot bags everything started to lag/rubberband - sounds like a client stress issue since it only happens when you join squads.

    How do I delete games (plural? or you mean GW?) cache?

    You can also delete the bin64 folder that's in the same path as gw2.exe in addition to what @Khisanth.2948 suggested. The folder will recreate when you relaunch the game but load everything in anew. And yes I was talking specifically about Guild Wars 2 :)

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.