Low fps with I7 8700k and AMD RX 5700 — Guild Wars 2 Forums

Low fps with I7 8700k and AMD RX 5700

Hi, while im gaming apex and battlefield 5 easily on ultra settings.. GW2 is being a real b*tch.
Autodetect also says low settings ???.
I tried so much like stresstesting my pc > everything fine (95%)
i checked my ram speeds, they are ok.
i updated my drivers
i updated directx
i unparked my cpu's

im just lost what to do, guildwars 2 cant seem to run smooth....

Comments

  • I have been having similar issues with my RX 5700 / Ryzen 5 2600 build as well. Every other game I've played runs fine (Destiny 2, FFXIV, to name a few) but GW2 will just not make my GPU run at it's full clock speed or use anymore than 10% of my GPU. It seems to stutter when moving the camera like loading in textures and models gets the GPU to work but it otherwise just idles at 4-5% usage. It does stabilize after a while of moving about the map and turning the camera but it still stutters regularly. A little lost as what to do and how to fix it. I did get the issue to go away after a driver update and windows update but the problem came back a week later.

  • @PandLantis.2496 said:
    I have been having similar issues with my RX 5700 / Ryzen 5 2600 build as well. Every other game I've played runs fine (Destiny 2, FFXIV, to name a few) but GW2 will just not make my GPU run at it's full clock speed or use anymore than 10% of my GPU. It seems to stutter when moving the camera like loading in textures and models gets the GPU to work but it otherwise just idles at 4-5% usage. It does stabilize after a while of moving about the map and turning the camera but it still stutters regularly. A little lost as what to do and how to fix it. I did get the issue to go away after a driver update and windows update but the problem came back a week later.

    exactly this! it runs at 90 fps when steady but as soon as i turn my camera, everything goes to kitten. I hope someone can help us with this, it's really annoying!! i love the game :)

  • Neroz.1026Neroz.1026 Member
    edited August 5, 2019

    https://pasteboard.co/IrjFRjd.png

    Everytime i change the camera angle, my GPU usage goes down a lot.

    is it just poor optimalization or is it fixable?

  • Maze.3825Maze.3825 Member ✭✭
    edited August 7, 2019

    OP, I highly doubt it's your CPU. I have what I believe to be the same experience and have a Ryzen cpu + the 5700XT. Hopefully since the it's a very new card AMD drivers will eventually correct it.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.