Guild Wars 2 problem, or a system issue? — Guild Wars 2 Forums

Guild Wars 2 problem, or a system issue?

My problem occurs almost exclusively with Guild Wars 2, but I don't play other games currently so the only times I see issues outside of GW2 they are minor and over quickly. I'm not sure if this is a GW2 exclusive problem, or if it's just highlighting system issues.

Ahem.

While playing GW2 I have a recurring issue that won't go away. I'll be playing and suddenly the sound will cut out and most of the text will disappear in game. I have attached screenshots which demonstrate this. In one of the screenshots you can see that my engineer is in holo form, and yet the holo form graphics are not displaying!
. Another image shows me talking to the NPC Miyani and yet there is no dialog text nor is there text displaying where my mouse if over the pistol 4 skill
. A third screenshot shows a menu with missing text

Often this will occur for 10 to 20 seconds and then fix itself. Sometimes the game freezes for 10-30 seconds.

I've troubleshooted my SSD quite a bit, but nothing has helped and it seems to be functioning normally outside of the freezes. I've read that Windows 10 can have trouble with SSD's but nothing has helped from the list of fixes for that issue. I've done things such as making sure my hard drive is using AHCI mode and checking the SATA ports. Drivers are up to date. I've repaired the GW2 game client. This happens occasionally in Chrome but not as often as in GW2.

My system has a Ryzen 5 1600 processor, Radeon RX 560 graphics card, Gigabyte AX370 Gaming 5 motherboard, and an SSD.

Thanks!

Best Answer

Answers

  • The image with the Holo form glitch didn't seem to display properly, but the other two did.

  • If you want to eliminate the SSD as a potential source, then copy the entire GW2 folder to another drive and run the game from that. If the problems persist, you know there's some other issue; if they go away, you know it's the SSD.

    Before doing that, it's worth repairing the client (instructions on the support website if you search for "repair"). This resolves a number of oddball issues with a variety of symptoms all related to GFX. (That probably isn't enough; it's just an easy step and eliminates some issues without having to worry about the details. In games with huge databases like this, the data file sometimes gets corrupted subfiles, which are replaced by this process.)

    "Face the facts. Then act on them. It's ...the only doctrine I have to offer you, & it's harder than you'd think, because I swear humans seem hardwired to do anything but. Face the facts. Don't pray, don't wish, ...FACE THE FACTS. THEN act." — Quellcrist Falconer

  • I have tried repairing the game client, to no avail. I have Radeon settings as a third party graphics program, I will try disabling that.

    Unfortunately using a different SSD or a separate computer aren't options right now. I'll post my results.

  • Deigh.8401Deigh.8401 Member
    edited August 11, 2019

    Disabling the GW2 profile in Radeon Settings appears to have solved the issue. It's amazing how often the solution is incredibly simple.

    Edit: I was wrong, it didn't fix it.

  • Happy to hear it worked out for you! Happy gaming. :)

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.