Unable to buy Gems in-game — Guild Wars 2 Forums

Unable to buy Gems in-game

Anyone else had trouble buying gems with a credit card from the in-game window? I put in all the information and it just took me back to the start Gem purchase screen. I seen similar problems in the forum in the past but nothing this month. Happened to me and a guild mate today.

Comments

  • same here. I tried with credit card and with PayPal. None is working. I tried another account on my PC and it was working there fine. but no luck with my main account :(

  • You can contact the Billing CS Team via the 'Support' link above/below for assistance.

    Good luck.

  • Same here, it flashes some kind of red message, but I am unable to read it.

  • I had the exact same issue and I was irritated that they wouldn't take my money!
    One ticket to the billing support team and it was fixed the following day! (Which is pretty good considering I put the ticket through on Sunday)

    Hope it works out

  • Got same issue here, submitted the ticket, hopefully it gets resolved before Extra Character Slot sale ends.

  • Can can't buy gems too, I will buy a key online sales are ending soon

  • Having the same issue, already made a ticket. My husband is having the same issue.

  • I made a ticket too and it's being looked into. Sadly I missed the character slot sale and I'm really hoping they resolve before the new anniversary package discount is gone. I also tried to buy Gems again - same issue although I can see there is an error message that flashes up too quickly for me to read. Good luck everyone; let's hope we all get fixed up soon.

  • Update: I tried making a purchase for a different amount (4,000 Gems instead of 8,000 Gems) and it worked. However, I tried the same 4,000 purchase again and it failed. So there is still an issue but I suggest trying a different amount and see if you can get Gems until Anet fixes this.

  • Philcharr.7863Philcharr.7863 Member ✭✭
    edited August 28, 2019

    Same bug.
    a red very smal pop up appears from time to time talking about an "unexpected error".
    Tried with the 2800 gems package several times, with closing and launching again the game.

    I additionally bought an endless cean weapon skin with a Black Lion coupon and did not get it neither in mail or inventory.

  • I have the same problem cannot order gems i made several trys with two different connections two different pcs and it still just flash the red message and goes back to choosing payment.I can make orders on different e-store sites just fine tested.

  • Sometimes it helps if u reset the router.

    [MERC]
    Devona's Rest

  • And, it always helps (one way or the other) if you contact the Billing CS Team.

  • Calistin.6210Calistin.6210 Member ✭✭
    edited August 29, 2019

    Had a problem not long ago and was able to fix it by doing this, pasted this from another thread I mention this in. It may solve the issue for some of you, if not you will need to contact support.

    Bought the unbreakable tools at 50% off then went to buy them for my better half and bam Unfortunately an error has occurred. Please try again later! so I guessed the game doesn't want married couples using the same payment source or something so she tried using her paypal but bam the same error again.

    I did some searching and digging around and found a solution for those with this error that worked for my wife.

    You need to go to c\user\"yourusername"\appdata\local\temp and do a search for gw2cache delete this file and voila gem store purchase worked.

    The file you want to delete should look like this but may have different numbers after gw2cache.

    gw2cache-{xxx9786F-27D6-xxxx-6C78-E9BAxxxxxxx23}

    My wife was able to buy gems via paypal and get the unbreakable tool all without having to wait on support. This should really be something Anet has in tier support section so people can try this before contacting support.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭
    edited August 29, 2019

    It's called 'clearing the GW2 cache', and instructions are found in the Knowledge Base accessed via the 'Support' link above/below and 'Search - Troubleshoot Trading Post' (among others).

  • Calistin.6210Calistin.6210 Member ✭✭
    edited August 29, 2019

    @Inculpatus cedo.9234 said:
    It's called 'clearing the GW2 cache', and instructions are found in the Knowledge Base accessed via the 'Support' link above/below and 'Search - Troubleshoot Trading Post' (among others).

    That's nice but when you go to support/purchase support there's nothing about this which is where this should be otherwise 75% of the people going there will not find it.

    It should be right in here:

    https://help.guildwars2.com/hc/en-us/categories/200110178-Purchase-Support-Payment-Methods-Upgrades-and-Products

    Nor is it mentioned under the "problems when purchasing gems" result when searching for "can't buy gems"..

    https://help.guildwars2.com/hc/en-us/articles/115016021188-Problems-When-Purchasing-Gems

  • TheQuickFox.3826TheQuickFox.3826 Member ✭✭✭✭
    edited August 29, 2019

    If the in-game store has problems for you, try buying gems at 3rd party shops:
    https://www.google.com/search?q=guild+wars+2+gem+card+2000

    You can also use the list of retailers listed by ANet here, but this one is outdated and for my country (The Netherlands), none of the listed retailers have any gem cards for sale.
    https://www.guildwars2.com/en/retailers

    So, I would just use Google.

    Ascalon Will Prevail!

    GW Wiki user page | GW2 Wiki user page

  • Same problem here. Deleting the cache as noted above did not work. I've submitted a ticket.

  • Nash.2681Nash.2681 Member ✭✭✭
    edited August 30, 2019

    1) The issue is present for longer than a year and can happen to anyone out of nowhere
    2) Clearing the cache can help to solve it, but there's no guarantee (for me and my wife it didn't work)
    3) Arena.Net made their stance on that topic clear (can't find the original quote, but I quoted it here before https://en-forum.guildwars2.com/discussion/comment/979799/#Comment_979799 )
    4) summary: either go through the ticket fuzz and beg Arena.Net to take your money, or just vote with your wallet hoping they will start taking customer service more serious in the future

    €: gem store got shut down for maintenance. May be that'll finally fix the issue, we will see...
    €€: nope, didn't change a thing. So still no €€ for arena.net from me and my wife shrug

    XMG U716
    i7-6700 (Desktop version)
    16GB RAM
    Geforce 980m

  • +1 to gem purchase problems. Cleared the cache with no success. I know for certain it's not on my end with the various financial and tech steps I did before submitting a ticket.

    I will add this- Just before attempting to purchase gems, I bought the maguuma pact operation portal device which was on discount.

  • Same issue. I submitted a ticket yesterday, it was read this morning, but it hasn't been fixed and I haven't heard back from them at all.

    They really need to 'up' their customer service. This happens to me once a year at least, and it's beyond irritating. Everybody suggesting 'just submit a ticket', yeah, and miss out on sales/etc. while they take their time to even open it, let alone respond to it.

  • Halbarz.3854Halbarz.3854 Member ✭✭✭

    I have a similar issue, as I suggested in another post they should sell gems through their website (like they do with the game) it would fix most of the issues that we have.
    For some reason in game the payment system just doesn't work while on the website itself I can buy the game without a problem. (same card)

  • i have had the exact problem as everyone else here. I submitted 3 tickets so far and ArenaNet has yet to acknowledge me. I am putting the game down since I feel it is broken.

  • I'm concerned for the financial well being of the game when a once dominant Service Deptartment (ArenaNet) for a video game was immediate and typically to the liking of the customer. I now sense a change in management and that portends problems imo. :-(

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭
    edited September 12, 2019

    When you submit multiple duplicate tickets, you end up back at the end of the queue. Close all duplicates and only update the original.
    If you are not receiving the near-immediate automated response, check your spam/junk folders.
    Due to high volume, CS Team response times are longer than usual.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.