Random lag, but not really lag issue — Guild Wars 2 Forums

Random lag, but not really lag issue

System: Asus Predator G752VT
Graph card: GTX 970m

I recently started playing again, and now everytime after a hour or so I get a LAG SLAP for about 4 min, or a Alt tab and back again, but it's not really Lag. it's a delay between my system and the game, I basicly input commands to dodge or hit a skill button or move my mouse or my character and it takes like 3 a 4 seconds before my character starts doing it, and without ALT Tabbing or waiting 5 min, it keeps doing that, I use a wired mouse and keyboard build in, So I have no clue why this is. and it's kinda annoying dying using a lvl 80 char and getting smacked by a lvl 10 spidey because my character is on drugs or just drunk.....

Comments

  • What are your CPU/GPU temps when this happens?

    "When you power creep the game and make it so that spam gameplay is nearly as effective as deep knowledge and nuance, the quality of players will decrease." -Exedore

  • Normal not hot at all, like i said it doesint take longer then like 5 min, and then it's gone. and after a short while it happens again, in non active zones and realy active zones like lion's arch

  • Zushada.6108Zushada.6108 Member ✭✭✭
    edited September 23, 2019

    I think you are on a Laptop but have you cleaned the fans? I had a ROG laptop and my husband still uses one and we have to clean the fans regularly to keep wonky things from happening. Sometimes I pull the RAM and battery covers off and clean those too. The other idea is if you have a battery installed, remove it and try playing. This will help to see if the laptop is "borrowing" from the battery" e.g. lose plug connection. Also, check the power settings in Windows as it can sometimes try to accomodate for power use when it shouldn't.

    Also if you are on wireless, try wired and if on wired, make sure to refresh the router and flush your dns cache.

  • @Zreaver.1468 said:
    Normal not hot at all, like i said it doesint take longer then like 5 min, and then it's gone. and after a short while it happens again, in non active zones and realy active zones like lion's arch

    Normal isn't a temp. If you want help with this, we need detailed information to rule out possible issues and track down what the problem might be.

    "When you power creep the game and make it so that spam gameplay is nearly as effective as deep knowledge and nuance, the quality of players will decrease." -Exedore

  • so maybe, just maybe after an hour all those loaded models and textures finally fill up your ram and your operating system starts to page stuff? You know, the great performance killer and lag reason formerly known as swap? how much ram do you have?

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.