High latency recently — Guild Wars 2 Forums

High latency recently

Kelso.8279Kelso.8279 Member ✭✭
edited October 14, 2019 in Account & Technical Support

Hello,
last few days I have massive lag spikes appearing by random. Everything literally stops and then "catch up" as ping return to normal, making game unplayable. It starts mostly when more players are around, such as bounties in POF maps. These lags does not concerns only me, but other players complaining about them too. But spikes occurs sometimes even when im just roaming around or attacking a mob.
Nothing wrong on my side, so it is probably a tracing/packet loss problem.
I have never had any lags in GW2, latency was virtually nonexistent.
Other online games runs normally, so problem occurs only in GW.
I hope you will resolve this issue soon, I would like to play this gut game again :)

Best Regards

*ps: I also noticed that textures loads more slowly after login or teleport to another location on map. It lasts around 1-2 seconds until everything loads properly. Idk if these 2 problems has any coherence, but seems to me that both appeared at the same time. Something has certainly changed in game in the last +-3 days that started these lags.

<1

Comments

  • I've also encountered recent lag spikes esp. around reset and during some high-traffic moments such as world boss trains. Everything else showed fine ping-wise, but lately I'll spike up to infrequent 2s+ ping during the affected times.

    Helpdesking rodent hailing from Skrittsylvania.
    Roaming skritt needs caffeine badly.
    Oldschool electronic music enthusiast who also likes Autechre.

  • Kelso.8279Kelso.8279 Member ✭✭
    edited October 14, 2019

    so, looks like this problem befalls only POF maps. In core tyria or HOT maps i had perfect latency without any spikes. Completed entire Dragon stand meta without a hitch (maybe just a coincidence, will test again tomorrow).
    Then ported to Domain of Vabbi and lagged again. Moreover, there was not any players around so it just seems to be random.

  • aceofbass.2163aceofbass.2163 Member ✭✭✭

    Bump.

    Also affecting wvw

  • Jura.2170Jura.2170 Member ✭✭✭

    It's happening with Teq in Sparkfly Fen
    and in wvw
    you press skill buttons, and the skills don't turn on
    or you have to wait a few seconds for them to turn on

    please make a Taimi voice mail pack
    my QoL wishes

  • Bump. It's everywhere in the game. Ping swings wildly from an acceptable 150 to more than 1k. The game is unplayable for me at this rate.

  • Odik.4587Odik.4587 Member ✭✭✭✭

    @slycere.1296 said:
    Bump. It's everywhere in the game. Ping swings wildly from an acceptable 150 to more than 1k. The game is unplayable for me at this rate.

    This clownfiesta with the ping lasts for like nearly a month, unplayble and just given up, problems arrive on their serves judging by the trace, they tell me to run the game at windowed mode....lol

  • TdcTaz.9703TdcTaz.9703 Member
    edited October 23, 2019

    I'm having the same issue - the ping is relative low around 30 but skill input is delayed 2-3 seconds in periode. I'm also on the verge of just giving up on the game :(

  • Jazz.4639Jazz.4639 Member ✭✭✭
    edited October 29, 2019

    i have that too since more than over 1week now (eu). its in all gamemodes but wvw and pve (im mostly at pof maps atm) are the worst. skill delay or not activating skills, animations from targets and positions are wrong/delayed and even freezes over more than1-3 secs with ping spikes over 2k. its unplayable and super unfun when you even die to npcs in wvw sometimes when lag hits you unlucky in a bad moment or when you try to do a legendary bounty and are dead after few seconds complete freeze out. never have a dc, but it is more or less permanetly laggy from little skill delays to several secs freeze every few secs :(

    YT/Tw PvP WvW Power Mes Guides/ Gameplay https://tinyurl.com/njhmjsh
    my neighbours listen to awesome music... whether they want it or not

  • Herkyman.3865Herkyman.3865 Member
    edited October 27, 2019

    Happening in Gendarran Fields also.... The HERO points don't activate, and quest characters do not do what they are supposed to do when you interact with them (sparring for example). I logged of in Gendarran Fields, and when I log back on it puts me in Lion's Arch. Tried it a few times, same thing, from GF to LA.

  • Same here: erratic high ping on any map; mostly, but not always, when map population is higher; sometimes leads to disconnects. For last several days (since 10/22 or 10/23, iirc).
    Connecting from MA, USA to NA servers.

  • Tashigi.3159Tashigi.3159 Member ✭✭✭

    This seems to always happens after the Halloween event is added, I should note. If you pull up threads from last year and the year before, it's the same trend.

  • Jimbru.6014Jimbru.6014 Member ✭✭✭

    I thought at first it was my video drivers due to a coincidental update. But it's not. GW2 is sending my CPU off scale. I am getting single digit FPS in Lion's Arch and much higher ping than usual. This started like two or three days ago. Nothing else is affected; it's something with GW2.

  • been getting it in pvp matches and lobby as well can't really do much, its not my computer its the game it seems

  • I have been experiencing high ping since the patch on the 29th, basically everywhere. My internet is fine, it only happens in GW2.

  • Kelso.8279Kelso.8279 Member ✭✭
    edited October 31, 2019

    After 2 weeks problem still persists. Today lagspikes even in LS4 maps, which was fine before.
    Game is near unplayable on certain maps. On Vanilla maps, problem appears only in mass group events, such as Tequatl. These events was also lag-free in the past, its only issue was crappy FPS. Now it is crappy FPS + lagfiesta... great =)

    PS: nothing is more fun than find oneself downed (or even dead) after 3 second lag-freeze

  • I have been running Windows Resource Monitor on my other screen, and I notice that latency under TCP Connections is not going above 120ms, yet the game client (Options page) might be showing 400, 900, or 2500!! So it seems to confirm that the issue is not related to my local connection.

  • The worst it's ever been for me, was standing on the seething pillar in draconis Mons looking at COM tag and Boss icon swirling around me on the map, while my toon is the only object on screen. All day skill lag, watching all the buttons flash like it's a 3 way in stonemist castle, while a single pocket raptor eats me at it's leisure.

  • Thel.9087Thel.9087 Member
    edited November 4, 2019

    I'm not surprised tbh. And it's always in the EU server, & most frequently on PoF expansion maps when latency doesn't happen in Tyria & HoT maps. FYI I'm on ethernet :)
    https://imgur.com/YkIbtYR
    NA is fine as usual. EU region is unplayable atm. So, despite their resources, they are unable to keep the stability for one region.

  • Same here. Noticing it in wvw fights. Think this happend after last update with the templates. I didn't hadn't had any problems before.

  • I've been having this issue for over a month as well, and I'm at the end of my wits. I don't know what's to blame and it's making me all the more frustrated. My internet seems to be fine outside of GW2 - I don't experience any problems with watching videos, downloading files, etc., but for quite some time now my ping has been spiking at complete random in to the thousands.

    I've heard others experiencing the same, as has been confirmed here and when I made my own thread about the issue a while back, so I assume it's on GW2's end. But because I'm not 100% certain, I'm trying with every fiber of my being to contain my rage. I'm so far beyond the limit of my patience with this I nearly spin kicked my computer not 10 minutes ago.

    I'll give some clarification as to what my issue is despite having already said so several thousand times in the past since this whole ordeal began:

    • Doesn't matter where I am. PvE, PvP, WvW, home instance. It happens anywhere.
    • Skill usage, movement, environment, etc. are not the cause, I'm certain of that.
    • My CPU has enough space to be operating comfortably so it's not my computer reaching it's memory limit.
    • I've cleared my cache, uninstalled and reinstalled, done data rebuilding, file renaming, every trick I can think of. Still having this problem.
    • No problems with any other program outside of GW2. All websites, games, etc. work fine.
    • I've been told it may be packet loss but I've no clue how to resolve that issue if that's the case.

    If this is seriously on ANet's end and not mine, and I find out... I kitten you not they will be getting the angry message of their life time. I've been putting up with this for way too long, asking various people and trying so many different things trying to figure this out with NO HELP from ANet.

    Witchery [YWY] | Maguuma/Anvil Rock | Diamond Legend
    Hate me if it makes you feel better ... ♫

  • Have you tried a program like PingPlotter to see where any connection issues may lay?

  • Dante.1508Dante.1508 Member ✭✭✭

    Same its pretty random but i have had it happen as well.

  • I had the same problem yesterday but in POF launch zones only.

  • Despond.2174Despond.2174 Member ✭✭✭
    edited November 12, 2019

    Currently--well according to 4-5 people who confirmed with me--there are seriously latency issues with OCE, namely on the TPG network. Last 3-4 hours it's just been unplayable. Fine for a bit, spike to 1.8k, hover @ 600ms etc. I was trying to do some HPs with people from OCE and they were all too saying how bad it was.

    At one point I was lagging so bad I was still on a stiff mount while dismounted. It just froze the animation. I am not sure if it's on the ISP end or something else. Restarted my modem, did ping tests on multiple other games and it was fine so it's definitely something amiss between that OCE area and AANET atm.

    Just tried to do pinata event then. It was so laggy I couldn't even tag it. 3k MS, pinata died on my screen about 40 seconds after it actually died on the server. So unplayable.

  • Miatela.5047Miatela.5047 Member ✭✭✭
    edited November 14, 2019

    Really bad connection issues today during PvP. The Skyhammer match I had was basically unplayable with multiple people per team experiencing connection issues, high latency, being disconnected and then spammed with that useless "help" message regarding problems likely being caused by a firewall (eh, no). On top of that, despite managing to come back for the match (even though a teammate was disconnected for the vast majority of the game) I lost rating and received dishonour. Sure is a great system!

    This was on EU servers, connecting from the UK, nothing else impacted at the time of the issues - only Guild Wars 2.

    Someone that I was in the match with grabbed a screenshot of the issues during the game and posted it on reddit. Constantly high latency spikes and frequent disconnects isn't very fun for a mode like sPvP! Not experienced these issues in raids, home instance, fractals or LS3/4 maps but HoT and PoF maps have been really bad recently.

    Edit: LS4 maps now being an issue. LS3 still fine.

  • tbh, the last wek I had the least skill lag ever. Even big action in EBG - usually a lag-fest without any joy, while others were lagging, I had no issues.

    And for the last 30h, people using vodafone could not access amazon, netflix, google etc pp. So.. maybe, just maybe, the lessened load on some important european hubs played a role. I don't know, I enjoyed the no lag experience a lot.

  • Galenthiel.1590Galenthiel.1590 Member
    edited November 19, 2019

    @Kelso.8279 said:
    Hello,
    last few days I have massive lag spikes appearing by random. Everything literally stops and then "catch up" as ping return to normal, making game unplayable. It starts mostly when more players are around, such as bounties in POF maps. These lags does not concerns only me, but other players complaining about them too. But spikes occurs sometimes even when im just roaming around or attacking a mob.
    Nothing wrong on my side, so it is probably a tracing/packet loss problem.
    I have never had any lags in GW2, latency was virtually nonexistent.
    Other online games runs normally, so problem occurs only in GW.
    I hope you will resolve this issue soon, I would like to play this gut game again :)

    Best Regards

    *ps: I also noticed that textures loads more slowly after login or teleport to another location on map. It lasts around 1-2 seconds until everything loads properly. Idk if these 2 problems has any coherence, but seems to me that both appeared at the same time. Something has certainly changed in game in the last +-3 days that started these lags.

    I'm having exactly the same issue. It's unplayable. Every meta event is a lag party for me. When more then 10 players are around my ping randomly skyrockets to 4000. Atm the only temporary fix that i've found is going back to character selection, and after the ping goes back to normal, log in. It's just temporary, because after 5 or less minutes the ping randomly goes way over 500.

    Oh i play on EU server, from Italy. Other games are fine.

  • Junkpile.7439Junkpile.7439 Member ✭✭✭
    edited November 19, 2019

    Weird thing is that ping seems to stay 50 for me, but still i have 2-10 sec skill lag. Not whole time, but like every minute or two. Seems to happen only in PvE. At least didn't notice it in wvw.

    Low quality trolling since launch
    Seafarer's Rest EotM Hero

  • I've been having the same issue for at least the past week. Logged in today after the update and it seemed to have fixed itself... only to return instantly once they did a patch after the update a few hours ago. I am getting super tired of this.

  • Indonesian player here, usually plays on 250 -270 ping, and it is really fine. However, lately my ping jump between 2k to 500, already contacted my ISP and they said my connection is fine. I can even stream HD without buffering (for a third rate country it is a good sign).

  • Still having the same problem after the update. Ran other games and they ran fine so I guess it's not on my end.

  • The game servers have been shockingly bad now for weeks, im not sure if Anet is even tracking it, as they never seem to respond to these topics,

    The Trading Post is also bad, today i couldnt use it at all, it just wouldnt load anything, then after 10 minutes it popped up saying, cannot connect to the login servers.

    Don't say what you mean, it will get you in trouble.

  • Hesione.9412Hesione.9412 Member ✭✭✭

    I popped on to see if there was a thread about this, and here it is. My partner and I got huge latency spikes today, it made the game unplayable at one point and still very annoying at other times. We were doing map completion in Elon Riverlands, and off by ourselves. The map did not appear to be hugely populated - there was no HP or bounty train, not that many people did a Deadhouse event or the Augury Rock event. Perhaps the largest number turned up for a bounty, which we ended up helping, and strangely no lagfest then.
    I didn't notice any lag ping info - allegedly my ping dropped to 17 at the times of the spikes, whereas normally I play with 230-260 ping. This is the first day I've noticed it, and it's the second day we've been playing on PoF maps - getting his mounts, one by one.
    There isn't a pattern to it, that I can see. The first occurred on the HP at the far south west of the map - the commune with the ghost jumudi, where we got downed by the djinn there because we couldn't fight it due to the lag. Another lag event occurred when we were fighting branded at the far east of the map, for that heart.

  • thepenmonster.3621thepenmonster.3621 Member ✭✭✭
    edited November 22, 2019

    Did a bunch of i.p. and traceroute magic and all of my lag problems begin in America. Maybe all of yours does as well?

    And while US internet is generally awful the huge lag comes consistently from a couple of IP address owned by a mysterious organization called

    ... squinting...

    "Amazon Technologies Inc".

    They've really been kitten the bed recently.

    People play games on their phones now. Figure it out.

  • Yeah, it's not that I don't lag at all or my ping is that great (usually around 160~200) but since new TIS chapter, I've lagging and dc'ing a lot. Today morning the lag was so bad that gathering a Volatile Magic orb only granted the expected XP after a few seconds, making me always turn around to check if I didn't miss an orb by accident.

    Keriayn‌‌ | Asura | Necromancer
    Raven Evergloam | Human | Mesmer
    Astrid Bloodbourne | Norn | Guardian
    Pallu'Kaziel | Sylvari | Ranger
    Johanna Mordkönige | Human | Warrior

  • Aenaos.8160Aenaos.8160 Member ✭✭✭

    Third day in a row, serious server lag issues in The Desolation.

  • Yesterday most POF and some LS4 maps were lagging like there is no tomorrow. :s
    During serpent ire meta we had several seconds long lag-freezes, which is more than enough to break the game. Everybody complained about them so there is definitely some serious issue on GW side or tracking route.
    Im playing from middle Europe.
    Im just wondering why Aned did not solved this issue yet. Since early October most Path of Fire maps are unplayable in certain times.

  • I experienced it in fractals as well, managed to glitch into a dark area. It is only happening since about a day ago after I started icebrood story but didn't finish it. I have 3 screenshots to show it happening, if someone wants them, I can post them.

  • Same issue as everyone else. Lag like crazy. I notice is mostly in WvW because that's where I spend most of my time. Ping spikes between 2.5k ms to 4k ms at times. Average ping times lately have been around 900 ms. My issues started sometime around the beginning of October, I think. I've done everything I could think of to troubleshoot the issue from my end, but to no avail. My connection is fine for every other MMO I play, for streaming videos, etc. No issues anywhere else. Just with GW2. I thought it was the router at the place I was living in October, but I recently moved and I'm still getting the lag and ping spikes at my new place, even with a new, better router and wifi card. Hoping someone finds a solution for this soon. I can't take much more of the skill lag/rubber banding/disconnects.

  • Since the update, in Tokyo I am getting 3000-4000 ping near blobs in wvw, 1200 near zergs- until the update this was at most 350 ping. I have tried repairing client, deleting gw2 temp file, wtfast, restarting modem, checking firmware, etc. Please help.

  • Dante.1508Dante.1508 Member ✭✭✭

    My ping in game has jumped to 800 from 300ms not sure why i'm on Win 7.

  • Second day in the row, my ping reaches 2k out of nowhere in PVP ranked. Full restart of the router didn't help. Had the same issues in the LS4 maps and POF map. But the most annoying thing is when it happens in the middle of the match and you just suddenly drop dead. Never had any issues before (EU server).

  • Yesterday I had latency problems in Dragons Stance map (HoT). I noticed a lot of people having problems. When I logged out of to Character screen and then logged back in to the map, the majority of the people probably did the same cause the map was empty (only the commander was still there so I knew this was the same world instance).
    Ping rose over 9000 (no pun intended). I also had problems in Rata Sum, where ping went up to 800+

  • Same here for the past several weeks now. Some days everything is fine, other days I'm constantly having huge ping spikes and fps drops for no reason at all. It's there for a couple of seconds, then disappears for a minute or two and then there's another spike and the cycle goes on and on. Rebooting doesn't change anything, it just seems to be either a good day or a bad day and nothing to do about it which is incredibly frustrating.. Same thing for my entire fixed fract party (and we're not necessarily having it on the same days, one day one of us has it, the next day two other ones have it.. ) All of us can run anything else just fine but only having problems with gw2 so I doubt it's on our end.

  • Same problem. Massive lag spikes, disconnects from chatserver, gemstore not loading, skills not reacting...

    Srsly whats going on? Had this problem the last few days and it's getting much worse! Unplayable at this state! And no reaction from devs so far...

  • Zaklex.6308Zaklex.6308 Member ✭✭✭✭

    @Kirigaya Kazuto.8547 said:
    Same problem. Massive lag spikes, disconnects from chatserver, gemstore not loading, skills not reacting...

    Srsly whats going on? Had this problem the last few days and it's getting much worse! Unplayable at this state! And no reaction from devs so far...

    Because it's the internet and not the game, that's why, it's almost always the internet that causes these issues, either something with the way it's routed or something the ISP has changed.

    Yes...no...maybe...what do you want, can't you see I'm busy saving the world...AGAIN!

  • I got the exact same problem. Lag spikes, disconnects a ping that goes above 4k.
    Using trace route my connection dies at 150.222.104.40 which is an Amazon Server.

  • Kelso.8279Kelso.8279 Member ✭✭
    edited December 15, 2019

    now even core Tyria maps lagging :( Had the same lagspikes/rubberbanding like in HOT/LS4 during Blazeridge steppes Shatterer and Gendarran leg. anomaly events, I once even disconnected.
    Daily LS4 map Sandswept Isles unplayable.
    II tracked problem to Amazon and Liberty Global servers, which both has 100 percent packet loss during lagspikes.
    Plese fix your servers, im boycotting any gem-purchases until Im able to play this game normally.

    Best Regards

  • Neara.7901Neara.7901 Member
    edited December 15, 2019

    Bump. Same here (EU). Today it got so bad I can connect, log in, have a decent ping for 5-10 minutes and then suddenly hit 3000ms and get disconnected from the server.

    Traceroute drops at some point at an Amazon AWS server and never recovers.

  • Same here, since Saturday 21:00 very bad connection to the server suddently form germany to the frankfurt servers.
    The state is currently unplplayeable, moving a Item in the inventory thaks 10 sek +, and so on....

    I ran tracert on a game server:
    tracert 18.185.197.21

    Routenverfolgung zu ec2-18-185-197-21.eu-central-1.compute.amazonaws.com [18.185.197.21]
    über maximal 30 Hops:

    1 <1 ms <1 ms <1 ms fritz.box [192.168.178.1]
    2 5 ms 4 ms 4 ms 62.155.242.44
    3 6 ms 5 ms 5 ms m-ef1-i.M.DE.NET.DTAG.DE [217.5.69.26]
    4 6 ms 5 ms 6 ms 80.157.128.94
    5 7 ms 10 ms 11 ms 52.93.41.26
    6 6 ms 6 ms 6 ms 52.93.41.35
    7 44 ms * 41 ms 52.93.128.139
    8 * * * Zeitüberschreitung der Anforderung.
    9 * 42 ms 41 ms 54.239.107.64
    10 * 43 ms 39 ms 52.93.111.134
    11 36 ms 35 ms 35 ms 52.93.111.133
    12 * 41 ms 44 ms 54.239.107.49
    13 36 ms 38 ms 37 ms 54.239.5.170
    14 * * * Zeitüberschreitung der Anforderung. = Timeout
    15 * * * Zeitüberschreitung der Anforderung. = Timeout
    16 * * * Zeitüberschreitung der Anforderung. = Timeout
    17 * * * Zeitüberschreitung der Anforderung. = Timeout
    18 * * * Zeitüberschreitung der Anforderung. = Timeout
    19 * * * Zeitüberschreitung der Anforderung. = Timeout
    20 * * * Zeitüberschreitung der Anforderung. = Timeout
    21 * * * Zeitüberschreitung der Anforderung. = Timeout
    22 * * * Zeitüberschreitung der Anforderung. = Timeout
    23 * * * Zeitüberschreitung der Anforderung. = Timeout
    24 * * * Zeitüberschreitung der Anforderung. = Timeout
    25 * * * Zeitüberschreitung der Anforderung. = Timeout
    26 * * * Zeitüberschreitung der Anforderung. = Timeout
    27 * * * Zeitüberschreitung der Anforderung. = Timeout
    28 * * * Zeitüberschreitung der Anforderung. = Timeout
    29 * * * Zeitüberschreitung der Anforderung. = Timeout
    30 * * * Zeitüberschreitung der Anforderung. = Timeout

    Ablaufverfolgung beendet.