Roll into Madness, help!!! — Guild Wars 2 Forums

Roll into Madness, help!!!

I can't figure this out at all. I am doing everything I find on how you are supposed to drift but it doesn't matter what keys I press, when and how I turn the camera as I press them the beetle just goes wacky crazy fast and shoots way off course every time i used the speed boost. I have watched videos that visually show me what it is supposed to look like. But what is happening with me is as if that functionality is disabled and all I am allowed to do is the boost part. This is so extremely frustrating because, as far as I can figure, it is impossible to get gold without it and you need gold for several achievements. Thanks.

Comments

  • thehipone.6812thehipone.6812 Member ✭✭✭

    You can't really steer well with the boost going, so you need to use in the right places. Where you see an orb on the ground you can usually assume that it is safe to use the boost at the orb or very shortly after.

  • There should be a mount movement skill 2 in your controls settings. Most mounts don't need it, but the beetle, griffon, and skyscale do. I'm not sure what the default is, but you should program it as something comfortable to you. This particular beetle race is a rough one to be getting started on because the field has a ton of little bumps in it, raising you into the air for split seconds over and over. You can't start drifting while you're in the air, so that makes some annoying problems. I finally got gold by button mashing my drift key until it would actually start in several of the tight turns.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited October 25, 2019

    @Jia Shen.4217 said:
    I can't figure this out at all. I am doing everything I find on how you are supposed to drift but it doesn't matter what keys I press, when and how I turn the camera as I press them the beetle just goes wacky crazy fast and shoots way off course every time i used the speed boost.

    You need to press the Drift key/button for just a second or two, depending on the situation, because the longer you press it the longer you keep sliding. Also, the camera angle needs to change rapidly, it's not enough to just make a slight turn.

  • starlinvf.1358starlinvf.1358 Member ✭✭✭✭

    Having racing music helps too..... Some suggestions:

    and of course......

  • starlinvf.1358starlinvf.1358 Member ✭✭✭✭

    Bonus music because youtube reads my mind.....

  • Jia Shen.4217Jia Shen.4217 Member ✭✭
    edited October 26, 2019

    @thehipone.6812 said:
    You can't really steer well with the boost going, so you need to use in the right places. Where you see an orb on the ground you can usually assume that it is safe to use the boost at the orb or very shortly after.

    By only using the boost at or within a couple seconds of the orbs the time has improved to silver but still gold seems out of reach because I'm still not getting any control hardly at all with drift. Especially if used at/after a couple of the recharge orbs. Though continued after next quote.

    @Aaron Forestman.4758 said:
    I finally got gold by button mashing my drift key until it would actually start in several of the tight turns.

    Button mashing doesn't seem to be working. If I stop holding move forward it slows down a little bit so it's not as crazy but if I stop holding move forward too long the beetle stops completely even if it seems like there is still boost left. The problem I seem to be having is that even though the camera is almost a complete 180 from the direction I'm traveling even with mashing the drift button i end up running wild off course. The spots it happens in doesn't seem to be any different to me than any other.

    Note watching a video on this course shows the player able to speed up and slow down like a race car perfectly controlled acceleration and deceleration so that the whole time they are chugging along at a pace that seems to exceed the pace of the raptor. And only using the boost 2 or 3 times. But if I don't use the boost it's like I toggled walk/run key to walk. And that is also the pace I end up after the couple times I randomly get lucky and the beetle turns and slows correctly. But my impression of this course is that there is absolutely no margin of error and gold requires a flawless bot like execution. What else do I need to do? Thanks.

  • After trying different tips from here and elsewhere I finally came to discover what the problem was. For some reason Disable Conditional Mount Movement Ability Input was making it so drifting wasn't working at all. Resulting in my experiences described above and the setting had to be turned off contrary to all the tips and guides I found to correct the cause of the problem. But what really worked is a tip I found only after discovering a video by AyinMainden in which it was stated that you need to use A+S and D+S in combination with the mouse to maintain control of the beetle. And was the key to actually succeeding at gold. I don't know why none of the other tips and guides i found didn't have this info. In fact there must have been a dozen or more I looked at prior to this thread and after in search of success. But once I had this combination of controls knowledge it was only a matter of repeatedly running it to get the turns after boost right. And was far less frustrating in than my experience from lacking the info revealed the problem. Hopefully this info will be helpful to others who have this problem in the future.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.