[Self-Solved?] GW2 can not access the .dat file — Guild Wars 2 Forums

[Self-Solved?] GW2 can not access the .dat file

I ran the program and it started a small pre-launch update. Then it halted right there after applying a small pre-launch update at the pre-launch update screen. It said something to the effect of "GW2 can not access its archive file .dat. Please confirm that the file can be read and written. Closing that popup window showed the pre-launch updater saying to check my internet connection (4) or something. After resetting my computer and finding no change, I moved the .dat file to the desktop. The application then downloaded files via the pre-launcher and is now downloading files from the login screen proper. I am assuming this means the problem has corrected itself and am posting this here for developer review and as a potential solution for others with the same problem.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.