Cannot play the game — Guild Wars 2 Forums

Cannot play the game

Hi there,

I'm just coming back to the game after 1+ year being away.

I installed updates, entered my account details, but when I press the PLAY button on the client, the game doesn't load. The GW2 game icon opens in my Windows bar, and then closes after 2 seconds.

I've even just tried reinstalling the whole game from scratch, with the same results. I've just updated my card video drivers too in case it was that, but nothing.

Anyone else experienced this? I'm all out of ideas...

Southern Lord

Comments

  • Healix.5819Healix.5819 Member ✭✭✭✭

    Launch the game using the -windowed option, then set your desired resolution within the game.

    It can also be caused by overlays (such as MSI/RivaTuner, Mumble and Discord) or mods (placed in GW2's bin folder).

  • @Healix.5819 said:
    It can also be caused by overlays (such as RivaTuner).

    You are a star anon. Appreciate it. Just closed RivaTuner down and it worked first time. Appreciate it.