My game has no sound, possibly driver related issue — Guild Wars 2 Forums

My game has no sound, possibly driver related issue

So a couple of months ago I had an issue with some headphones that basically caused them to constantly connect and disconnect from my PC, I got sick of it so I ended up deleting an Audio driver and that pretty much solved the problem except for the fact that GW2 now no longer has any sound from the audio device Im using (some other applications also have this issue). The audio from the game does work if I switch it over to the monitors speakers. The driver was a realtek one, ive tried to find it on the internet but their website is pretty unfriendly for users. Would really appreciate any help or input for the issue, thank you very much.

Comments

  • Your computer manufacturer's site should have realtek audio drivers.

  • @Inculpatus cedo.9234 said:
    Your computer manufacturer's site should have realtek audio drivers.

    That would be my motherboard manufacturer right? So that would be MSi, Ill check it out and see if it fixes things.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited November 14, 2019

    https://www.ccleaner.com/speccy --> will tell you the exact name and model of your motherboard (and other hardware)

    Once you know the model, you can visit its download page and install all the available drivers, including that of your soundcard.

    If you don't want to use two soundcards (your motherboard's and that of your headset's USB adapter), you can always plug the headset directly to your soundcard. Make sure to adjust the volume so it won't blow your eardrums. ;) When you do so, you won't require the installation of additional drivers (for your headset), so make sure to uninstall those first.