API KEY ERROR — Guild Wars 2 Forums

API KEY ERROR

There is some time i'm trying to use the ApiKeys on different platforms, apps, sites, but no one is working, every time, every site and app can't see my account data... Why!? Can someone help me please!? I also talk with gw2 staff support and they told me is working... For them -_-"
Apologize if i'm in the wrong section of topics...

Comments

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    Can you give an example of a website or two where you fail to make use of your API key?

    (P.S. Have you tried generating a new key and use that one instead?)

  • Healix.5819Healix.5819 Member ✭✭✭✭

    You have to set what a key will give access to when creating it. You can test your key and see what permissions it has by using it like this:

    https://api.guildwars2.com/v2/tokeninfo?access_token=your key

    For basic account information, you can use:

    https://api.guildwars2.com/v2/account?access_token=your key

    If your key works like this, but not on a website, it's possible that the site is either outdated or your browser is blocking it due to a security or privacy setting.

  • I tried to use different API Keys on sites like: gw2efficency, AddOn TacO, mobile applications, both from computer and from mobile, but it always fails. Gw2 efficency and not only tells me: This API key is invalid, has corrupted API data or the API is down.
    Error reported by the API: "ErrBadData"

    I looked for the permissions of my api key on the link you post and tells me:
    {
    "id": "xxxxMY APYKEYxxxxx",
    "name": "Gw2efficency",
    "permissions": [
    "progression",
    "wallet",
    "tradingpost",
    "builds",
    "account",
    "characters",
    "inventories",
    "unlocks",
    "pvp"
    ]
    }

  • Healix.5819Healix.5819 Member ✭✭✭✭

    @Mihai.3842 said:
    Error reported by the API: "ErrBadData"

    That's a problem with the API itself. In short, it's bugged. You could retry support, giving them a specific link to the section of the API that reports this error, or you could post it in the API forum section. If you haven't already, try creating a few new keys to see if any of them will work.