[BUG] Drawn weapons invisible in hand (when hidden in equipment) — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

[BUG] Drawn weapons invisible in hand (when hidden in equipment)

Ashantara.8731Ashantara.8731 Member ✭✭✭✭
edited December 7, 2019 in Bugs: Game, Forum, Website

When you hide weapons in your equipment loadout, they also become invisible while drawn when you switch weapon sets. This means you are fighting "with bare hands."

Please fix!

Comments

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    This is still a big issue, so I hope someone is already working on a fix? (It looks silly to fight with no weapons in hand...)

  • Krypto.2069Krypto.2069 Member ✭✭✭

    Another Bug with Shield, Back-piece and Mounts:

    1) Set your Shield to Hide
    2) Swing your weapons (unsheathe/draw by hitting the "1" button)
    3) Get on your mount while weapons are drawn

    Your SHIELD will NOW be VISIBLE on your back while mounted... but it shouldn't be :wink:

    4) Get off of your mount

    Nothing is now on your back :astonished: -- not your shield or your back-piece. :-1:

    NOTE 1: unsheathed/drawn weapons are not adhering to the Hide option if you mount up when your weapons are drawn. This seems to be happening to all weapons. (I just noticed and tested it with my shield first because shields have always been problematic with the back piece hocus-pocus. :lol:)

    NOTE 2: the problem seems to be that when mounting up, our weapons are not triggering the "sheathed" state; therefore, they're visible when the toon is mounted if the weapons were not sheathed before mounting.

    Anet,

    Please test and fix the above. Thank you. :+1:

    Moonlight [THRU]

  • GamerOnline.3650GamerOnline.3650 Member ✭✭
    edited December 10, 2019

    I too have been noticing some shenanigans with weapon visibility. I also will mention that I'm in the general habit of sheathing my weapons manually before riding so haven't noticed the riding bug. But then I just started experimenting with these settings a few hours ago.

    I've set all of my weapon slots to invisible (those that currently hold weapons, great sword and rifle). When my target runs away, I can switch to shoot them in the back with my invisible rifle. It looks like I'm miming the shooting.

    Ok...after saying this, I'm deliberately trying to trigger this and the game isn't cooperating. It seems to be working.

    Aha!! When I switch to my mace and shield ( 2, 1-handed), the bug manifests when I switch to my rifle (1, 2-handed) while in combat. That was the behavior I first noticed. So, posting this as is. :)

    Farm responsibly, for you are not alone. Share the love, not the hate.
    Support your local environmentally friendly farmers.
    Asuran Mesmer Mind Tricks: These are not the golems you are looking for.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    Let's hope for a bug fix today (Tuesday) or next week (Wintersday patch) the least.

  • This has still not been fixed, almost 3 months now...

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @Marckan.9526 said:
    This has still not been fixed, almost 3 months now...

    Shame. Not surprising, though.

  • reapex.8546reapex.8546 Member ✭✭✭

    @Ashantara.8731 said:

    @Marckan.9526 said:
    This has still not been fixed, almost 3 months now...

    Shame. Not surprising, though.

    Yeah, a visual glitch like this probably isn't high priority as the game breaking bugs they're addressing.

  • Stiiiiill waiting...