Crashes after Wintersday Update — Guild Wars 2 Forums

Crashes after Wintersday Update

johncvalle.7053johncvalle.7053 Member
edited December 17, 2019 in Account & Technical Support

On Mac OS X 10.14.6

After Wintersday updated, I am unable to play the game without crashing in a few seconds after loading into the game. I can move around for roughly 5 seconds then "a serious error has occurred" window pops up.

I tried repairing game data and that crashes as well with the same error.

I even reinstalled the game, same crash.

I'm in Mount Maelstrom. I know someone else here was crashing out in Divinity’s Reach.

Error message attached:

https://imgur.com/Ok1CrZ7

Comments

  • On Mac OS 10.15.2
    WvW HUGE lag then crash...8 times. Tried all the usual fixes but nothing works. Same error message as above.

  • Having the same problem. After the patch I can play for a short time, then it crashes. Now i've finished isntalling the full patch, its lasts about 5 seconds while in game.
    Mac OS MOjwave

  • Having the same problem too... Just after the Wintersday patch, the game crash everywhere, sometimes few seconds or few minutes. I am with Macos Sierra 10.12.6, and I never had this problem before. g
    Give us a solution please

  • I crashed upon startup, and got an error message that GW2 detected a problem upon closing during the last time I played. It was suggested I let the program fix itself, but, when I clicked to do that, it hung, and stopped responding. I am using a PC running Windows.

  • Same problem here. Since Wintersday update I crash regularly and for no obvious reasons. Sometimes the game runs for 30 minutes before the next crash, and then again I am unable to even log in. Running on Mac version Mojave 10.14.6 and everything was running smooth before the Wintersday update.

  • LYNX.7802LYNX.7802 Member
    edited December 20, 2019

    same thing happen to me too
    https://imgur.com/Z5vrxED

  • sorry for double post but i just somehow fix mine
    so here's what i do
    since turning off firewall &anti vir won't fix it so i just start to delete all guild wars 2 related folder including the on in appdata and even the one in quick access / recent
    and somehow the launcher works again

  • the same happened to me just before few minutes ago, I am using a PC running Windows(Version 1903).
    I only tried to delete the folder of Guild Wars 2 in appdata as @LYNX.7802 suggested at first it was still crashing but now it's not I tried switching characters a few times and there is no serious error.

  • wvw crashing to

  • Same here keeps crashing after Wintersday update on Mac OS 10.15.2.

  • I'm crashing as well. I've been in contact with tech support, who has me doing all kinds of things, but the results don't change. I've played for a year with relatively no problems. Patch day, and everything crashes on my Mac.

  • I've been having the same problems. Since the error messages in the log mentioned missing textures I changed my texture, shader and character model settings from high to medium and just made it through the first POF chapter. I couldn't get through the first fight without a crash before. Don't know if they patched it, changing the textures got around the problem or I just got very lucky, but if you are still having issues try changing those settings.

  • Same here I just tried to play for a bit just now and everything worked but it was only for about 5 min or so. Crashed during TT2 times and COJ :( by by all my XP boosters

  • I'm having a hard time with the fact that tech support wants all of us to 'do these steps'. It's only been since Wintersday patch, so it's not like it's an ongoing issue. And seeing the number of replies here, it's obvious it's not our equipment. This is so frustrating. I crashed three times today trying to do the bounty, then another six trying to get my human quest story moving for Monday's key.

    How bad is it? I actually started playing SIMS 4 for something to do.

  • yozora.1652yozora.1652 Member
    edited December 22, 2019

    (Also Mac OS X 10.14.6) I've been experiencing the same issues since 17 December as well – at first it would crash with no warning at random times, giving me the 'serious error' message. I've been in contact with support since the day after, and it's only gotten worse since. I've tried everything they suggested, rather oddly unrelated to the actual problem, which is the Wintersday download. Even deleted all GW2 files and app and reinstalled – now it crashes immediately upon opening, whether that's during the Divinity's Reach loading page or after approximately 3 seconds in Amnoon. The core reason for this crash is pretty obvious, considering I've never had anything like this before Wintersday, and the crashes started right after. It's pretty unhelpful to have the support team respond around once per day with the most basic things that have already been checked and double checked. The game is 100% unplayable now, and all I want at this point is an estimate on when there will be a fix available...

  • Vegeta.2563Vegeta.2563 Member ✭✭✭

    Unfortunately the basic window doesn't say much, but the "Show Details" button would.

  • Yep, I'm having the same exact issue on my Mac (with most recent software updates) although I can't tell if it's from the Wintersday event given I literally just came back to the game yesterday from 4 month long hiatus. At first the crashes were happening every 20-30 minutes or so but now it just crashes at the load screen. Tried everything to get it working, no luck...

  • kathy.8291kathy.8291 Member ✭✭✭

    Im having that same problem.. Since Wintersday patch. my ping has been up to 4,000 (which IN 6 + years playing this game) NEVER happened. Ive also got the Your firewall error going to Character Screen pops up. No Firewall, Nothing happening in the background, it was the New Patch that is killing all of us. Hopefully When Wintersday ends all this Error, and high ping will end

  • Does anyone know if it works better now after Wintersday ended? I'm not keen on trying and getting annoyed again.

  • Yes a lot of crashes also here but also after the winterday was turned off or better I'm not sure I did only dailies during the winterdays so it can be also before that..

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭
    edited January 11, 2020

    The Devs posted about the Mac crashing issue. You can find it on the Carousel, still, I believe.

    https://en-forum.guildwars2.com/discussion/comment/1131543#Comment_1131543

  • Fueki.4753Fueki.4753 Member ✭✭✭✭

    Today I had two crashes.
    Once in PvP RIGHT when the enemy team had their last tick for the win.
    Another shortly before reaching the end of the Loreclaw Expanse Jump Puzzle (which also is a daily).

    I wonder if the recent crashes are related to the daily/achievement system.
    I'm using Windows 10, not a Mac.