(Mac OS 10.15.2) Crashing since Wintersday Update & can't reinstall) — Guild Wars 2 Forums

(Mac OS 10.15.2) Crashing since Wintersday Update & can't reinstall)

Wolf.2596Wolf.2596 Member ✭✭
edited December 23, 2019 in Account & Technical Support

I've sent in reports and done everything support (who regardless how many people have this same issue) seems convinced it has to be a system issue on my end. I've even tried a clean reinstall of the game but the Mac 64 Download won't install at all now either. The download locks up at 35% and won't proceed any further. I know it isn't a connection issue on my end, because I'm not having problems doing anything else. All my other games not to mention streaming are working fine. I even did a speed test on my connection and that isn't the problem here. I'm about ready give up trying.

Comments

  • Lord Warfin.1209Lord Warfin.1209 Member ✭✭
    edited December 23, 2019

    It's not your system. There are apparently missing or corrupted high quality textures in the Wintersday update for Mac. Try changing your graphics settings to medium, assuming you can get it to reinstall. I changed my texture quality, shader and character model from high to medium and that fixed the crashes.

  • Wolf.2596Wolf.2596 Member ✭✭
    edited December 29, 2019

    I gave up and tried reinstalling after the game went completely non-functional. Unfortunately, I am now one of those people that can't get the download past 35% trying to reinstall. The workarounds people have posted so far will only work for windows, so won't do a Mac user like me a whole lot of good.

  • I have the same problem. I've been playing GW2 just fine for over a year on a 2017 MacBook Pro, and just since the Wintersday update has the game refused to move past a zone loading screen.