Character select screen unresponsive - AMD 19.12.2 — Guild Wars 2 Forums

Character select screen unresponsive - AMD 19.12.2

I just updated to the new AMD 19.12.2, RX 590 8GB GPU - 2600X CPU, no overclocking.
Now when I log in, the character select screen is unresponsive. I can hit Enter and select the last played character, but to select a different one, I have to ALT+Tab then select the character, at which point the screen becomes unresponsive again.

Any thoughts?

Wolf Moonstar
Dragon Council, Third Seat: Jade Sea Haven (Jade) of Ehmry Bay
My Ryzen Rig

Comments

  • Healix.5819Healix.5819 Member ✭✭✭✭

    This is generally caused by an overlay, which sits on top of GW2's window and intercepts your mouse input. Discord for example has been a common cause of this problem.

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @Healix.5819 said:
    This is generally caused by an overlay, which sits on top of GW2's window and intercepts your mouse input. Discord for example has been a common cause of this problem.

    This. :+1: There is no other logical explanation. Simply deactivate the Discord overlay in the settings.

  • @Ashantara.8731 said:

    @Healix.5819 said:
    This is generally caused by an overlay, which sits on top of GW2's window and intercepts your mouse input. Discord for example has been a common cause of this problem.

    This. :+1: There is no other logical explanation. Simply deactivate the Discord overlay in the settings.

    Thank you both. I know they added a stream overlay into the drivers. I will look to see how to disable it. AMD seems to always take one step forward then two back when they revamp the driver packs.

    Wolf Moonstar
    Dragon Council, Third Seat: Jade Sea Haven (Jade) of Ehmry Bay
    My Ryzen Rig

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @moonstarmac.4603 said:
    I know they added a stream overlay into the drivers. I will look to see how to disable it. AMD seems to always take one step forward then two back when they revamp the driver packs.

    Oh, so it was an overlay from AMD's software, not Discord? Well, glad you figured it out. :)

  • @Ashantara.8731 said:

    @moonstarmac.4603 said:
    I know they added a stream overlay into the drivers. I will look to see how to disable it. AMD seems to always take one step forward then two back when they revamp the driver packs.

    Oh, so it was an overlay from AMD's software, not Discord? Well, glad you figured it out. :)

    I disabled the stream overlay, but the AMD - Press ALT+R for Radeon Settings overlay popup still comes up. Can't figure out how to change this yet. Only happens in MechWarrior 5 and Guild Wars 2, don't see it in Fallout 76 or other games.

    Wolf Moonstar
    Dragon Council, Third Seat: Jade Sea Haven (Jade) of Ehmry Bay
    My Ryzen Rig

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭
    edited December 30, 2019

    Go into the Hotkey settings, select to change the Alt+R hotkey and press Del when you are asked to assign a new one.

    Link: https://community.amd.com/thread/225466

  • @Ashantara.8731 said:
    Go into the Hotkey settings, select to change the Alt+R hotkey and press Del when you are asked to assign a new one.

    Link: https://community.amd.com/thread/225466

    I just noticed they released the 19.12.3, which fixes this. I will run the update tonight. The issue is that with the x.2, even when turning all overlays off the "toast screen" which is that 'Press ALT+R to open Radeon Settings' still came up. x.3 corrects this along with other issues I have seen in other Windowed-Full games. It also fixes the issues I've seen in MW5.

    Wolf Moonstar
    Dragon Council, Third Seat: Jade Sea Haven (Jade) of Ehmry Bay
    My Ryzen Rig