Administrator and Mouse 4/Mouse 5? — Guild Wars 2 Forums
Home

Administrator and Mouse 4/Mouse 5?

So, like many, many other people on here, I was having lots of issues since the Wintersday patch. I won't go into the details, but eventually I scraped together a full reinstall, adjusted some other settings, and got it to where i don't seem to be crashing upon pulling up a loading screen (fingers crossed) when I run the game as Administrator in WIndows 10.

However, I noticed something odd I had not expected: when running under Administrator: my Mouse 4 (forward) and Mouse 5 (back) buttons are not being recognized by GW2. Mouse 3 still works fine, and I can still see in my custom keybinding for them both m4 nd m5 are still showing them as valid choices that I had set them to previously under Options for the game, but GW2 doesn't seem to be recognizing them anymore as valid keypresses/mouseclicks anymore.

On a hunch, I tried playing the game withough running as Adminsitrator, and they are recognziing those two mouse buttons just fine again (but I dare not run without being Administrator, lest it start crashing on me again).

So, any ideas why it is ignoring those two mouse buttons when running as Adminstrator? I use them quite a lot in-game, and while GW2 is swiftly approaching the 'too many problems to bother playing anymore,' it's not quite there yet.

Comments

  • godofcows.2451godofcows.2451 Member ✭✭✭

    Just a wild guess on your situation. If your mouse is using any kind of software to recognize those buttons, or a macro program which is common on current and modern gaming mice, or any service of any kind at all that is connected to it, it might have to be elevated to administrator too. I do the same on my yolomouse.

  • Healix.5819Healix.5819 Member ✭✭✭✭

    When you start a program as an administrator, regular programs cannot interact with it. You'll need to configure the software your mouse uses to also run as an administrator. Alternatively, there is no need to run GW2 as an administrator. It should only want it if it's under the Program Files folder, so you can simply move the GW2 folder somewhere else, such as C:\Games\Guild Wars 2. You could also give regular users full control of the GW2 folder instead.