Downloading GW2 Files Remaining stuck at 49,100? (edit found solution) — Guild Wars 2 Forums
Home

Downloading GW2 Files Remaining stuck at 49,100? (edit found solution)

Ordin.8341Ordin.8341 Member ✭✭
edited January 21, 2020 in Account & Technical Support

so download was going well and at decent speed about ~10 MB/s until it hit 49,100 files remaining since then counter is stuck at that value while data downloaded still goes up but at slower rate about 2-3MB/s , it went up by about 4GB since it hit 49,100 and total data downloaded so far is 45,225MB (not sure how much total of whole game should be) but file-count and progress-bar didn't move at all is it normal for file count and progress bar to be stuck for long? are remaining files just that massive?

Comments

  • You can read about some possible solutions in any of the other threads concerning this issue.

    Good luck.

  • Ordin.8341Ordin.8341 Member ✭✭
    edited January 21, 2020

    huh I run it with -log and it seems it can't download certain file I tries to re download it over and over so that's why MB downloaded goes up while file-count remains the same I'll found some similar topics and will try different things man I already wasted 2 days and it wasn't progressing at all :(

    I found working fix using VPN and switching to US helped but I had to use US server when I tried other European servers for VPN I was getting same issue so I guess the issue is somewhere in European asset servers? (I'm from Poland I tried Czech and German VPN servers and had the issue)

    maybe this will help some other users if you don't have VPN try asset-server from different region will than yours
    read this https://wiki.guildwars2.com/wiki/Command_line_arguments#Usage
    and add to your shortcut -assetsrv 52.202.5.88 or -assetsrv 54.84.216.160 those are NA asset servers EU asset servers that I tested all had the isuue

  • Trevor Boyer.6524Trevor Boyer.6524 Member ✭✭✭✭

    Yup

    This is happening to me and I can't seem to figure out how to fix it. I've played this game for 8 years now and have had to reinstall plenty of times, never had any issues like this before:

    When I try to reinstall the game, it says it is downloading and it shows the amount of MB downloaded, but the file's remaining gets stuck at 33,151. And even though it shows that it is still downloading, it never cracks that number of 33,151.

    I've sat and let the bar completely finish the download all the way to end, but when I restart the client it starts back over at 0% with 33,151 files to download, but none of them ever touch the computer.

    The strangest part about this, is that before this happened, it had downloaded maybe about 50% of the game file first, which stuck on the PC, and THEN it started doing this with those remaining 33.151 files. It shows and says they are being downloaded, acts like they finish from the bar under, but they never touch the PC somehow.

  • Healix.5819Healix.5819 Member ✭✭✭✭

    @Trevor Boyer.6524 said:
    This is happening to me and I can't seem to figure out how to fix it. I've played this game for 8 years now and have had to reinstall plenty of times, never had any issues like this before:

    This is currently a common problem because some of the patch servers are handing out corrupted files, which causes GW2 to download them over and over since it's not getting what it expects. There are other causes, but this is currently the most common and can be solved by simply launching with "-assetsrv origincdn.101.arenanetworks.com" to use the main US patch server - only use it to get past the files you're stuck on, since it'll be slower.

  • @Healix.5819 said:
    This is currently a common problem because some of the patch servers are handing out corrupted files, which causes GW2 to download them over and over since it's not getting what it expects. There are other causes, but this is currently the most common and can be solved by simply launching with "-assetsrv origincdn.101.arenanetworks.com" to use the main US patch server - only use it to get past the files you're stuck on, since it'll be slower.

    have been reading these posts here and i dont understand half of them. "run with" "launch with" and whatsoever. anyway i have the same problem its stuck at around 50k remaining files and apparently its trying to download the same file over and over again.
    so can anyone of you explain what to do in a very simple way? in forms of "right click the exe data, go to properties, then ...." please ...

  • @Ordin.8341 said:
    huh I run it with -log and it seems it can't download certain file I tries to re download it over and over so that's why MB downloaded goes up while file-count remains the same I'll found some similar topics and will try different things man I already wasted 2 days and it wasn't progressing at all :(

    I found working fix using VPN and switching to US helped but I had to use US server when I tried other European servers for VPN I was getting same issue so I guess the issue is somewhere in European asset servers? (I'm from Poland I tried Czech and German VPN servers and had the issue)

    maybe this will help some other users if you don't have VPN try asset-server from different region will than yours
    read this https://wiki.guildwars2.com/wiki/Command_line_arguments#Usage
    and add to your shortcut -assetsrv 52.202.5.88 or -assetsrv 54.84.216.160 those are NA asset servers EU asset servers that I tested all had the isuue

    Thanks it help (-assetsrv 52.202.5.88)

  • @Healix.5819 said:

    @Luc de Lanzac.2160 said:
    in forms of "right click the exe data, go to properties, then ...." please ...

    Right click your GW2 shortcut and select properties. It should open a window with a shortcut tab selected. At the top is the target path. At the end of this path is where you can add the options, like this:

    "C:\Example\Gw2-64.exe" -assetsrv 54.84.216.160

    Remove this from the shortcut after you're done.

    Thank you so much for the clear instructions! This solved the problem for me too. <3

  • knako.6709knako.6709 Member
    edited February 9, 2020

    The fixes suggested in this post did not fix it for me. The files remaining count wont update at all. However, I have noticed every time I restart the launcher the file count goes down by 1. Guess I just have to do it 43 thousand times, then I'll be home free.

    Seriously though, does anyone have other suggestions on how to fix this? Changing the asset server did nothing for me besides lower the depicted download speed. Thank you!

  • Did you try the other Command Line Arguments suggested?

  • Healix.5819Healix.5819 Member ✭✭✭✭

    @knako.6709 said:
    Seriously though, does anyone have other suggestions on how to fix this? Changing the asset server did nothing for me besides lower the depicted download speed. Thank you!

    Using origincdn.101.arenanetworks.com (currently 54.84.216.160 and 52.202.5.88) will be slower because it's the main server located in the US on the east coast, whereas assetcdn (your default) is closer to your location. The main problem right now is some assetcdn servers have corrupted files, which is causing the launcher to get stuck endlessly downloading them.

    Most people will simply be able to use:

    -assetsrv origincdn.101.arenanetworks.com

    If that's not working, use:

    -log -image -assetsrv origincdn.101.arenanetworks.com -patchconnections 1

    If that's still stuck, let it sit for 5+ minutes, then exit and check Gw2.log for errors (located under %appdata%/Guild Wars 2/). If it's not stuck, let it download a few files then exit and launch normally; repeat if necessary.

  • Sigh, just reinstalled windows and this is appening also to me. I'm playng from Italy anyone has found a solution? Never had such a problem before.

  • edited February 13, 2020

    Is anyone from AN reading these support forums? The problem is still there!
    My download is stuck at 0% showing the same file remaining counter, download rate jumps to 2MB/s then plummets to 0 KBs where it stays for a while until it jumps again. I've restarted countless times and tried all values for "-assetsrv", still same behaviour. It's embarasing this issue is being reported for weeks and still hasn't been fixed. At this point I literally can't download and play the game.

  • Abakk.9176Abakk.9176 Member ✭✭✭

    Been stuck downloading since around 50k files left for almost a week now.

    So i just used the "-assetsrv 54.84.216.160" trick and its now finally downloading normally.

    What a weird bug and what a massive problem when people who end up not installing/playing the game when they don't find a solution.

  • I don't understand this -assetsrv 54.84.216.160
    what do I exactly need to do? I'm using mac os

  • I believe this is the correct information:

    Follow these steps if you are running the game on a Mac operating system:

    Click on the "Finder" icon located in your Dock or the desktop of your computer to make "Finder" the active program in the Finder menu bar.
    Click on "Go" in the Finder menu bar. A dropdown will appear.
    Click on "Utilities."
    Once in the "Utilities" folder click Terminal.app.
    Copy and paste the following line into the terminal and click "Enter":
    
    /Applications/Guild\ Wars\ 2\ 64-bit.app/Contents/MacOS/GuildWars2 -assetsrv 54.84.216.160
    

    (I don't have a Mac, nor ever have had a Mac. These instructions are from the Knowledge Base [but using a different Command Line Argument].)

    Good luck.

  • JimE.5013JimE.5013 Member
    edited March 25, 2020

    @knako.6709 said:
    The fixes suggested in this post did not fix it for me. The files remaining count wont update at all. However, I have noticed every time I restart the launcher the file count goes down by 1. Guess I just have to do it 43 thousand times, then I'll be home free.

    Seriously though, does anyone have other suggestions on how to fix this? Changing the asset server did nothing for me besides lower the depicted download speed. Thank you!

    Has anyone faced the same problem as myself and knako.6709? Files remaining stuck at 77,460 and 0% for me.

    Drive has hundreds of gb in space. Tried using all of these but nothing works:

    -assetsrv 52.202.5.88
    -assetsrv 54.84.216.160
    -log -image -assetsrv origincdn.101.arenanetworks.com -patchconnections 1
    -repair

    Even tried deleting installer and downloaded files, restarting download process, changing IPV4 DNS to 8.8.8.8, 8.8.4.4.

    Nothing works. Anyone have any solutions?

    EDIT: Using a VPN has helped with this, files are reducing now. After the free VPN of 500mb finished, just downloading normally without the VPN works fine now. TunnelBear's free version was the one I used.

  • Alvin Ip.9214Alvin Ip.9214 Member
    edited March 30, 2020

    VPN does not work for long; it only helped me download 20~30 files and now stuck again. Are there any other solutions? Tried all the solutions i saw above in this thread. This is very annoying, currently stuck at 301,000 files ;-;

  • This message pops up on the terminal every time:

    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [38769:775:WARNING:resource_bundle.cc(303)] locale_file_path.empty()

  • Anyone from Anet reading this forums? the Issue is still here btw....

  • What solution you do
    I have same problem