Server lag — Guild Wars 2 Forums
Home

Server lag

Donutdude.9582Donutdude.9582 Member ✭✭✭
edited February 21, 2020 in Account & Technical Support

Good day,

I am writing to you today concerning repeated episodes of lag that I am encountering when playing through Path of Fire maps.

Currently, I am in the Domain of Vabbi on server 18.185.68.76. At times, I am experiencing 1-3 second interruptions in communication to the server, resulting in frustrating gameplay.

Now, I've run a search on these forums and could not find a recent post relating to an open-world map. I am aware of the on-going WvWvW lag issues.

I'd appreciate any input from the forum community. I reckon this will be something that the Support team will need to take a look at but I thought I would try here in a more open discussion first.

For your information - I have run basic network troubleshooting and can confirm with 100% reliability that my connection and hardware are not at fault.

Many thanks for your time,
Donutdude.

My Wiki Profile
Honorary Seraph Captain
Guardian Expert

<1

Comments

  • I have been having the same problem.

  • I also am having this problem.

  • I'm having this problem too, never had those spikes to be honest lol

  • Thanks for your comments folks.

    I'll pop a support ticket across as it would seem that the issue is not limited to me.

    My Wiki Profile
    Honorary Seraph Captain
    Guardian Expert

  • In the desert highlands (derelict delves) and the lag spikes are unbearable. Seems to be a map wide problem when I asked in map chat. Everyone was lagging.

  • Batel.9206Batel.9206 Member ✭✭✭✭

    Same here. I've been in the Elon Riverlands, Crystal Oasis, and Desert Highlands - lagging to heck and back, and it's a map-wide problem. I was worried thinking it was my computer not being able to handle high graphics settings in those areas...nope, just lag.

    Don't cry, Daniel
    Fear not, Daniel
    Don't you know you're not alone?

  • Saaaaaaaaaaame. I got a group together to do facet and we failed because everyone lagged so bad. It was a collaborative "What's with this lag" in Discord at the time. I was told the ping had jumped to 400. Mine also went up to 530 when I was in Desolation. I have been trying to help my new guild mates get their griffons but I can sense they are getting frustrated because of the lag. In every PoF map I have played in yesterday and today, I have heard people talk in map chat about lag. One person said they were about to call their internet provider but they were glad it wasn't just them. It seem like it's just huge spikes of lag that stop/slow down the game for long enough you to miss a skill or 2 and die because everything froze. I don't normally write in the forums but I felt like this is something that needs to be addressed. I hope it gets fixed soon!

  • I've been having massive lag issues the past week.. I am not sure if this is only because of the new patch, but from what I know my Australian guild had to cancel some PvE events due to this lag.. I've seen my own ping go as high as 600-700ms (a guildie even said they got pings ranging from 1500-4000) when my average is about 250ms basically freezing the game for 5 seconds at a time whenever the spike happens.

    If I knew how I'd try to trace my connection to see where the problem is. For now though I'll just assume its some error in one of the intermediary Oceanic servers that Anet hasn't noticed yet. Hope it gets a solution soon.

  • darksome.1697darksome.1697 Member ✭✭✭

    Been experiencing this lag in PvE for the last month or so, have bug reported it several times, and posted on the forums about it, still no word from Anet. There's thread going in the other bug forum specifically about the Tequatl event, which is heading towards being unplayable because of the lag issues. https://en-forum.guildwars2.com/discussion/96467/tequatl-mass-map-crash#latest

  • @Grim.9682 said:
    I've been having massive lag issues the past week.. I am not sure if this is only because of the new patch, but from what I know my Australian guild had to cancel some PvE events due to this lag.. I've seen my own ping go as high as 600-700ms (a guildie even said they got pings ranging from 1500-4000) when my average is about 250ms basically freezing the game for 5 seconds at a time whenever the spike happens.

    If I knew how I'd try to trace my connection to see where the problem is. For now though I'll just assume its some error in one of the intermediary Oceanic servers that Anet hasn't noticed yet. Hope it gets a solution soon.

    You can use a program like PingPlotter to trace your connection.

  • same can't even use black lion trader or move alot in LA without massive lag and i not usually have it

  • Batel.9206Batel.9206 Member ✭✭✭✭

    It's still continuing in Path of Fire maps even after the patch today. This is so annoying...

    Don't cry, Daniel
    Fear not, Daniel
    Don't you know you're not alone?

  • Good evening! Input lag and temporary ping increases have been observed for some time. It is very inconvenient to play, please correct.

  • March 1st and this is still happening. I'm playing through PoF and it's unbearable. any update on this?

  • Donutdude.9582Donutdude.9582 Member ✭✭✭

    I'm still going through the motions with Support at the moment I'm afraid.

    My Wiki Profile
    Honorary Seraph Captain
    Guardian Expert

  • Vegeta.2563Vegeta.2563 Member ✭✭✭

    @Donutdude.9582 said:
    I'm still going through the motions with Support at the moment I'm afraid.

    I hope they finally come to a conclusion there is something wrong with the Amazon servers the game is hosted on. Packets dropping. Skill delay. Random weapon skill cooldowns. Trading post taking forever to respond. Login servers stop working at times, even for a full 2-3 minutes. Its just getting worse and worse.

  • Donutdude.9582Donutdude.9582 Member ✭✭✭

    Might be worth logging your own tickets to help them realise there is an issue. Be sure to check that all of your Windows patching and drivers are up-to-date. Also be patient - troubleshooting something like takes time with a lot of steps to cover.

    My Wiki Profile
    Honorary Seraph Captain
    Guardian Expert

  • I would open a support ticket but right now I'm getting "IP restrictions are enabled. Access may require connecting to an office network or VPN. Contact your Zendesk administrator for help."

  • @Vegeta.2563 said:
    I hope they finally come to a conclusion there is something wrong with the Amazon servers the game is hosted on.

    They probably know but can't do anything about it because of contract agreements. And from what I've read Amazon's servers are always the main targets of most of the web's attacks anyway so Anet is just collateral damage.

    The Commander will end you.

  • Rezzet.3614Rezzet.3614 Member ✭✭✭

    been getting random lag spikes and disconnects ever since the patch as well

  • I am also experiencing a lot of server lags in germany, please take care of that.
    The lags are that long, that it has a heavy impact on the gameplay.
    And no you don't have to care about my internet connection or any other network issues on my side !!!

  • Mannah.4012Mannah.4012 Member ✭✭
    edited March 14, 2020

    WvW is literally unplayable. Yesterday I went from 400-700 ping to 1700-4250 ping (I normally play with <100 ping). Tonight goes on the same way...

  • Blur.3465Blur.3465 Member ✭✭✭

    It happens mostly if people are doing bounties and other bigger bosses.
    I've noticed massive delays and lag during bounties, really unbearable to play.
    Some World Bosses also cause this, where sometimes my skills aren't registering when I press them.

  • alteriel valie.4751alteriel valie.4751 Member ✭✭
    edited March 15, 2020
  • Mannah.4012Mannah.4012 Member ✭✭

    @Blur.3465 said:
    It happens mostly if people are doing bounties and other bigger bosses.

    I'm doing personal story at the momment with a new character and I still have the problem. 800 ping doing an instanced mission or afking in a city with spikes por +3000 ping. It's not only wvw/world bosses, it's in general.

  • Calisanna.8732Calisanna.8732 Member ✭✭✭

    The last two days I've been having huge skill delay, and major lag spikes. High ping issues. Unsure what has changed, but it is unplayable. Ran a speediest. My internet is fine. Average ping for me is usually 70-90. Last two days it goes over 1k. Im lucky to have an average of over 200. Whats going on?

  • Me too. I'm from SEA region and almost all of my friends couldn't play properly without using VPN services ( and sometimes even with VPN the lag still persist especially in wvw and pvp ).

    I can't really pinpoint the exact time when this all happened ( maybe 2 weeks ago )....but I remember that it all started when a friend of mine from SEA region experiencing massive lag while playing gw2 but I have no problem at all despite being in the same region. A week after that I too suffer from it. And slowly but surely everyone else started to experience lag.

    Basically, I experienced the same problem that everyone else posted here.

  • Therys.4368Therys.4368 Member ✭✭

    Thought it was just me. The lag started last month and the game basically became unplayable with the ping spiking to 3000. I couldn't complete the last story instance without having a friend carry me through it. I started a ticket and support made me jump through the usual hoops (the checklist) for 2 weeks and found nothing wrong on my end. Ultimately, they suggested I change servers but a) I like my current server and b) What if that doesn't fix it? I refused the offer and they just closed my ticket without further response or action. Now I can barely even log in. Don't expect tickets to help. They can't do anything for this.

  • bobsort.4097bobsort.4097 Member ✭✭✭
    edited March 18, 2020

    Same here, right after this last update which I got this morning, I keep lagging and then the famous "check your router and firewall" message! and finally I have to close the game and login again to be able to play for another few minutes. From SEA region too, and I'm sure I'll be asked again to share pathping result and even blame the issue to my router, wireless connection (I'm on fiber to gig lan) and etc.

    BTW, it has nothing to do with doing big events or something, people in my map were less than fingers of both hands

    I bet you never ride skyscale under water before

  • Haven't played this game since shortly after launch. Came back yesterday and this lag and disconnect is really starting to make me regret that choice...

  • Chung.3420Chung.3420 Member ✭✭
    edited March 19, 2020

    I also have the lag issue,can't hit kitten with melee weapon.Just give up and go other mmo until the problem solve Zzzz

  • Anna.7845Anna.7845 Member ✭✭✭

    I have lots of lag as well just ruins pvp..

  • Also having the lag issue (SEA). I've troubleshot whatever I could with my own home PC, my ISP but to no avail.
    The game is nigh unplayable, there are some pockets of good connection here and there that I managed to put some gameplay in, but otherwise it's just a constant lag spikefest.

  • I have same problem in Piken Square right now. I get 300+ping spikes

  • Thanks God, it's not my internet (brazillian here)

  • WvW 1000 ping

  • Nikola.3841Nikola.3841 Member ✭✭
    edited March 24, 2020

    3k ping, mostly in icebrood saga areas, but it feels like 30k really...i press skill and it fires few minutes afterwards

    Ots not like that all the time, but quite often, more often than not actually

  • Yeah, I hardly ever get lag, but for the past 24 hours every time I go near a group of more than 15 my ping goes up to over 4000 and I have 15-20 seconds skill lag. WvW virtually unplayable at the moment, but only for certain people.

  • crepuscular.9047crepuscular.9047 Member ✭✭✭✭

    have a feeling something to do with the covid19, networks are getting flooded because people are working from home and stay home watching streams instead of going out

    [RIP Fashion Wars 2005-2018]     [TTS] [KA] [SI]     [RIP Fashion Wars 2005-2018]
    Praise the Inevitable Eternal Transcendent King Palawa Ignacious Joko, the Beloved and Feared Undying Eternal Monarch of All !!!
    ... til Aurene ate him for dessert 😭
  • Yeah same here. Errors with connection when starting up, lag (ping 300-1000). No issues before.

  • i've download ExitLag 7 days trial to get better route.... so... bannerlord will release in 5 days...

    anyone can teach me how i can configure my device to get this route?

  • This is so annoying. Never had this in years. These random spikes on EU just making my char glitch through things or just disconnecting me...

  • @Divine Martyre.3509 said:
    This is so annoying. Never had this in years. These random spikes on EU just making my char glitch through things or just disconnecting me...

    where're the GM to solve this,,,

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    The Tech Devs rarely post in this forum.

    For an individualized response, you can contact the Tech CS Team via the 'Support' link above/below.

    Good luck.

  • Yeah I have a ticket with them and none of the solutions help. They have resolved to pointing it back at my ISP, which I have been in contact with BEFORE I contacted Anet as I wanted to be sure it wasn't something on my end in the first place.
    I've started paying for Mudfish because at this point it's gotten so bad that I couldn't even load in a map.
    If they rarely post at this forum - why have a tech support forum in the first place?

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Because the Devs can learn about issues without having to stop work to respond.
    Because players can assist other players with many issues.

    If a VPN is helping, it is likely taking a different path to the servers, and using a different Tier 1 backbone, which is quite often the source of these kinds of issues.

  • phoenixxx.8230phoenixxx.8230 Member ✭✭
    edited March 27, 2020

    Yes, thanks for your helpful reply.

    Now for some actual tips of what worked (for me at least, YMMV) to the others suffering from this problem, I tried the free version of hide.me, which worked for a couple of days until that too stopped working. I am now on mudfish (3 days now) and it has been working so far, unfortunately it is a paid option.

    That is of course assuming there is something wrong with your routing to the servers (my internet is working fine in all other areas and online games except GW2).

  • crepuscular.9047crepuscular.9047 Member ✭✭✭✭

    @Inculpatus cedo.9234 said:
    If a VPN is helping, it is likely taking a different path to the servers, and using a different Tier 1 backbone, which is quite often the source of these kinds of issues.

    for OCE, most ISP uses the route that goes up through Asia Pacific to Asia then onto Euro, then to NA east coast, the premium route that crosses the pacific directly to the NA west coast are usually used by business, which some VPN uses

    i think maybe we OCE players would have better experience if we just play on the EU servers rather than NA

    [RIP Fashion Wars 2005-2018]     [TTS] [KA] [SI]     [RIP Fashion Wars 2005-2018]
    Praise the Inevitable Eternal Transcendent King Palawa Ignacious Joko, the Beloved and Feared Undying Eternal Monarch of All !!!
    ... til Aurene ate him for dessert 😭
  • The game recently hasn't lagged too much for me, but over the past week it's been terrible, and today has been unplayable. I don't know what is wrong with GW2 servers but they need to sort it out. I've done speed tests and played other games without ANY problems. So GW2 has issues. If they don't sort it out I'm going stop playing and look for another MMO.

  • Donutdude.9582Donutdude.9582 Member ✭✭✭

    Thought this worth reiterating here:

    Update on lag from the Development team

    My Wiki Profile
    Honorary Seraph Captain
    Guardian Expert