Switching build template switches active weapon — Guild Wars 2 Forums

Switching build template switches active weapon

I have a GS on weapon set 1, and sword/pistol on weapon set 2 on Template 1. On Template 2, I have a GS on set 1, and sword/sword on set 2. GS is my Active weapon (even says so in the template popup). When I swap templates, it always switches to either sword/pistol or sword/sword, not the Active weapon. If i swap out the location of the GS and the S/S or S/P in both templates (GS being on bottom) and I swap Templates, it still always switches out of GS.

Tagged:

Comments

  • Skotlex.7580Skotlex.7580 Member ✭✭✭✭

    Hmm, I don't have that issue. Maybe your hot keys to change build happen to include whatever you've set as hot key for weapon swap? :o

  • YtseJam.9784YtseJam.9784 Member ✭✭✭

    it happens when both with hotkeys and by clicking on the tabs in the UI as shown in my video :(

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    @YtseJam.9784 said:
    I have a GS on weapon set 1, and sword/pistol on weapon set 2 on Template 1. On Template 2, I have a GS on set 1, and sword/sword on set 2. GS is my Active weapon (even says so in the template popup). When I swap templates, it always switches to either sword/pistol or sword/sword, not the Active weapon.

    Yes, same here. It always automatically switches to the secondary weapon set instead of the primary one.

    This needs to be fixed. A temporary solution is to swap your weapon sets on each loadout. :/

  • YtseJam.9784YtseJam.9784 Member ✭✭✭

    i tried that (as you see in my video) and nothing makes it stay on GS

  • We’re aware of this bug and are investigating it.


    Stéphane Lo Presti
    Content Marketing Manager

  • Linken.6345Linken.6345 Member ✭✭✭✭

    @Stephane Lo Presti.7258 said:
    We’re aware of this bug and are investigating it.

    Thx for taking the time to reply to so people do see they are being heard.

  • Flatley.1620Flatley.1620 Member ✭✭✭

    I don't play so much these days and I'm late to this party but I, too, am seeing this. Happens when I switch between ranger and druid builds using longbow/staff.