Couple of Bugs on Revenant and Build Templates — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

Couple of Bugs on Revenant and Build Templates

Kidel.2057Kidel.2057 Member ✭✭✭
edited November 6, 2019 in Bugs: Game, Forum, Website

Since build templates I'm experiencing lots of bugs with revenant utility skills.

First of all my utility skills get swapped to a "default" arrangement instead of staying in the order I set them. It happens with every legend currently.
This may be trivial, but the other bug is way stranger.
If I activate Glint facets and swap to another herald build that has glint on a different slot, facets consume energy even if I'm on Jalis or Shiro.

Comments

  • Ahi.9673Ahi.9673 Member ✭✭
    edited November 6, 2019

    it's far from trivial, not having skills where your muscle memory expects them to be makes it essentially impossible to play a revenant at the moment unless you remember to double check your skills after every loading screen

    please fix asap

  • Kidel.2057Kidel.2057 Member ✭✭✭
    edited November 6, 2019

    You may be right, I simply assumed I was the only one rearranging Rev utility skills (I do that based on use frequency)

  • Vyrulisse.1246Vyrulisse.1246 Member ✭✭✭

    Yeah it's a big issue and annoyance.

  • Shaogin.2679Shaogin.2679 Member ✭✭✭

    Hope they fix this soon.

    Doc Von Doom

  • Ahi.9673Ahi.9673 Member ✭✭

    still bugged

  • ArthurDent.9538ArthurDent.9538 Member ✭✭✭✭

    I'm just had my skills swap places on me right as a pvp match started so I had to play with them in unfamiliar spots. I was litterally double checking their position before the match because of this bug and it didnt matter, they just swapped when I couldn't change them back.

  • I'm still having this problem!!
    It's very annoying when you forget to double check it. It keeps swaping my #7 and #9 utility skills. I'd say that the biggest problem is, it's swaping other legends that are not currently selected. For example, if I'm playing Kalla+Shiro as Renegade and I change build for Glint+Shiro as Herald, it will swap the skills in Dwarf Jalis even though it was not selected in any build. So, whenever I decide to change and play with Dwarf Jalis, the utility skills will be in wrong position even if it's been 2 hours since I last changed my build. I have to go through every legend checking skills' position everytime I change my build to make sure.

    It's an awful experience when I forget it. I end up using the wrong skills in the wrong time, which is already something bad, but also my team mates think I'm using this as an excuse to be a bad player.

  • Ahi.9673Ahi.9673 Member ✭✭

    still not fixed

  • Virdo.1540Virdo.1540 Member ✭✭✭✭
    edited December 23, 2019

    its changing the arrangment even if just simply switching legends at all, switching the elite spec (even if not choosing the legend before&afterwards) , simply when going underwater,on mount or siege in wvw/pvp.

    but ye, maybe its happening on the build template-changes now too

    ....its happening since the rev got out

  • Ahi.9673Ahi.9673 Member ✭✭

    I only recently came back to the game and picked up revenant...if it is indeed been happening since before build templates it will probably never be fixed...welp

  • Aaralyna.3104Aaralyna.3104 Member ✭✭✭✭

    I still hope on a fast fix (it completely breaks playing basic game play on revenant).

  • gebrechen.5643gebrechen.5643 Member ✭✭✭
    edited December 27, 2019

    Still bugged:
    Hammer 2: Coalescence of Ruin sometimes doesn't hit in the direction you face, or just misses left or right of the target you have selected. In some cases the effect disappears below the floor and does no damage.
    Sword 3: Unrelenting Assault. In WvW it targets medipacs at Sentrys or the supplies at supply huts and you don't hit the target you chose.

    Can confirm the issues with the switching facets. That bug killed me at least three times today.

    Disciples of the monkey god [Apes]

  • I thought I was only having issues when I switched templates, but I will be in the fractal lobby on Shiro, making sure that the skills are in my preferred order. Then after we load into a fractal they've reset again. So kitten infuriating. I'm almost at the stage where I'm using the default skill positions out of sheer unadulterated frustration even though it lowers my performance.

    "My condi clear/boonstrip isn't popping? Is it my ping.....? Oh no, nvm it's just the kitten skills resetting AGAIN."

    Disagreement =/= "negativity"
    Criticism =/= "hate"

  • LadyHawk.5319LadyHawk.5319 Member ✭✭✭

    This bug is so annoying! Scenario: In WvW, you have a brief moment of no combat. You swap templates "real quick". You check your legendary stance. All good. Bam! In combat again. Press your mouse button for "roads" and ... what the heck! Where are my roa ... oh! I got chains instead. You look at your skill bar and yep ... big sigh the utilites are not where my I had saved them on my template. You spend the rest of the fight getting finger tied cuz you are hitting the wrong buttons. Rinse and repeat.

    My other favorite is with Glint. The facets don't show when you activate them. In order to get them to show, you have to swap the 3 facets around in your slots. Perhaps this is Anet's nerf to Revenants :p

  • Ahi.9673Ahi.9673 Member ✭✭

    still not fixed

  • Virdo.1540Virdo.1540 Member ✭✭✭✭

    @Ahi.9673 said:
    still not fixed

    i dont think its "fixable" :bleep_bloop:

  • Infusion.7149Infusion.7149 Member ✭✭✭✭

    happened to me today

  • SCHTiFU.9143SCHTiFU.9143 Member ✭✭
    edited May 31, 2020

    EDIT: Reading the bug reports of others, I now realize this is not an issue with empty skill slots, but just with changing legends via build-templates. As soon as you do it, things get messy.

    ~~So, there seems to have been a partial fix to this issue, but that fix only works, if all your skill slots are occupied. If you leave some skill slots empty (because you don't have enough skills on that legend yet), all skill orders will be messed up again after changing build templates.

    This is quite a bummer for me right now, because I wanted to have the assassin for its speed-buff as a simple "travel-form", but I don't intend to use it for fighting, so I don't want to level it up any further right now. I am level 27 right now and ended up getting that third assassin-skill to make this work for now, but I expect the issue to return once I hit level 31 and the elite skill is unlocked.~~

    I also found this rant on reddit about the issue:
    https://www.reddit.com/r/Guildwars2/comments/dozq31/revenant_utilities_are_currently_trashed_with/