Modniir Ulgoth bugged out. Pls fix your evvent which are in collections... — Guild Wars 2 Forums

Modniir Ulgoth bugged out. Pls fix your evvent which are in collections...

PeaceOrFreedom.6179PeaceOrFreedom.6179 Member
edited September 21, 2019 in Bugs: Game, Forum, Website

The Meta Event for Modniir Ulgoth just wont start. Why do they put events in collections who are bugged. in July 2018 someone posted the same bug and even got an answer that its on the list to fix but nothing happened so far.
Anything you can do to fix that? The only way i know is to get a new map instance but this wont happen unless there comes some patch or there are enough people on the map that a second will open but, well, wont happen on Harathi Hinterlands.
The event is stuck at "The Seraph are digging in at the forward camp." and the follow up event does not start. (Map IP


  • And again yesterday. Looks the same today :(

  • Hello,

    We tried to do this event yesterday and today (we tried 4 times) and each time the event bugged and did not start.
    The boss appears but he is invulnerable and so we cannot do the event.

    We need it for mistwarden collection.

  • Your best bet is to try it immediately after the Release patch on November 19th.

    Good luck.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.