Legends and templates. — Guild Wars 2 Forums

Legends and templates.

Buran.3796Buran.3796 Member ✭✭✭✭

The game seems to randomly shift the order of the utility skills in my legends when I jump from game modes; seems also unable to remember the exact legend I was using the last time I entered in the game with a Revenant character and shifts instead to the "default" listed in the template I'm using. I'm doing something wrong or is just part of this disgracefull bag of bugs called Revenant? I swear this class feels like a house of cards: every time the encoders change a line the entire build crumbles and falls apart...

Comments

  • You’re not doing anything wrong it’s just more kitten revenant bugs that will take ages to get fixed

  • Fueki.4753Fueki.4753 Member ✭✭✭✭

    Jalis and Glint keep getting flipped for me on switching loadouts, too.

  • alain.1659alain.1659 Member ✭✭✭

    Yep. A single skill place chamge got me killed last night. That is when I discovered this cute bug. Now we shall do the waiting game for a fix. Again.

    And with mount up-dismount I sometimes experience a camera bug like the old hammer 3 one but faster, harder to detect. Maybe it is me or maybe I was in a specific point at map.

  • I have the same with the inspiring reinforcment skill in the dwarf stance, it keeps switching to different skill slot.

  • I'm having similar problems with Kalla and Ventari. The skills keep getting swapped around and sometimes I get double icons showing the same skill twice, but one will be the real skill and the other will be another, and they're always in the wrong spots. It's extremely frustrating and makes me want to just use the old method of swapping builds.

  • Virdo.1540Virdo.1540 Member ✭✭✭✭

    its always has been like that.

  • Knighthonor.4061Knighthonor.4061 Member ✭✭✭✭

    does this only happen to people that move the skills around? Because I dont have this issue. just curious

  • Hannelore.8153Hannelore.8153 Member ✭✭✭✭
    edited November 30, 2019

    This has nothing to do with build templates,it was happening even before it for Rev, especially with mounts. They don't seem to save the utility state properly, for example Guardians and Mesmers lose their mantras sometimes even in the same map..

    Its just really noticeable on Revenant because they seem to have the most haphazard implementation overall..

    Hannah | Daisuki[SUKI] Founder, Ehmry Bay | Mains Mariyuuna/Tempest(PvE), Terakura/Spellbreaker & Kitty Koume/Reaper(WvW) | ♀♥♀

  • @Hannelore.8153 said:
    This has nothing to do with build templates,it was happening even before it for Rev, especially with mounts. They don't seem to save the utility state properly, for example Guardians and Mesmers lose their mantras sometimes even in the same map..

    Its just really noticeable on Revenant because they seem to have the most haphazard implementation overall..

    While it certainly existed before build templates, it’s only been this big of a problem once before (which was fixed relatively quickly). Build templates exacerbated the issue to a huge degree because it doesn’t account for the other utilities properly as you mention. It definitely has a lot to do with build templates and their design not accounting for the outlier that’s is revenant’s utility designs.

  • arielwind.8921arielwind.8921 Member ✭✭✭
    edited December 3, 2019

    feels very inconvenient that needs to check utility state every time when i do map hop. Still we have no clue to confirm one of underwater utilities until we get into underwater. It's kinda unfair to get killed because of it in WvW.

    -Dec. 3 update: thanks Anet for fixing the issue so soon.