Cinematic in "On the Mend" story not triggering properly — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

Cinematic in "On the Mend" story not triggering properly

Montarrro.4986Montarrro.4986 Member
edited January 2, 2018 in Bugs: Game, Forum, Website

Well, as the title says, the last cinematic (when going downstairs to check on Petra and Andrew) in the personal story "On the Mend" does not work properly for me. It switches into the cinematic screen, but the characters won't appear, there is no audio and the text doesn't display either. This has happened twice so far and the only option is to skip the dialogue, which is kinda meh.

Would be cool if this could be fixed, I prefer hearing the conversations instead of having to read them in the chat panel. : D


  • Donari.5237Donari.5237 Member ✭✭✭✭

    Hmm. I'm told there's an overall issue with story cinematics. I helped a friend through One Path Ends last night and in the "initiation" sequence all the audio and associated subtitles appeared very rapidly, followed by the cinematic of the phases of initiation playing out in silence. He told me he'd been seeing reports that many personal/living story instance cinematics had been behaving oddly since the last patch, including issues such as you mention.

    Hopefully the next patch we get will correct the problem; meanwhile, I think you're not alone in your suffering, if that helps at all.

    I just did a key run a couple of hours ago on a sylvari (White Hart track) and did not have any visual/audio issues, though, so it apparently isn't happening globally.

  • Ah, hopefully that patch will come soon. But at least now I know I'm not the only one with this problem. : D

  • I can certainly vouch for this. I've been going back and doing all the storyline quests from the very beginning of the game. Everything Was fine until I got to "Heart of Thorns". Not only is the dialog and audio cutting off abruptly, it is also cutting off portions of the storyline, ultimately ruining the Storyline as a whole. For example, the part were you and Bram argue in the jungle is completely missing, causing a plot hole.

  • AggiePunbot.1962AggiePunbot.1962 Member
    edited May 17, 2020

    Was this issue ever fixed? I just experienced this today; I Alt+F4 out of the game in order to try to kickstart it back into working properly (since I'm a new player and have never played this mission before) but it just keeps happening.
    ETA: Well, it worked after I closed the game down twice. Strange that this glitch has been around for years and hasn't been fixed yet, though.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Never seen anyone post about this issue, except for the one time it was an issue over 2 years ago.

  • this jus happened to me.. alt F4 to quit and about to redo it again.. hopefully this time it works

  • @iNaddict.8021 said:
    this jus happened to me.. alt F4 to quit and about to redo it again.. hopefully this time it works

    worked second time