Story Quest Stuck on Old Character — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

Story Quest Stuck on Old Character

I created a character 8 years ago shortly after launch and left it alone after the tutorial. After playing through my main and dropping GW2, I have come back and want to play through this other character. I logged in and started playing just fine. However, when I reached level 10 and my story quest "activated" I am unable to progress it. As a sylvari, it's the Awakening quest to retrieve a jungle troll salve. However, there are no quest markers, and when I go to the troll area, there is no salve anywhere in sight. There is also no story instance. Speaking with the quest NPC doesn't help and I don't know how to progress. It appears stuck. Any suggestions?


  • I have solved this issue. I restarted my game fully and it appears to have reset properly. Hope this helps anyone that gets stuck like this. Everyone else, please ignore this!

  • I won't just ignore it - instead, I'll thank you for coming back to tell us that you have resolved the issue, and also for telling us what you did. (You'd be surprised, maybe, by the number of people who never come back to a thread, so we don't know if they solved it (and are rude) or just gave up and removed the game, or whatever.)

    Anyway, thanks!

    @Biff.5312 said:
    Exercise your whimsy.

  • something similar happened to me recently. returning player rerolled and started my personal story quest... "on the mend", but the cutscene at the end of the missions didnt play out.. had to alt f4 as the game wasnt doing anything i was just sitting there waiting for the cutscene to start.. closed the game, rebooted and it was fine on the second try...