BUG: The Convergence of Sorrow II: Requiem — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

BUG: The Convergence of Sorrow II: Requiem

Beethoven.8194Beethoven.8194 Member ✭✭
edited October 19, 2020 in Bugs: Game, Forum, Website

After successfully completing the "Find the djinn vessel before the Brandstorm overwhelms the area" event, the next event wont start. It pops up for 1-2sec and then disappears again.



  • Yes, thats exactly my issue as well! There is only the djinn event or nothing! Pls fix this Anet! I want the Requiem armor!

  • Today, someone on reddit told me that he had the same problem.
    His problem was that the humans in the north die instantly to the branded crystals when the event starts.

  • Aravind.9610Aravind.9610 Member ✭✭
    edited October 21, 2020

    Ran into this too. Please fix soon so I can finish requiem armor. It seems to happen even if the djinn event prior to this failed.

  • Also getting this bug, terribly annoying

  • same issue, the event disappears at 2min 54s/3 min almost guaranteed. The Event is now buggy for at least 3 days, tried different timezones and instances of the map if possible

  • very annoying bug

  • Reported this in-game, but gonna throw a comment on here, too.

    Exact same issue, am unable to progress this acheivement because the event ends after only a few seconds. Have tried 4-5 times over the last 4-5 days, same issue every single time.

    The informatiom about the people dying being the cause isn't something I've noticed before.

  • Scratchpaw.1069Scratchpaw.1069 Member ✭✭
    edited October 22, 2020

    Encountered the same issue here. The "Djinn Vessel" event completes and the "Prevent Brand Energy from overwhelming the area" dynamic event only shows up for about 3 seconds until it dissapears. This basically blocks any more progress towards unlocking the Requiem Armor. Please fix!

  • Same issue here, Event shows up for 2 seconds before disappearing again. Cant progress. Please fix. Thank you.

  • I also encountered the same issue. Event show up but all villagers under the tree dies instantly and event will dissappear altogether. Please fix.

  • Ioana.8034Ioana.8034 Member
    edited October 24, 2020

    Encountered the same issue today. Event disappears instantly. Please fix. Cheers.

  • markk.2401markk.2401 Member
    edited October 24, 2020

    Also seeing the same issue. The event disappears as soon as it starts. Please fix so we can get the Requiem armor.

  • same issue here

  • Inoki.6048Inoki.6048 Member ✭✭✭

    I can confirm. I’m trying to do the achievement and I’m stuck at this stage. Tried to wait several times for the shifts and events to happen.

    Every transfer delays alliances.

  • same for me. tried to do the second event5 times in a row today (17:10, 17:40, 18:10, 18:40: 19:10) failed instantly every time

  • same issue here, tryed it 3 times in a row, event failed at 2:57 each time... pls fix

  • araneavalon.5741araneavalon.5741 Member
    edited October 27, 2020

    This is still happening after today's (October 27 2020) patch. Specifically, after a successful completion of the prior event, the exact same issue happened -- the event started briefly, and then failed, with the villagers dying.

  • I can confirm that it´s still bugged.

  • Still bugged after today's patch

  • Inoki.6048Inoki.6048 Member ✭✭✭

    @selmorn.7538 said:
    Still bugged after today's patch

    Ofc, because there was not even a mention in the patch notes about a fix. They added UX improvements to the inventory tho', albeit slightly lacking, because they took away the option to move the Compact option away, and some people tend to miss-click.

    Every transfer delays alliances.

  • still bugged as of 10/31

  • Still bugged. Multiple attempts but the event disappears after a few seconds. Cannot progress in requiem collection. :(

  • Same issue encountering here, submitted in-game report.

  • FrogDevourer.4523FrogDevourer.4523 Member ✭✭
    edited November 1, 2020

    Update 1 : this time the event did not reset. The bug does not always happen. Still I failed the event by 2 seconds. Oh well...
    Update 2 : three new attempts. The event has disappeared each time after a few seconds.

  • waxx.3619waxx.3619 Member ✭✭

    Yep this event is broken and in a way it's game breaking because it now locks off an entire line of activity ( armor collection ).

  • 11/3 still not working disappears as soon as it comes up with full area clear

  • Update : 4 more attempts. The event disappeared each time.

  • As of 11/3/20 at 11:40 p.m. PST the dynamic event "Prevent Brand energy from overwhelming the area" is still bugged. Within ~3 of the temporal shift after the djinn vessel event the npcs spawned in and died immediately before any branded enemies spawn in. It's been like this for over a week and a half now, would be awesome to see it fixed so we can continue working on our requiem sets.

  • 11/4 still bugged

  • whoknocks.4935whoknocks.4935 Member ✭✭✭✭

    Any news? Maybe it's beter to submit a ticket... It is weeks i am trying to complete the collections and cannot because of this bug...

  • can confirm still bugged. :c

  • getting this bug as well

  • Still bugged as of today.

  • Still bugged

  • Still bugged as of 07/11/2020. Blocking achievement progress.

  • Did try 2 times today 7 Nov. 2020. It doesn't work.

  • whoever I talk at the map says they have the same issue at this event. Seems anet is too busy releasing new wing skins instead of solving game breaking bugs. its been 2 weeks

  • Inoki.6048Inoki.6048 Member ✭✭✭
    edited November 8, 2020

    @kaan.5074 said:
    Seems anet is too busy releasing new wing skins instead of solving game breaking bugs. its been 2 weeks

    It's been longer, I'd say more than a month. I remember I keep coming back to this and it doesn't work.

    ANet, can we get an ETA?

    Every transfer delays alliances.

  • Same issue here. "Prevent Brand Energy from overwhelming the area" dynamic event only shows up for about 3 seconds until it dissapears. Fix it, please. Thank you.

  • Yup... same issue here today !

  • Is ArenaNet aware of the issue/is it on the devtracker?

  • They must be aware.
    Several ingame reports.
    WEEKS of reports here...
    At this stage... ArenaNet and their silence speaks volumes.

    I am getting extremely frustrated... you are there waiting... MANY are there waiting... shift happens you get booted out. Event starts but even before you can enter the bubble.... Gone...

    Can someone blast a horn to wake them up?

  • I can confirm that it´s still bugged. Please fix

  • Seriously. Just literally any confirmation that someone has even read any of the reports or this forum thread would be nice at this point. Like hell, that's a low bar but that's where we're at I guess.

  • Thanks, Scratchpaw. Some hope at least.

  • Nope, still bugged

  • I just went back and try, Noori spawned and went to dead instantly...

  • @Scratchpaw.1069 said:
    Managed to finally get this event today. I was in a bugged map but had the pop-up to switch maps because of low population. The new map had the event running and we managed to complete it, so there is hope. Quite relieved after checking the Ancestral tree for about a month. I think the event only works the first time on a new map.

    i got it the same way too. thanks for the hint