[Feedback]: DPI Scaling — Guild Wars 2 Forums

[Feedback]: DPI Scaling

Hi folks! The update of October 17, 2017, included high DPI aware UI scaling. Since many of you seem to have questions and thoughts about this, we invite you to use this thread for your feedback.

Here's a brief description of how it works: macOS and Windows provide a UI scaling value, usually based on the monitor resolution and dimensions. As of Tuesday's patch, we use this in the 64-bit client to scale the in-game UI as well. You can change it in your OS settings, but each OS version will have the setting in different places so please consult your favorite search engine to determine how to change that setting, if you wish to do so.

We do want you to know that we are aware that there have been crashes related to this feature, and we hope to have fixes for those very soon. In the meantime, please share your other feedback in this thread.

Jon Olson | Programmer
Beta, Character Select/Create, Enhanced Squad UI, Play for Free, Raids, Streaming Client, & Native Mac

Tagged:
<13

Comments

  • Goettel.4389Goettel.4389 Member ✭✭✭✭

    I'm on a 1440p display but enabling or disabling scaling doesn't seem to do anything. Am I missing something?

  • Chorne.8195Chorne.8195 Member ✭✭✭

    My GW2 client had to repair data this afternoon, I don't know if that has anything to do with the issue. And the launcher was massive when I opened the game up but the UI was fine, didn't stick on DPI scaling, thank god, some people said that happened to them. ( By the way, as Boysenberry said, don't make it the default, it freaked me out when I opened the game yesterday. )

  • My last log in had to repair as well. Visually everything looked the same on my account. I'll post again if anything changes.

    The next time you get angry at someone try walking a mile in their shoes. After that, who cares! You're a mile away and you have their shoes! -Someone with more awesome quotes than me

  • I want to know if the issue of the DPI setting not remembering itself will be addressed. I have tried the supposed "fixes" to this (such as toggling with other settings to make it remember the checkbox, going into the actual game shortcut settings, etc) and none have worked. It's really annoying to have to go into my graphics settings and uncheck this feature every single time I log in, unless of course I feel like playing with a massive and blurry UI. I have even had it check itself back on randomly while I was playing the game. I'm glad the crashes are being looked into, but to me this is far more irritating than my game going down once in a while (since I know that crashes are always eventually resolved).

  • It was annoying to have this turned on by default as it looked horrible on mine. What was more annoying was the fact it wouldn't save when I unchecked the option. Thankfully someone on here posted a workaround of changing a second setting, like shadows, to force the game to save the settings. Thankfully that worked.

    Having it unchecked though hasn't changed the launcher back to normal size, and hasn't put the launcher back to the centre of the screen. (since the update launcher is about 1.5x bigger and appears near the bottom of the screen, with the lower half of it containing the buttons cut off the bottom). Is there a fix on the way to change that back to how it was before the update?

  • Game of Bones.8975Game of Bones.8975 Member ✭✭✭✭

    My only issue is having to go in and change the box each time I log in.
    I'm curious why this doesn't save while everything else does.
    Not a coder/programmer so please type slowly when you answer so I can understand.

    "That's what" -- She

  • I had no issue with it. I unchecked the box though, because I don't need it (running 1080P) and it makes no difference for me either way. Some others have reported that unchecking the box didn't 'stick' for them, so I tested this by exiting the game and restarting it. The box remains unchecked for me.

  • Solvar.7953Solvar.7953 Member ✭✭✭

    I appreciate that my mini map is now a reasonable size (really the only issue I had before even on the largest interface size). However, with DPI scaling, text and other stuff does not seem as sharp as before. So there certainly seems to be something of a trade off here - better sized UI elements at expense of sharpness. I'm running at 4K on a 40" monitor, so perhaps this is more an issue with this setup.

  • Jon Olson.8439Jon Olson.8439 Member ✭✭✭

    @cottonling.1368 : We are investigating why it does not save for some.

    From some of our experiments the app being blurry may be related to either how it was launched, or having a scaling that doesn't quite line up. We're looking into our options on what and how we can alleviate these.

    Jon Olson | Programmer
    Beta, Character Select/Create, Enhanced Squad UI, Play for Free, Raids, Streaming Client, & Native Mac

  • Vandril.3490Vandril.3490 Member ✭✭
    edited October 19, 2017

    @Jon Olson.8439 : I'm also experiencing the issue of the DPI Scaling setting not saving. In fact, after testing, of the few graphics options I tried to test, none of my graphics settings changes are saving. It's worth noting that I have not tested every setting option under the Graphics tab, but rather only a handful. In %appdata%/Guild Wars 2/, the GFXSettings.Gw2-64.exe XML file is not updating when I change settings and close the GW2 client. I imagine it's meant to. (Unless it's a "default settings" file?) I use the 64-bit GW2 client, and editing this file does change my settings when I load the game.

    For example, I was able to default the DPI Scaling setting to off by finding its corresponding line in the GFXSettings.Gw2-64.exe XML file...

    <OPTION Name="dpiScaling" Registered="True" Type="Bool" Value="true"/>

    ...and changing Value="true" to Value="false".

    So, instead of being unable to keep DPI Scaling disabled when I restart the client, DPI Scaling now turns itself off every time I restart the client.

    All of this is, of course, a new issue that only popped up after the recent patch which introduced DPI Scaling as a setting.

  • Running 1920x1200 windowed fullscreen with an interface size set to Larger, most text elements are now blurry. Thankfully not the chat window. Small, Normal and Large are fine as before.

    Comparison Large / Larger

    I've tried the in-game DPI scaling checkbox as well as switching between Application / System from the 'Override high DPI scaling behavior' dropdown of the Gw2-64.exe properties, to no avail.

  • I think it has promise, but...

    At some point, my performance (MacOS 64-bit) has fallen off, so I decided to try running at the second-highest resolution, which definitely helps. But that also puts me into a weird place with DPI scaling. If I turn it off, things are so small that Large doesn't do the job, but if I turn it on, things are so large that Small doesn't do the job. What I'd want would be if I could turn DPI scaling on, then have an Extra Small setting.

    One of the annoying things with DPI scaling on and using Small is that things are so large that the chat text can't fit between the left side of the screen and the icon bar, so it gets scooted up into my field of view, which is very annoying. The only choice I have is to move the chat to the top of the screen and have the party swap to the bottom, which is better functionally but aesthetically really puts the text over top of everything I want to look at.

  • I have just tested Vandril.3490 's idea on my 32 bit client, wherein the DPI Scaling option cannot be disabled due to the Tickbox being greyed out - and it appears to be working.

    The DPI Scaling option is now unchecked, but still greyed out, my graphics are back to normal, and the setting has persisted through several restarts.

    1. Take a backup copy of the file : C:\Users\\AppData\Roaming\Guild Wars 2\GFXSettings.Gw2.exe.xml
    2. Edit the original file, changing the text :
      to now read :

    Note: - change just the last value to "false".

  • I still have the enlarged launch screen. Unchecking the DPI in the game (after I finally got my changes to not revert on logging out) does not affect this. Can the launch screen also be set to ignore the DPI?

  • My UI problem is solved, and anything to do with the log in window?
    It's still too big.

    https://imgur.com/uD3X5mn

  • I use the x64bit client:

    1) Edit: C:\Users\AppData\Roaming\Guild Wars 2\GFXSettings.Gw2-64.exe
    2) change the last value to "false"

    Thanks to Pookie.1078 for this fix!

  • Lillith.5724Lillith.5724 Member ✭✭
    edited October 19, 2017

    Well, unchecking the DPI box definitely works, but it defaults back when I relog. I'm not exactly sure I understand what do here as Pookie suggested since I don't like to mess around with the properties portion of the files.
    This is making my eyes water and giving me headache.
    The log in screen takes up almost my entire desktop as well.

    @Pookie.1078 said:
    I have just tested Vandril.3490 's idea on my 32 bit client, wherein the DPI Scaling option cannot be disabled due to the Tickbox being greyed out - and it appears to be working.

    The DPI Scaling option is now unchecked, but still greyed out, my graphics are back to normal, and the setting has persisted through several restarts.

    1. Take a backup copy of the file : C:\Users\\AppData\Roaming\Guild Wars 2\GFXSettings.Gw2.exe.xml
    2. Edit the original file, changing the text :
      to now read :

    Note: - change just the last value to "false".

  • evilsofa.7296evilsofa.7296 Member ✭✭✭

    Known good way to save DPI scaling setting without mucking about with files:

    1. While in game, toggle DPI scaling to whichever setting you want.
    2. Toggle Shadows to any other setting (doesn't matter what)
    3. Quit to desktop
    4. Relaunch the game
    5. Toggle Shadows back to the way you had it before

    DPI Scaling will now be saved the way you want it. This is apparently a long-standing issue that has worked with other settings that wouldn't save in the past.

    If things still aren't working, did you set your settings file (whichever it might be) to be Read Only in a previous attempt to force settings to save and then forget about that?

  • @Malikah.3761 said:
    Running 1920x1200 windowed fullscreen with an interface size set to Larger, most text elements are now blurry. Thankfully not the chat window. Small, Normal and Large are fine as before.

    Comparison Large / Larger

    I've tried the in-game DPI scaling checkbox as well as switching between Application / System from the 'Override high DPI scaling behavior' dropdown of the Gw2-64.exe properties, to no avail.

    So i did not imagine that. I have the same resolution 1920x1200 and have the same Problem. I have the window set to fullscreen.

  • I'll repost here then. UI text (like inventory and such) on some parts of the screen becoms blurry when using interface size smaller. Normal - no issues. Not sure about larger sizes since I don't use that.

  • Rabbi Rick.3194Rabbi Rick.3194 Member ✭✭
    edited October 19, 2017

    The issue with DPI scaling that I am experiencing (in addition to the "no save" issues above - which seem to be fixed by checking/unchecking another setting), is that when DPI scaling is turned on, the mouse pointer is HUGE. The pointer size does not change with the ui size setting; therefore, I can't run with DPI scaling on.

  • @CarbonylGoat.5147 said:
    My UI problem is solved, and anything to do with the log in window?
    It's still too big.

    https://imgur.com/uD3X5mn

    Echoing this, the launcher is still gigantic for some reason, even with DPI unchecked in-game.

  • The DPI setting will not save for me either. Every time I log in, my chat box covers the majority of my game and my cursor is the size of my finger. Then the log in screen keeps hiding at the bottom of my screen and I have to drag it up every time I load the game. This is a very weird feature. I'm glad to know it isn't just me having issues

  • So, DPI Scaling remained unchecked for me until I needed to make a screenshot of a character. Whenever I make screenshots of my characters (usually in poses or standing positions), I change my settings to "Best Appearance." I did that today, and the DPI Scaling got checked. Then I went back to Auto-detect when I was done and unchecked the DPI Scaling. Then I logged back in...

    The DPI Scaling was checked. I'm on a laptop so it doesn't matter much to me, but it seems like if you're running GW2 on high settings/highest settings, then DPI Scaling will auto check, and it will auto check when you change settings.

  • This new patch has brought in massive issues to my game. My framerate now randomly drops to very low amounts, making the game in general utterly unplayable. This was not an issue on Monday.

  • Ever since the update, text on the trading post window has become blurry. It's crisp in all other parts of the UI (from what I could tell so far). It doesn't matter if I have the option checked or unchecked.

  • What is up with the mouse cursor?? It has never been that easy to see, but since this update the cursor is a fraction of the size it used to be and is almost impossible to see. This is probably one of many unintended consequences of making such a drastic change, but now is a serious QoL loss. Please make whatever change needed to restore the cursor back to a visible size please.

  • Blodeuyn.2751Blodeuyn.2751 Member ✭✭✭
    edited October 20, 2017

    The problems I am having with DPI scaling:

    Resolution: 3840 x 2160 with the UI set to Small
    System: Windows 10, GTX 1080 Founders Edition, Samsung 23.6-Inch UHD-QHD Monitor
    Client: 64-bit

    Issues:
    1. Many windows (such as Friends, Guild, Inventory, Trading Post, Mail, WvW info window [B]) are about 15-20% larger than they "should" be.
    2. The mouse cursor is about 15-20% too large as well.
    3. All text is too large which makes it appear to have anti-aliasing issues. I think this is what people are describing as blurry text.

    The mini map, chat window, and skill bar are a good size, so no issues there for me.

    Maybe the best way to describe my issue is that prior to DPI scaling, we needed an option to set the UI to Extra Large. Now it feels like we need an Extra Small option.

    Blodeuyn Tylwyth
    Quaggan OP [QOP], League of Extraordinary Siegers [LEXS]

  • @skaia.9582 said:
    Ever since the update, text on the trading post window has become blurry. It's crisp in all other parts of the UI (from what I could tell so far). It doesn't matter if I have the option checked or unchecked.

    I have this issue, and also with text in merchant windows. The option toggle has no effect for me either.

  • My problem is:
    Without DPI: everything is so small i cant even read, even with UI scale set to max.
    With DPI: everything gets extremly big like HUGE ! the UI covers 70% of my screen, and i cant make it smaller.
    Thats on 4k so i gotta make the resolution lower on the game (which makes it annoying cuz when i need to alt-tab to another screen it takes a couple seconds cuz of the resize) i was really hoping the DPI scale could fix it, but having the skill bar being bigger than my own char is a no no.

  • TheQuickFox.3826TheQuickFox.3826 Member ✭✭✭✭
    edited October 20, 2017

    Build: 83,379 (Update 2 - October 19th, 2017) has fixed the "DPI Scaling" setting not being saved error for me.
    (Windows 7 Pro x64, GW2 X64)

    Ascalon Will Prevail!

    GW Wiki user page | GW2 Wiki user page

  • i absolutely 1 billion percent disapprove of this dpi nonsense, when ticked everything is giant slow and horrid looking
    when unticked im not completely sure its not just in my head but it doesnt feel quite right

  • I would very much like for you to revert this until you can figure out how to introduce it properly. The blurry UI text is really starting to give me a headache.

  • I agree with the post above. Very annoying atm. Currently keeps launching with the option checked and I need to uncheck it because everything just looks so bad and blurry.

  • @Sultane.9150 said:
    I agree with the post above. Very annoying atm. Currently keeps launching with the option checked and I need to uncheck it because everything just looks so bad and blurry.

    Try making a change to some other graphics setting after unchecking the box, then log out and restart the game, and it should stay unchecked even after reverting whatever second setting you changed back to where you had it originally.

  • I have to turn it off every time I login.

    I makes the game look terrible.

    Default to off please!

  • Actually, in my case when we talk about blurry ui text, the dpi checkbox on or off makes no difference whatsoever. Come to think of it, nothing at all happens when i turn it on or off, so I'm not even sure what that setting is supposed to do.
    All I know is that ever since this Halloween patch was introduced, me and many others suffer from blurry ui text when using an interface size other than normal.

  • tippolit.3591tippolit.3591 Member ✭✭✭

    Given the fact that so many people have a problem with this, why in the world would this change not be reversed until a proper fix can be implemented?

  • CrimsonNeonite.1048CrimsonNeonite.1048 Member ✭✭✭
    edited October 21, 2017

    @Goettel.4389 said:
    I'm on a 1440p display but enabling or disabling scaling doesn't seem to do anything. Am I missing something?

    Do you mean text is still unreadable in1440p? Because I see the same issue, unless I switch back to native or 4k resolution instead.

  • DPI Scaling defaults to On every single time I launch the game now. And my toons all look horrible, before or after turning it off. I'm on the Mac 64 bit client. The game is unplayable for me until this is resolved.

  • This option should not be on by default, it confuses a lot of people and the term dpi scaling isn't something that is "user friendly" so in a lot of cases the average player won't know what is this is or what it represents.
    Personally for me I don't know why it the option doesn't save and it seems that this scaling is also applied to the splash screen?...

  • evilsofa.7296evilsofa.7296 Member ✭✭✭

    The good: I have a 24" 2560x1440 monitor, and for the first time I am now able to use the native resolution, set Interface to Larger, and be able to read everything.

    The bad: well, almost everything. I am now doing the Personal Story, and the text in the Cinematics is extremely tiny. I don't think I've seen any other example of text unaffected by DPI scaling yet.

    I am using Windows 10 and in Windows' Display settings, I have Scale and Layout set to 150%.

    I do not seem to have the blurry text problem.

  • Windows 7 user: 1920x1080 screen
    I like that I can choose the ON or OFF position. I don't like that it does not remember my choice to be OFF .
    I like that since this update, after i tick the OFF box, I can actually read the text now. For use outside of game I have large text etc. For in game everything is smaller because I want to see more of the area and therefore I wasn't able to make out most of the text: though that red text may as well be invisible...i can't make out those letters at all, large or small scaling.
    I hope this helps you all. Thanks for the game, it is a lot of fun.

  • Llethander.3972Llethander.3972 Member ✭✭✭
    edited October 21, 2017

    @Goettel.4389 said:
    I'm on a 1440p display but enabling or disabling scaling doesn't seem to do anything. Am I missing something?

    It's most likely that your DPI settings are set to 100% (ie. "normal") and, therefore, you would not notice a difference. If you were to set your DPI Scaling in your OS settings to 120% and then enable the DPI setting in GW2 you would likely notice a large difference.

  • Hamfast.8719Hamfast.8719 Member ✭✭✭
    • Running GW2 on 64 bit Windows 7 (1920x1080 Full Screen)
    • Throwing in the -32 switch so that SweetFX works.
    • The DPI Scaling option is checked, and grayed out so that I am unable to change it.
    • The UI elements are supposedly set to "small", but they are far bigger than normal. My various windows completely cover the screen.

    Please fix ASAP so I can get on with the business of enjoying Halloween.

    Build someone a fire, and they'll be warm for the rest of the day.
    Set someone on fire, and they'll be warm for the rest of their life.
    - Unknown Fire Elementalist

  • I still have to uncheck the DI scaling every time i log in like lots of people. Also the Trading post is blurry. When will this be fixed? It is not ok to play like this! Before launching an update check it!

  • I bet most people don't even use DPI scaling in Windows at all, but like me run @ native 100% setting.

  • What are the chances the Windows scaling percentage is the the same people want for the game anyway. Right now players would have to change their system settings every time before launching the game or find a compromise.

    Wouldn't it be better to have a slider or a field to enter a ratio for scaling in game too, to be independent of the OS value?

  • This new feature stopped 3D, Stereoscopic, from working. due to that I say the following: If your team decides to remove Stereoscopic support (after giving it to us for since GW2 start!) we need to know. I, for one, will play much less in 2D and do not play using VR at all; most of us do not. I will stop spending money to do expensive things and won't buy in your store. GW2 will become one of many back-burner games for me. It was literally the 3D that kept me hooked and playing for hours. The 3D effects on the Legionaries was also amazing. If you pull 3D support in favor of higher VR resolution without giving us a 3D choice, then in my book you are criminals for causing all of us that paid for the Stereoscopic in your "Options" panel. I will stop trusting ArenaNet and flame you in as many places as possible on customer service.