Low FPS Issues [MERGED] — Guild Wars 2 Forums
New Super Adventure Festival Avatars! In celebration of this year’s Super Adventure Festival, we’ve added a group of new avatars to the bank. Enjoy the new look!

Low FPS Issues [MERGED]

SgtSarcasm.1653SgtSarcasm.1653 Member
edited January 14, 2018 in Account & Technical Support

Hi,

I've recently returned to GW2 after several years away, and I'm running it on a brand new desktop PC.
The specs on my computer are: Intel Core i7-7700, GeForce GTX 1080 Ti, 16 GB DDR4 2666 MHz. I'm also running the game from an SSD.

I tested my FPS on Heaven Benchmark 4.0 on highest possible settings @ 2560x1440 and got ~80-100 fps on most scenes, occasionally dropping down to a steady 60-70 fps on some more intense scenes.

However, when running GW2 I sometimes randomly start getting really low fps (30-40), even personal story instances and fractals. I could understand it if I only got fps drops during massive world event bosses or similar situations, but a lot of the time during world event bosses I have a solid 80+ fps.

Any help with fixing this would be appreciated, as this is really frustrating.

Tagged:
<<13

Comments

  • As I stated in the title, after PoF came out I've had insane FPS drops (1-2 FPS, basically a slide show) in the city and while out in the world whenever i do anything, including just turning my camera. My CPU usage has also skyrocketed whenever I launch GW2 from about 5-7% while idle on a web browser to 100% from just launching the game (50% briefly after the launcher is opened). Before PoF came out, I was consistently running GW2 at 40+ FPS before PoF release on relatively high settings.

    Also, this is only happening in GW2. I've had no problems whatsoever with frame drops and high CPU usage in games such as Warframe and World of Warcraft. Knowing this, I contacted support to see if it may be a problem on their end, but it's been 3 days and they haven't replied.

    It sucks because I've barely been able to play PoF which I was pretty hyped to get started on. If anyone else has experienced theses issues please comment so ArenaNet can take notice and see if it really is a problem on their end.

    Specs:
    Video Card - EVGA Geforce GTX 960 SSC
    Processor - Intel Core i7-2600 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
    8GB of ram

  • I'm having the same problem. The first few days was running fine didn't lag at all in the new maps but about 2-3 days ago my frame rate jumps to 15 to 3 frames per second, its not playable at the moment and I tested other games as well and those games run fine. I don't have the best pc but this never happens to me and i shouldnt be getting 3 frames per second. I'm guessing the latest patches caused the game to have a memory leakage cause when i run task manager while running gw2 i can see gw2 eating up more memory then it normally does. I hope they fix this soon so I can actually play the game.

  • same problem over here, i also had 2 instances where the game blackscreened and didnt close but locked up my PC for a few minutes until i was finally able to CTRL+ALT+DELETE and see that it was using 99% memory and i still couldnt end task.

  • I can confirm that also, my CPU does some pretty odd spikes and gw2 spikes to 80-90% CPU usage at times, which did not happen before the expansion.
    Running an i5 4670k, 16gb ram, Nvidia 1060 6GB. which is a fairly good system and nothing else spikes up my cpu usage.

  • Im from Malaysia. everytime when im at PoF maps, i got huge lag. other maps are smooth as silk. pls help

  • ThomasC.1056ThomasC.1056 Member ✭✭✭

    Probably the same issue here. I opened a thread some days ago about it. Unbelieveable FPS drops in some places, insane CPU and memory usage... Something is really wrong in the coding. No solution expected. Maybe ANet should gift me a better computer ?

    Look at that—you broke Scruffy's sarcasm meters. ~ Taimi.

  • your not alone i got a gtx 1080 with a i7 67k i use to be able to run this game from 80-100 fps now i average 40-50fps with occasional fps drops down to 5-10fps that dont go away until i reset my client. i dont have this problem with any of my other games.

  • What NVIDIA driver version are you guys running? It's been reported what version 388.13 and other older drivers from r387 branch may cause this issue.
    However, it seems like latest driver 388.31 works much better. I was unable to reproduce massive FPS drops with this driver on my GTX 970 and 980 Ti.

  • SkyShroud.2865SkyShroud.2865 Member ✭✭✭
    edited November 26, 2017

    Toons are not the only graphical objects in the game. The game is now badly optimized with anet throwing alot of small objects to decorate the map thus there will be maps that can be laggy for that reason. Of course, anet is never gonna optimize those.

    Founder & Leader of Equinox Solstice [TIME], a Singapore-Based International PvX Guild
    Henge of Denravi Server
    www.gw2time.com

    --

    Explanations of WvW Structures & Populations Issues

  • @Predator.1398 said:
    What NVIDIA driver version are you guys running? It's been reported what version 388.13 and other older drivers from r387 branch may cause this issue.
    However, it seems like latest driver 388.31 works much better. I was unable to reproduce massive FPS drops with this driver on my GTX 970 and 980 Ti.

    I've been running version 388.31 for some time now.

  • I've been having the same problem since Saturday afternoon.
    I play on a laptop, so it is not super high end, but the game always ran well and with few issues. I've tried: rolling back the main .dat file to a September back-up and updating, clearing the cache in AppData, installing the new nVidia drivers (to 388 from 384), and updating Windows 7. My character models are set to Low. None of it helped.
    Now, here's the thing. I get 50-60 FPS and everything is alright while I'm doing "simple" things, like gathering in my home instance and dailies. The moment I have to fight, it drops to 5-10 FPS and becomes a slide show. I ran the diagnostics and it looks like the game keeps using the disk (I can hear it turning on and off the way it really, really should not). I'm afraid to play the game any more at this point, and it really sucks because we've got a new episode coming tomorrow.

    I hope there's a solution to this. The problem is completely new and very confusing.

  • MadBomber.3719MadBomber.3719 Member ✭✭✭
    edited November 27, 2017

    do you have shadowplay on btw? im pretty sure it's nvidia shadowplay. I had to turn mine off . my frames would drop to like 9 fps randomly but once i turned it off and restarted my game i had no issues.

    i have similar specs with a OC'd 7700k & a 1080ti-- definitely shouldn't be dropping frames but yeah try turning off shadowplay.

  • You can try updating drivers or tweaking settings but it will not help since that is not the problem. Performance problem is a known issue for GW2, something that ArenaNet never really tried (or plans) to fix. What boggles the mind tho is that ArenaNet knows it, but they still keep releasing assets and map design that cannot be handled by the GW2 client. I mean really, that is something mind boggling...

    New maps coming out right, I bet that map will be beautiful but performance will be terrible (like always).

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    "What good is battle prowess when you are too dead to make use of it?" - Draco Ud Verik (Human Ranger) | Guild: Order of the Ebon [Hand]
    . My GW2 content charts: (1) PoF , (2) Personal story (pre-Claw Island/Orr) , (3) LWS 4 , (4) HoT , (5) LWS 2 , (6) Orr campaign , (7) LWS 3

  • Guys, I recently bought a new setup and upgraded from a gtx960 with a 3770kto a 1080ti and a 8700k. I still get the same fps I had with my old setup. What the hell? Is it the game or is my pc broken?

  • Btw it's 60 fps. In pubg I got 60 fps before the upgrade and now 115-144 fps.

  • @Crusartas.9502 said:
    Guys, I recently bought a new setup and upgraded from a gtx960 with a 3770kto a 1080ti and a 8700k. I still get the same fps I had with my old setup. What the hell? Is it the game or is my pc broken?

    Please help us with more information and to not participate in a guessing game.

  • ArmoredVehicle.2849ArmoredVehicle.2849 Member ✭✭
    edited December 11, 2017

    Press F11 > Graphics Options > Check "Frame Limiter" if it's set to 60 - If not then your V-Sync is enabled. In most cases the only reason you'd want to go higher than that is if you have a 144hz monitor. However if your monitor is 60hz I suggest leaving the limiter to 60 as it would only put unnecessary load + higher temperatures on your GPU with no benefits.

  • Ofc Framerate is uncapped and vsync is turned off, already checked that.
    Still can't pass 60fps. I think it's the game that's been poorly optimized.

  • Eros.6801Eros.6801 Member ✭✭
    edited December 12, 2017

    Hello, 2 months ago i bought a new laptop with gtx 1050 i7-7700 to replace my old gtx 650ti - i5 but i had very low fps on my new laptop around 15 - 20 fps. I tried to do everything but it didn't work. When i was desperated i read somewhere about a fix, after that it worked like a charm. Here is the method :

    • Check for newest graphic driver.
    • Run > msconfig > Boot > Advanced Options > Check "Number of processors" then drop down and pick highest number in my case is 8 > Uncheck "Maximum Memory".
    • Restart and run gw2.

    I don't know if this work on you tho because my case was a newly bought laptop but not replace new graphic card. Atleast it worked for me

    MEH !!!

  • One reason you are not seeing much performance gain is the i7 3770k, though older, has a good single core performance and isn't much lower quality in said category as than the i7 8700k. Also, if you have Vertical Sync on to prevent screen tearing, then you are capped at 60FPS.

    Wolf Moonstar
    Dragon Council, Third Seat: Jade Sea Haven (Jade) of Ehmry Bay
    My Ryzen Rig

  • Spladian.8346Spladian.8346 Member
    edited December 14, 2017

    V-sync only caps your fps to 60 if you have a 60hz native monitor. If you have a 165hz monitor then your v-sync cap will be 165 - assuming you have the horsepower to push fps above that. If you're computer isn't as strong, but have a 165hz monitor, then your fps will be as much as your computer can render.

  • I just upgraded from the i7 3770k (@4.3ghz) to a measily i5 8400 and I have some great noticeable performance increase. The only new components are : motherboard, cpu, and ram. The rest remains unchanged for me.

    • Even with the same identical settings ingame.
  • Haadi.9764Haadi.9764 Member ✭✭

    Is anyone still experiencing this? My fps was fine before but it started to drop suddenly down to 4-7fps before going back up again in the last 2 weeks. This week it got worse, it's 60+ when I first boot gw2 then drops and stays at 20s fps after about 15minutes.

    I'm playing on a 3 year old laptop with i7 4700, GTX 860m and 8gb ram. I used to run it with low/medium settings at 1080p and get 40-60fps. Now I can't even get stable fps with lowest settings at 720p.

    I tried playing other games like Overwatch, Paladins and Heroes of the Storm and they work fine with medium/high settings.

  • Kymi.8659Kymi.8659 Member
    edited January 2, 2018

    anyone still having high lag and load times for wp's on the pof maps? its so bad at times my mounts dont load and the maps arent filled in. very frustrating when you are trying to follow a leggy squad to get elegy mosaics for a Flames of War legendary torch, this is gonna take months at 2 or 3 per pop camping the same leggy mob for weeks on end :( Is 3 to 5 mins to load from Elon Riverlands to Oasis to long? by the time i get there the mob is dead :( also i have No probs with any of the other maps but the POF ones, central tyria and HoT maps work fine

  • I'm having the exact same problems as you... haven't found a solution yet

  • I play with settings on low, except player textures, and native sampling. But whats funny is if i go to the most of the old maps from the core game, my fps is like 50-80. Which it will dip during events and stuff as expected but its still visually tolerable. but in pof areas, its like 15-32 and in the single digits during bounties (which i could write a whole page on the ridiculousness of spell spam on bounites and events..), & certain areas with alot of architecture or in the new windswept guild hall. I thought maybe its because less people are on the old world maps. Or they just haven't updated the hardware for the pof servers to handle the load? Although my video cards are like 9 years old, I still have a new 256gb samsung SSD and a 2.8 oc'd to 3.2ghz i7 930 cpu and 12gb ram on win10. I havent had a problem til hot and pof xpacs. And wow, swtor, eq2, blade&soul, was fine last time i played them a year or so ago.

    I made maps using the unreal engine/UED as a hobby back in the early 2000s for unreal tournament 2k* games and there was a little trick you could do that would put an invisible wall up basically, between really open areas or areas that had a lot of animated textures, static meshes, mountains, or just clutter. And it sorta obscured stuff further behind it from your video card having to render it all in the scene. Ive always wondered if mmos utilized similar things in their map editing software. Sometimes you can notice this if you go in a far corner away from everything (like the edge of a map) and look away from the center of the area (into nothingness..) and if you have your options window open you'll see your fps go really high when you look away and go back down when you look back towards the map. This works if you look up at the sky or down at the ground too while zoomed in 1st person if you dont have your settings on ultra. Also if the game crashes, the Guild Wars Game Client will not end in the task manager, and I cant force End it. It usually takes it 5-10 mins to close on its own, or I will reboot, which is quicker to get back in the game. Which sucks keeping people waiting on you, or missing out on a bounty or something because I can get back in quick enough. All threads I find on this subject are dead ends/redundant and unresolved.

  • Guizao.4167Guizao.4167 Member ✭✭✭

    I have this very same problem since 2014. I know that my laptop is potato but I should be able to run the game at +30FPS.
    Configs:
    i5 2450M (2.5ghz)
    geforce 540M (my bottleneck)
    6gb RAM

  • lucvw.6025lucvw.6025 Member
    edited January 12, 2018

    I have this problem too, but not only in PoF, but also in HoT. The only thing that helps is shutting down my computer and restart. Then everything works fine. So I think it has something to do with Windows or display driver and not with GW itself, because it only recently started. Still, it would be nice that someone of Arenanet could confirm this problem and suggest a possible solution...

    Config: i7 - 5960X
    Geforce GTX980
    32GB RAM

  • About 2 days ago my game has lowered in frame rates, and has little mini lag spikes. walking around, turning the camera, generally everything is causing these little "skips". tried reseting my computer, deleting cache files, and lowering graphics, nothing is working. The game was running perfectly before.

  • Just random $0.02 but it seems everyone in the thread is running an Intel CPU and Micro$oft just rolled out the OS patches for the two specter vulnerabilities and the meltdown vulnerability effecting Intel CPU's at the hardware level, along side the last roll-outs of the fall creators update for windows 10. Why do I feel this has something to do with Micro$ofts mess up.

    Are you guys having these issues in other games as well or just in GW2?

  • Hi All,

    Just started playing GW2 again.
    I remember when i played when the game Launched back when i was young.. MY PC ran GW2 Horrible.

    But now i have.:
    GTX 970 with 4GB.
    Intel Core i5-4590 @3.30GHz.

    I can Play WoW, ESO, BDO almost every game i know on Ultra Settings.
    But when playing GW2 on "Best Appearance" i get like 30 FPS and when i look around with my mouse it lags in a odd way.
    Like the game is lagging?... and i havent tried that for +2 Years in any game.

    SO can anyone tell me why this game runs so bad on my PC?
    I feel a bit lost over paid 49.99€ for an expansion that runs terrible on my PC :angry: :-1:

    Hope any 1 can clear my head :anguished:

    Best Regards
    Stefan Rumle

  • GTX 970 4GB
    I5-4590 3.30Ghz

    I too have only 30FPS....

  • @Crusartas.9502 said:
    Guys, I recently bought a new setup and upgraded from a gtx960 with a 3770kto a 1080ti and a 8700k. I still get the same fps I had with my old setup. What the hell? Is it the game or is my pc broken?

    I have the same FPS with my new PC too.
    My 5 Years old PC is having the same FPS as my new...

  • eoz.1834eoz.1834 Member ✭✭
    edited January 14, 2018

    hi. having issue about random massive fps drops. its same map and same character but the difference is "I had to restart the game client after the fps drop". this issue happens me after january 9th update before that everything was smooth. playing on asus x550vx laptop. intel i7-6700HQ, 16gb ram, nvidia geforce gtx 950m. got latest windows 10 update and all drivers updated.

    edit: it started to happpen since january 9th update. never had this before. playing gw2 on same computer almost a year. geographical location: eastern europe and game world is desolation.

    https://imgur.com/a/TTbV3

  • @ArcanistSeven.8720 said:
    your not alone i got a gtx 1080 with a i7 67k i use to be able to run this game from 80-100 fps now i average 40-50fps with occasional fps drops down to 5-10fps that dont go away until i reset my client. i dont have this problem with any of my other games.

    Same exact issues here. Used to run great, now it runs alright, but fps drop here and there till restart. Makes me pretty mad.

  • Hey folks,

    There were quite a few individual threads about FPS concerns. Whether you have a new PC or an old one, whether you just joined the game or have played for years and have noticed recent decreases in your FPS, it seems prudent to merge the threads into one and relay a request internally for someone to take a look. I know that merging sometimes somewhat "garbles" the conversation, but this is an important issue, and the breadth of reports in a single merged thread only helps to emphasize your concerns. So I hope you'll be ok with the merge, and of course if other players have issues with FPS, please add them here.

    NOW... having said that, I believe that it would be super helpful for you to tell the team a few things:
    1. When did this issue first start?
    2. Has it been consistent across time, or has it become worse lately? Or has it come and gone (been intermittent) over time?
    3. What is your general geographical location?
    4. On what game world are you playing?

    If you can edit your posts in this thread, or post a new one in this thread with more information, we'd really appreciate it!

    Thanks so much!

    Gaile Gray
    Communications Manager: ArenaNet
    Fansite & Guild Relations; In-Game Events; Community Showcase Live

  • edited January 14, 2018

    Hey folks,

    Can you please look at this thread and this one (about the Mac 64-bit client) and see if the solution the OP used is helpful to you, as well?

    Gaile Gray
    Communications Manager: ArenaNet
    Fansite & Guild Relations; In-Game Events; Community Showcase Live

  • Bloodstealer.5978Bloodstealer.5978 Member ✭✭✭✭
    edited January 14, 2018

    The sudden FPS drop to a solid 30FPS can happen anytime any map, any instance.. this has been happening from my own experience since the around the time the Microsoft Fall update hit. I am not convinced that is the issue but something has definitely been happening within the game ever since.. irrespective of what graphics settings are used.

    I always set my system to Win Fullscreen with frame limiter to 60/vsync on and have always got a pretty stable 60fps.
    This issue instantly drops the fps randomly down to 30fps but fixes itself back to 60FPS after either ALT-TAB to desktop or going to graphics setting in game and switching to Window, then back to Windowed fullscreen.. however I am finding this issue is manifesting itself more often now.. almost as if a 3 way WvWvW zergfest is exploding around the map... which tends to lead me to think its actually something going on in game causing the issue not our gpu's or their respective drivers/OP sys etc.

    Life is what YOU make it... NOT what others tell you!

  • It may be more helpful to list the IP address of the map you are in when experiencing issues, rather than the name, as there may be more than one instance of a map.

    Good luck.

<<13
©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.