Eerie Driftwood not spawning - Page 2 — Guild Wars 2 Forums

Eerie Driftwood not spawning



  • Still broken for me as well

  • Still same issue for me as well. Not fixed for me and did the meta after updating client

  • It's possible we have to wait for reset, so let's give it an hour.

  • Same, still broken. Can't harvest any of the spawned wood after Zohaqan, it stays inactive to me.

  • Nodes have not respawned for me either.

  • Still broken after new Meta after reset.

  • Just completed the meta after reset...still no nodes...watched others in the group gather the node right beside me but I could not interact with it

  • I am assuming we don't need to do another ticket?

  • still broken :(

  • it is now the 12th and I still have no respawn of the eerie driftwood for me to try get the stuff from it for the collection. Any idea when will be fixed. Thanks love the map <3

  • I dont know if I should do a ticket since we are all on this thread . Do I?

  • @Surell D.4537 said:
    I am assuming we don't need to do another ticket?

    I'm going to update mine via email and inform GMs that fix didn't work.

  • Moogri.1935Moogri.1935 Member ✭✭

    Same here, mine isn't spawning either :(

  • Guys. There is no bug (i think).
    Its the fact that initially all the driftwood nodes on map were spawned and when you harvested everything in one day (as I did too) now the are respawning a few nodes a day.
    Got my collection stuff few days in. And I see much-much less active driftwood nodes when non-gatherable driftwood nodes all over the beach.
    Use skimmer, check the coastline. Dont forget there is some driftwood on southern island shore as well.

  • There's no bug? Do you know it's been a week since any driftwood has spawned for us? Come on man.

  • Hey friends,
    We're investigating why the driftwood is failing to spawn again. Thank you for your patience!

    QA Embed
    Lord Faren Fanclub Member

  • Metatron.8347Metatron.8347 Member
    edited March 13, 2018

    Thank God I was only on this for 2 days before I came here! I am stuck on "What we do"
    Yesterday (12.Mar.2018), I completed the Meta 3 or 4 times, the logs had spawned but I got no Luminescent Seaweed but plenty of ruined logs. I came on today (13.Mar.2018), read that the bug had been fixed, So I quickly started playing only to find nothing respawning at all after completing the Meta Event. I tried more than one level 60+ axe, even standard to no avail.
    March 8 this thread was started, I do hope they fix it...Tonight!?:¬]

  • I finally finished the achievement because I found a node I hadn't harvested before. Searching places I don't visit that frequently payed off. For everyone else I hope the bug gets fixed soon.

    No skin should be exclusive to gem-store rng boxes.
    What really happened with mount skins

  • It's still not fixed, IG is still not fixed

  • Still no eerie driftwood spawning for me :angry:

  • Still no eerie driftwood for me.

  • Yeah, bugged.

  • Still not spawning for me either :(

  • aandiarie.7195aandiarie.7195 Member ✭✭✭

    Have you all tried a different character? and anet is it time gated?

  • None for me either, guess all we can do is wait.
    Might be helpfull for Anet if you guys post more details of your circumstances on this : ?

  • I have put in a ticket with an explanation as well as a screenshot. Yes we have tried multiple characters. It seems to be an account wide bug.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.