Game alt-tabbing or flashing desktop [merged] - Page 7 — Guild Wars 2 Forums

Game alt-tabbing or flashing desktop [merged]

1457910

Comments

  • Gotta love this....

    1803.png

    Still no response.

  • pomp.7314pomp.7314 Member

    @slayerking.3581 said:
    Found the problem, It's the new focus assist kitten they have put into the new winblows update. If you go to settings>system>focus assist and turn it all off, it does it much quicker now instead of sitting there for 10 seconds or so on the desktop.

    just like everybody else affected, it only started after the win10 latest update.
    This hasnt fixed it for me, but it only tabs to desktop for a fraction of a second now instead of several seconds now

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    @Dying Oblivion.8296 said:
    Gotta love this....

    1803.png

    Still no response.

    You may not be aware that due to high volume, tickets may take 10 days or more currently.
    Also, there is no current 'fix' (from the Devs) to this problem; just a request from the Devs to send logs/information.

  • maddoctor.2738maddoctor.2738 Member ✭✭✭✭

    @Wraithclaw.9081 said:
    I've just started having this issue today as well after a windows 10 update.
    Is anyone able to post a list of the current suggested fixes? (a summary/dot points with links would be wonderful)
    There is just way too many posts to sort through ^_^
    The issue seems to happen more to me on first game load, less so between loading different areas.

    The only "fix" that works is using Windowed Fullscreen instead of Fullscreen, that way all the issues go away.
    However, if you must use Fullscreen for performance issues then there is no universal fix available, yet.
    If the black screen takes a very long time, then you can disable Focus Assist, type Focus Assist in search, and set it to off. This will make the black screen take only a few seconds, with Focus Assist on it takes considerably longer. Doesn't solve the issue completely but it does make it more tolerable.

  • killermanjaro.5670killermanjaro.5670 Member ✭✭✭

    @GM Magister.8736 said:

    @Rayti.6531 said:
    This suggestion from "eragon03" on reddit fixed it for me.

    • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
    • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

    I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

    Thanks for posting this here, Rayti! I missed that Reddit post, so I'll see if this works for the folks I'm working with in support tickets. :)

    Will that "disable fullscreen optimization" effect fps in any way?

    Anyhow, I had the Windows 10 update a couple of days ago and I'm having the same issue as everyone else here. Since the update the game takes about 10-15 seconds longer to launch to the title screen, and between every loading screen it's flashing back to the desktop, although still showing the GW2 cursor & playing the music, which is making loading screens a lot longer than before the update. Have updated Nvidia drivers and tried rolling back to older drivers but to no effect. I've tried turning off the "Focused" notification thing, which has helped reduce the time that the loading screen flashes to the desktop, but it hasn't got rid of it from happening. Will submit a ticket through the support site as suggested in an earlier post.

  • @killermanjaro.5670 said:

    @GM Magister.8736 said:

    @Rayti.6531 said:
    This suggestion from "eragon03" on reddit fixed it for me.

    • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
    • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

    I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

    Thanks for posting this here, Rayti! I missed that Reddit post, so I'll see if this works for the folks I'm working with in support tickets. :)

    Will that "disable fullscreen optimization" effect fps in any way?

    Anyhow, I had the Windows 10 update a couple of days ago and I'm having the same issue as everyone else here. Since the update the game takes about 10-15 seconds longer to launch to the title screen, and between every loading screen it's flashing back to the desktop, although still showing the GW2 cursor & playing the music, which is making loading screens a lot longer than before the update. Have updated Nvidia drivers and tried rolling back to older drivers but to no effect. I've tried turning off the "Focused" notification thing, which has helped reduce the time that the loading screen flashes to the desktop, but it hasn't got rid of it from happening. Will submit a ticket through the support site as suggested in an earlier post.

    This is really tricky to answer with certainty, as it's going to depend on a lot of different factors with your setup and circumstances. I know for some people, disabling fullscreen optimizations leads to better FPS while for others it causes some more lag.

    It's worth trying it out and reporting back here (or, even better, to a support ticket) to let us know if it at least stopped the alt-tabbing issue from occurring. If it makes the game less playable for you, however, I totally understand and, unfortunately, you'll probably need to pick your poison until we can find a more preferable solution - deal with the alt-tabbing, or take the lower FPS.

    I really do hope we can find a proper workaround for this soon. It seems like it's really annoying. :(

    Lead GM Magister - The one that deals with tech support questions. (✿╹◡╹)

  • Death Slayer.1468Death Slayer.1468 Member
    edited May 22, 2018

    @GM Magister.8736 said:

    This is really tricky to answer with certainty, as it's going to depend on a lot of different factors with your setup and circumstances. I know for some people, disabling fullscreen optimizations leads to better FPS while for others it causes some more lag.

    It's worth trying it out and reporting back here (or, even better, to a support ticket) to let us know if it at least stopped the alt-tabbing issue from occurring. If it makes the game less playable for you, however, I totally understand and, unfortunately, you'll probably need to pick your poison until we can find a more preferable solution - deal with the alt-tabbing, or take the lower FPS.

    I really do hope we can find a proper workaround for this soon. It seems like it's really annoying. :(

    I did some research regarding this issue and when I use Reshade the issue is not present. (Tested with latest version as of this post v3.3.2)

    I play the game in windowed fullscreen myself so I don't have the issue but though to share my findings.

    Maybe people with issue could try it out, no shaders need to be downloaded/used for it to work. It might also affect performance however it is some information that can be used to properly find a solution to the issue.

    EDIT: I would like to let Anet know of some technical stuff on what might cause the issue but I don't see creating a support ticket to be the correct solution nor post in here. Please let me know if a general support ticket should be used or if I should provide details in a different matter.

  • killermanjaro.5670killermanjaro.5670 Member ✭✭✭

    @GM Magister.8736 said:

    @killermanjaro.5670 said:

    @GM Magister.8736 said:

    @Rayti.6531 said:
    This suggestion from "eragon03" on reddit fixed it for me.

    • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
    • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

    I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

    Thanks for posting this here, Rayti! I missed that Reddit post, so I'll see if this works for the folks I'm working with in support tickets. :)

    Will that "disable fullscreen optimization" effect fps in any way?

    Anyhow, I had the Windows 10 update a couple of days ago and I'm having the same issue as everyone else here. Since the update the game takes about 10-15 seconds longer to launch to the title screen, and between every loading screen it's flashing back to the desktop, although still showing the GW2 cursor & playing the music, which is making loading screens a lot longer than before the update. Have updated Nvidia drivers and tried rolling back to older drivers but to no effect. I've tried turning off the "Focused" notification thing, which has helped reduce the time that the loading screen flashes to the desktop, but it hasn't got rid of it from happening. Will submit a ticket through the support site as suggested in an earlier post.

    This is really tricky to answer with certainty, as it's going to depend on a lot of different factors with your setup and circumstances. I know for some people, disabling fullscreen optimizations leads to better FPS while for others it causes some more lag.

    It's worth trying it out and reporting back here (or, even better, to a support ticket) to let us know if it at least stopped the alt-tabbing issue from occurring. If it makes the game less playable for you, however, I totally understand and, unfortunately, you'll probably need to pick your poison until we can find a more preferable solution - deal with the alt-tabbing, or take the lower FPS.

    I really do hope we can find a proper workaround for this soon. It seems like it's really annoying. :(

    Thanks for the reply. I've given it a brief try and it does seem to stop the loading screens flashing back to the desktop, but instead it flashes to a plain black screen for about the same duration (or maybe fractionally quicker), so I'll run it like this for a while and see how it goes fps wise. I've put it all in a support ticket with the log file and Game Advisor files attached as requested, so hopefully that'll give some information that might help find a fix in the future.

  • videoboy.4162videoboy.4162 Member ✭✭✭

    My computer just updated about 20 minutes ago and I'm now being hit by this too.

  • I couldn't see if anyone brought this up, so sorry if it's been said already, but I think that it's less an issue with the loadscreens and more with what's happening behind it, mainly for 2 reasons.
    1. The loadscreen does show up a couple of seconds before alt-tabbing, and again for a split second before coming back.
    2. When travelling via waypoint on the same map or switching instance, there is no alt-tabbing.
    This makes me think that the problem happens when the game loads a new map, so what is loaded when you arrive at this new map and doesn't change until you leave?
    Still can't understand why would any of that conflict with Windows, aside from it just being Windows.
    Also I could be completly wrong about all this, just leaving my observations, that's all. ;)

  • @Death Slayer.1468 said:
    I did some research regarding this issue and when I use Reshade the issue is not present. (Tested with latest version as of this post v3.3.2)

    I'm currently using an older version of Reshade (2.0), but I'm not seeing a difference with this issue whether or not I use it.

  • Bash.9602Bash.9602 Member
    edited May 23, 2018

    Just wanted to share my finds when looking into this. I used a tool called Windows Focus Logger to try and find out the reason for the game to lose focus/alt-tabbing.
    What i found was that a process called " ShellExperienceHost " and also " SearchUI " made GW2 exe lose focus for a few seconds. SearchUI process can be disabled but ShellExperienceHost cannot be as far as i know as it is required to run windows.

    How to actually fix this problem i cannot solve, but this is the cause i found. Feel free to use the tool urselfs and see if you have the same results adminscope.com/downloads/window-focus-logger-gui/

  • @Evueimeimei.5918 said:

    @Death Slayer.1468 said:
    I did some research regarding this issue and when I use Reshade the issue is not present. (Tested with latest version as of this post v3.3.2)

    I'm currently using an older version of Reshade (2.0), but I'm not seeing a difference with this issue whether or not I use it.

    I see I did some further testing and the issue seems to go away temporarily when changing from windowed fullscreen to fullscreen, but then comes back again after a alt-tab / game restart. :(

    @Bash.9602 said:
    Just wanted to share my finds when looking into this. I used a tool called Windows Focus Logger to try and find out the reason for the game to lose focus/alt-tabbing.
    What i found was that a process called " ShellExperienceHost " and also " SearchUI " made GW2 exe lose focus for a few seconds. SearchUI process can be disabled but ShellExperienceHost cannot be as far as i know as it is required to run windows.

    How to actually fix this problem i cannot solve, but this is the cause i found. Feel free to use the tool urselfs and see if you have the same results adminscope.com/downloads/window-focus-logger-gui/

    These processes does not cause any interaction with my window focus. I have disabled Focus assist in windows 10 build 1803
    csrss gains focus last since that was when I killed the game.

  • Cynder.2509Cynder.2509 Member ✭✭✭

    Happening to me too after last night's Windows update. Hopefully there's a fix soon.

    I'm Hunter, he/him/they
    Check out my Tumblr for more GW2 content if you want: http://is-it-because-im-charr.tumblr.com/
    Character infos: https://is-it-because-im-charr.tumblr.com/characters

  • Fat Disgrace.4275Fat Disgrace.4275 Member ✭✭✭✭

    fresh windows 10 64bit install with all drivers up to date, including chipset and intel rapid storage on a new SSD and its happening. must be something to do with the windows update in april

  • Krieger.7935Krieger.7935 Member
    edited May 23, 2018

    Got it since a week, and seeing for how long people have this problem, I doubt it gets fixed anytime soon, like the bad connection issue on Europe server some times. Seeing how GW2 is the only game the problem keeps happening, I'd guess as customer its not my job to find a fix or workaround. And no, I wont try all em so called "makes it better" suggestions or play in windowed mode, cuz thats not what I payed my collectors edition for, or now and then purchase Gems. I know its not easy, it takes time, but as said the problem isnt really new, and with the windows update beeing release in batches, the amount of people beeing hit by it will only grow.

    edit just looked back, OP started this on january 2. 2018, see what I mean...

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Except the OP seems to be addressing a different issue, than the 'minimize on load screen' issue.

  • edited May 23, 2018

    @Krieger.7935 said:

    edit just looked back, OP started this on january 2. 2018, see what I mean...

    This is probably due to multiple threads being merged that appeared to be related by one of the moderators. When I stepped in to begin replying, this thread began with this message from April 30th. The "first" post in this thread now does seem similar in that the game is randomly alt-tabbing, but the issue that I am tackling at this point in time and that seems to have only started after the April 2018 Windows update causes the game to minimize only during loading screens. Apologies for the confusion.

    In regards to your other statements of not wanting to try what we've already stated are only temporary fixes and not our final, official ArenaNet solution - I get it, they aren't preferred. But the fact that these do stop the issue from happening for certain individuals is valuable information for our programmers and for our support ticket discussions, since it can help us get a picture of what is causing this to happen.

    We aren't done working on this issue. I apologize that it's taking some time for us to find a permanent solution or client-side fix, but for now these are the things we've found that can work to patch up the issue in the meantime.

    Lead GM Magister - The one that deals with tech support questions. (✿╹◡╹)

  • I can say I come across something:
    The issue started happening to me today, after I updated windows 10. I went into settings in game after I checked some desktop settings. I noticed this:
    I had been changed to "Fullscreen" view mode. I normally run Windowed fullscreen.
    Once I changed back to Windowed Fullscreen, the issue stopped and I was able to change to another map without the "Alt-tab" issue.

    Cyberpower PC, MSI graphics, windows 10, with a 5% DPI Radeon scaling to fit a 32" TV.

  • I'm not sure if this has been mentioned already, but I'm also having the same loading screen issue with GW1. It definitely started after installing the Windows 10 update. The loading times also seem to be longer on both games - though obviously I haven't timed it.

  • I have had this issue since yesterday after my WIN10 updated. My partner updated his WIN10 a few days ago and it started for him then, too. I'm assuming it's to do with the most recent update. Just adding my comment so this issue can be resolved quicker.

  • Zero.3871Zero.3871 Member ✭✭✭

    i had yesterday the 1803 update too, and look, i got the Problem too.

  • Odinens.5920Odinens.5920 Member ✭✭✭

    Wow, Windows 10 sounds like a huge headache. Glad I've refused to update to it so far. I'll stick with 7 for the time being,

  • Fat Disgrace.4275Fat Disgrace.4275 Member ✭✭✭✭
    edited May 24, 2018

    @Odinens.5920 said:
    Wow, Windows 10 sounds like a huge headache. Glad I've refused to update to it so far. I'll stick with 7 for the time being,

    actually its the other way around, this is not a huge issue, more of an annoyance and windows 10 is very stable. there is no issues in playing the game, the updates have not slowed down system performance at all.

  • anabasis.7346anabasis.7346 Member ✭✭

    Same issue here after updating windows 10. I've tried disabling Focus Assist and made it much better though it didn't fix the problem. Instead of flashing to desktop for a few seconds while on a loading screen, now it only does it for a fraction of a second.

    Overall no big deal though it's worth reporting it.

  • @killermanjaro.5670 said:

    @GM Magister.8736 said:

    @Rayti.6531 said:
    This suggestion from "eragon03" on reddit fixed it for me.

    • In case you enabled it when asked for it after the last Win 10 update: DISable the option that prevents notifications from showing while you play fullscreen games (clicking the notification symbol in the lower right corner of your screen while having a game open should give you the option directly)
    • Go to the folder containing your GW2 executable, right-click the GW2 EXE file (presumably the 64-bit one for most people), go to properties -> compatibility, and check "disable fullscreen optimization"

    I hope this helps some of you getting rid of the flashing to desktop (or at least improve it)...

    Thanks for posting this here, Rayti! I missed that Reddit post, so I'll see if this works for the folks I'm working with in support tickets. :)

    Anyhow, I had the Windows 10 update a couple of days ago and I'm having the same issue as everyone else here. Since the update the game takes about 10-15 seconds longer to launch to the title screen, and between every loading screen it's flashing back to the desktop, although still showing the GW2 cursor & playing the music, which is making loading screens a lot longer than before the update. Have updated Nvidia drivers and tried rolling back to older drivers but to no effect. I've tried turning off the "Focused" notification thing, which has helped reduce the time that the loading screen flashes to the desktop, but it hasn't got rid of it from happening. Will submit a ticket through the support site as suggested in an earlier post.

    Same thing here: started after the latest windows 10 update.

  • ... same here. Automatic Alt-tapping when MapLoadCompletion reached 100%.

  • Cjam.8634Cjam.8634 Member ✭✭

    @vaz kor.5479 said:
    sign me up. same problem(jumping to desktop when loading any screen) since win10 update yesterday.

    Exact same thing is happening to me, it’s kind of annoying lol

  • Achraf Hidouri.8029Achraf Hidouri.8029 Member ✭✭
    edited May 25, 2018

    same here, Windows 10 Creators Fall Update, x64 with a Hybrid graphic card (Intel Graphics Control Center+AMD Settings) Note: Windows Version 1803

    Everything has the right to live

  • AnClar.1304AnClar.1304 Member ✭✭
    edited May 25, 2018

    UPDATE 05/25/2018: Updated Nvidia drivers to latest v397.93 on my GTX 970 FTW. No change...still get flash to desktop. Just more info on isolation of issue...and, yes, I also updated my ticket with this. Hopefully they'll be able to identify and fix this.

  • Well this (guild wars 2 minimizing on loading screens) is definitely a Microsoft Windows 10 April 2018 update created issue! It is unfortunate to say the least as it definitely detracts from the immersion of being in the world of Tyria. I have tried scratch installs of Nvidia drivers, turning off the Focus Assistant, turning off Game mode, checking for a new update, using Nvidia boarderless window mode. Thus far the only "fix" or work around is to run gw2 in a window mode. That at least gets it to stop the minimizing during loading screens. While that (in my opinion) sucks it's, Microsoft's fault. There have been very numerous request for them (Microsoft) to fix it but yeah, get them to do something!? You're better off reinstalling and not doing updates! :s If ANet can or does implement something to fix this when it is not their fault or responsibility it would show, yet again, how they think of their customers more so than other software vendors! I wonder if the MAC client has this problem? Lets all switch to Linux <3 (wait, was that my outside voice or?) Okay so that wont happen. Only one thing left to do............pray to the Developer Gods! <3 <3 <3

  • AnClar.1304AnClar.1304 Member ✭✭

    Other games are being affected by the April W10 update. This Reddit discussion is about League of Legends, but there are similarities to what we are experiencing. This is not flashing on map load but stuttering and other graphics issues. https://www.reddit.com/r/leagueoflegends/comments/8j94bz/psa_the_recent_windows_10_update_once_again/

  • Same thing happens to me EVERY time I zone. I have updated all of my drivers. This began with the Tuesday update for me. I think this is a GW2 oopsie. Hope it's fixed soon 'cuz it's driving me bonkers.

  • Smoaking.6125Smoaking.6125 Member ✭✭

    I've been having this problem lately. The game switches to desktop every time I switch characters, every time I waypoint. And when I try to open the game again, it takes a long time. I noticed when I try to open the game, a Windows 95 looking thing appears in the upper left. Picture attached.

  • EnderzShadow.2506EnderzShadow.2506 Member ✭✭✭✭

    I don't have it randomly happening, it happens with every load screen
    going into the game
    going from pvp area to pvp Map
    Going OUT from pvp map to pvp area

    mhm, ok, sure, whatever you say, no after you, I insist, no really, please, be my guest,

  • @EnderzShadow.2506 said:
    I don't have it randomly happening, it happens with every load screen
    going into the game
    going from pvp area to pvp Map
    Going OUT from pvp map to pvp area

    I'm also having this same issue, please fix it Anet.

  • Having same problem, looking forward to a fix real soon...

  • EnderzShadow.2506EnderzShadow.2506 Member ✭✭✭✭

    @Holie.3081 said:

    @EnderzShadow.2506 said:
    I don't have it randomly happening, it happens with every load screen
    going into the game
    going from pvp area to pvp Map
    Going OUT from pvp map to pvp area

    I'm also having this same issue, please fix it Anet.

    "If you go to settings>system>focus assist and turn it all off, it does it much quicker now instead of sitting there for 10 seconds or so on the desktop. "

    So it won't fix it completely, but its much quicker. btw, if you go into system and you dont see 'focus assist' you can just type 'focus assist' in the search box and that will bring it up. Just turn all that stuff off.

    mhm, ok, sure, whatever you say, no after you, I insist, no really, please, be my guest,

  • EnderzShadow.2506EnderzShadow.2506 Member ✭✭✭✭

    @Seth Moonshadow.2710 said:
    I wonder if the MAC client has this problem?

    Mac doesn't have the same problem, it has different problems.

    Side note- It seems like people who like to run Linux and the myriad of distros, enjoy the tinkering and understanding.
    Every time I run into a distro savant, they want to explain how simple it all is by burying my mind in terms
    and concepts that I am unfamiliar with.
    "simple? Rrrrrright..... Like Rocket science, brain surgery and particle physics, right?"
    It's ok, everyone 'nerds out' on something.

    mhm, ok, sure, whatever you say, no after you, I insist, no really, please, be my guest,

  • Sarnax.8357Sarnax.8357 Member ✭✭

    In order to fix my Win April update issue I had to install a previous Win update and delete the April one. That worked. I had tried to reinstall gw2 which didn’t work. I also tried the windowed mode which didn’t work. Only this.

  • Sky.8035Sky.8035 Member

    Alright, so I've discovered how to severely decrease the time it flashes your desktop before popping back into the game.

    1. Open up your Notification Menu located on your task bar on the bottom right side.
    2. Press the All Settings button.
    3. Select System
    4. Select Focus Assist on the left hand tab
    5. Turn off the 'When I'm playing a game' option

    This should decrease the minimize time from about 5 seconds to around 1 second.

    To take this a step further, another thing that will help, especially if you're running on an older PC.

    Repeat Previous Steps 1 & 2, then do the following:

    1. In the All Settings menu select Gaming.
    2. Turn off Game Bar.

    It appears that Focus Assist and the Game Bar are the primary culprits behind this whole thing. As far as why it still minimizes for a second... That appears to be a fix on Arenanet's end as it seems like a compatibility issue.

  • Ahratan.1098Ahratan.1098 Member ✭✭

    I've also just started getting this problem. I know it was caused by the "Feature update to Windows 10, version 1803" Windows update, because I was playing the game with no problem, updated (restarted) while making some food, then came back to play again a few minutes later and the problem started then and has continued since.

  • Seth Moonshadow.2710Seth Moonshadow.2710 Member ✭✭
    edited May 27, 2018

    @EnderzShadow.2506 said:

    @Seth Moonshadow.2710 said:
    I wonder if the MAC client has this problem?

    Mac doesn't have the same problem, it has different problems.

    Side note- It seems like people who like to run Linux and the myriad of distros, enjoy the tinkering and understanding.
    Every time I run into a distro savant, they want to explain how simple it all is by burying my mind in terms
    and concepts that I am unfamiliar with.
    "simple? Rrrrrright..... Like Rocket science, brain surgery and particle physics, right?"
    It's ok, everyone 'nerds out' on something.

    Yeah, sorry. I know it's not a MAC or even a Linux+WineHQ problem. I was just wishing that I was running my Linux+WineHQ system now is all :( Not to mention it would prove that it is NOT an Arenanet issues since guild wars 2 would be and probably is operating normally, while the rest of us wine (hehe ;) ) about the issue.

    It's a Windows problem caused by April 2018 patch creating an issue with games of many types. It's the new focus assistant creating issues. Even when turned off, with game mode turned off, with updated video drivers and the new KB4100403 (minimizing games not addressed) the game will minimize when you load into a new map (both gw1 & gw2). As I've said before the only way I've found to stop this from happening is to play guild wars 2 in a a windowed mode (using ALT+Enter key combo). If you play in this mode then there is no disruption of the game. It's just not as fun as full-screen.

    yeah sorry, I'm a bit salty on this one. I only use windows for Guild Wars and Guild Wars 2, soooo yeah kinda like "WHAT THE SVANIR!" or "OOOoooo can't you deploy a feature w/o breaking fun!?!? flooommaaaddoooo" or "EVERYONE COME!...oh wait never mind go...just go...it's broke" maybe "Every developer has the right to a typo..." "By the Alchemy! Did you just figure a a flux capacitor would power a golem? You must have studied under Synergetics" and "You call THAT a hunt? Bear be blessed cub!"

  • EnderzShadow.2506EnderzShadow.2506 Member ✭✭✭✭

    @Seth Moonshadow.2710 said:

    @EnderzShadow.2506 said:

    @Seth Moonshadow.2710 said:
    I wonder if the MAC client has this problem?

    Mac doesn't have the same problem, it has different problems.

    Side note- It seems like people who like to run Linux and the myriad of distros, enjoy the tinkering and understanding.
    Every time I run into a distro savant, they want to explain how simple it all is by burying my mind in terms
    and concepts that I am unfamiliar with.
    "simple? Rrrrrright..... Like Rocket science, brain surgery and particle physics, right?"
    It's ok, everyone 'nerds out' on something.

    Yeah, sorry. I know it's not a MAC or even a Linux+WineHQ problem. I was just wishing that I was running my Linux+WineHQ system now is all :( Not to mention it would prove that it is NOT an Arenanet issues since guild wars 2 would be and probably is operating normally, while the rest of us wine (hehe ;) ) about the issue.

    It's a Windows problem caused by April 2018 patch creating an issue with games of many types. It's the new focus assistant creating issues. Even when turned off, with game mode turned off, with updated video drivers and the new KB4100403 (minimizing games not addressed) the game will minimize when you load into a new map (both gw1 & gw2). As I've said before the only way I've found to stop this from happening is to play guild wars 2 in a a windowed mode (using ALT+Enter key combo). If you play in this mode then there is no disruption of the game. It's just not as fun as full-screen.

    yeah sorry, I'm a bit salty on this one. I only use windows for Guild Wars and Guild Wars 2, soooo yeah kinda like "WHAT THE SVANIR!" or "OOOoooo can't you deploy a feature w/o breaking fun!?!? flooommaaaddoooo" or "EVERYONE COME!...oh wait never mind go...just go...it's broke" maybe "Every developer has the right to a typo..."

    its alright, you're not too salty for me. Personally I'm not too excited about a forced update from Microsoft. Usually there is some 'not too technical' work around I can find online.
    I know whats causing this one, but also another irritation, --Microsoft just forces these updates, then forces them in an "on mode', without some kind of "Hey would you like to try this?" For example, right now, I am looking at my screen that is Dimmed because of some night time mode (similar to F.Lux). I didn't enable that. I never said YES to that option. Why should I go digging through they myriad of options to find what is causing this? Microsoft... leave my proverbial $@#$ alone!

    Least its a brief flicker.
    I don't like windowed mode...even full screen windowed mode.

    mhm, ok, sure, whatever you say, no after you, I insist, no really, please, be my guest,

  • Dravis.7681Dravis.7681 Member ✭✭
    edited May 27, 2018

    Possible solution "work-around" for those still having issues...

    I tried the "focus assist" and "disable full screen notification" suggestions and they helped some but I was still seeing the desktop between maps so I tried dozens of other things and here's what worked for me:

    • Hardware acceleration: disable it in any/all apps that you may have running in the background including: chrome, discord, spotify etc. TIP: to find out what apps are currently using your GPU go into your NVIDIA control panel and in the "Desktop" menu tick "Display GPU activity Icon in the notification area" then click on the icon in the notifcation area
    • Compatibility Mode: right click Gw2-64.exe -> properties -> Compatibility -> "Change settings for all users" -> Run this program in compatibility mode for "Windows 7"
    • Run As Administrator: on the same "Compatibility for all users" dialog, check "Run this program as an administrator" apply and save
    • CoherentUI_Host.exe: make the same changes to this as you did to Gw2-64.exe (above). It's in the bin64 folder of the GW2. NOTE: this step might only be required if you're also using GeForce Experience or another game overlay
    • GeForce Experience (or any other overlays you use with GW2): I made the same changes here as well and GeForce Experience is working perfectly for me with GW2 for the first time ever. I can bring up the overlay, enable/disable instant replay and close the overlay without everything locking up.

    Video proof of the fix on my system recorded with GeForce Experience:

    That's about it. Everything seems to be working (dare I say) better than ever for me at the moment. Hopefully this info will help someone else.

    Good luck!

  • @EnderzShadow.2506 said:

    its alright, you're not too salty for me. Personally I'm not too excited about a forced update from Microsoft. Usually there is some 'not too technical' work around I can find online.

    True, but I've not found one that is working so far :(

    "Hey would you like to try this?" I never said YES to that option. Why should I go digging through they myriad of options to find what is causing this? Microsoft... leave my proverbial $@#$ alone!

    Supper Agree!

    Least its a brief flicker.
    I don't like windowed mode...even full screen windowed mode.

    Agreed!

    @Dravis.7681 said:
    Possible solution for those still having issues...

    I tried the "focus assist" and "disable full screen notification" suggestions and they helped some but I was still seeing the desktop between maps so I tried dozens of other things and here's what worked for me:

    That's about it. Everything seems to be working (dare I say) better than ever for me at the moment. Hopefully this info will help someone else.

    Good luck!

    I tried your idea. While I'm not a fan of downgrading it does work in that it stops minimizing when zoning. Trouble with that for me is that it runs like kitten and takes more time to load than when minimizing. Once loaded in it's like I do't have a GPU anymore watching the floor load in, then plants then enemies who were already attacking me :/ I think I'll stick with Native mode Windowed Mode until a real fix comes out.

    That's not to say that your solution might not work for some others, so if you like it great job :) and use Compatibility mode. There is at least two options for players to use until a fix from some one, be it ANet or Microsoft, comes out. Because really all these are a "work-around" and not real solutions to the problem.

  • Dravis.7681Dravis.7681 Member ✭✭
    edited May 27, 2018

    @Seth Moonshadow.2710 said:

    I tried your idea. While I'm not a fan of downgrading it does work in that it stops minimizing when zoning. Trouble with that for me is that it runs like kitten and takes more time to load than when minimizing. Once loaded in it's like I do't have a GPU anymore watching the floor load in, then plants then enemies who were already attacking me :/ I think I'll stick with Native mode Windowed Mode until a real fix comes out.

    That's not to say that your solution might not work for some others, so if you like it great job :) and use Compatibility mode. There is at least two options for players to use until a fix from some one, be it ANet or Microsoft, comes out. Because really all these are a "work-around" and not real solutions to the problem.

    Ahh... that's unfortunate... My system is pretty beast mode so I didn't notice any slow down on map and/or objects loading and it lets me use instant replay in GeForce Experience so well it worth it for me. Not sure if calling it a "downgrade" is 100% accurate though... Considering all the software in question (GW2, GeForce, CoherentUI) was originally developed before Windows 10 was a thing. I do agree that "work-around" is probably more accurate than "solution" though so I updated my first post.

    The problem with a "real fix" is I suspect all this has something to do with that CoherentUI_Host.exe which is a 3rd party app no longer supported by the developer (Coherent Labs). Based on the 10 or so minutes of research I did on it, it makes use of "hardware acceleration" which is why I started messing with the settings of other apps running on the GPU. So unless Anet decides to rip that out and implement Coherent-GT (CoherentUI's successor) then we're basically at the mercy of Microsoft coming up with a fix...

  • Same problem here started happening this morning......need to mention that last night i updated win 10 (that automatic thing they do) :( !
    Most certainly Microsofts fault , sometimes i just want to cry for win 7 OS for years of usage never had a single problem on multiple PCs .

  • Same problem here :(

    I've got 2 PC's both running the same version of windows with the same gfx card and NVidia driver version. My new PC is a fresh Windows build (1803) and has had the problem since installation on the 18th May. The other is my partner PC which has been periodically patched to the latest version after having a fresh Windows 10 install about a year ago.

    In order to get my new PC not to go back to the desktop at every load screen I had to do the following:
    1) Turn off the Focus assist and its gaming automatic rule (this got rid of the long delay and gave a quick flick back to the desktop)
    2) Under the gw2-64.exe properties - Compatibility options, Disable full screen optimisations (this reduced it to just a quick black flicker)
    3) Put gw2-64.exe into Windows 7 compatibility mode (this got rid of the remain black flickering)

    After playing about a bit I found that I didn't need step two and once i was in Windows 7 compatibility mode, selecting Disable full screen optimisations didn’t change the behaviour back to seeing the desktop. Also Windows 8 compatibility mode still showed the flickering.

    Strangely the other PC was working perfectly fine with focus assist turned on and no compatibility settings selected. We also have another 3 devices running Windows 10 (mix of version 1703 and 1803) in the house and they don’t have this problem either.

    I'm hoping that running in Window 7 compatibility mode won’t have any performance implications. If I note any over the next day or so I will comment.

    I won’t deny that I am beginning to dislike the supposedly helpful features that keep cropping up in Windows.

  • Gwaihir.1745Gwaihir.1745 Member ✭✭✭

    So is there any plan by anet to fix this? Theres certainly enough information documented in this thread alone to find the issue.

    Shield of Wrath: Reduced the cooldown of this skill from 36 seconds to 35 seconds.

    Quality balance changes^TM

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.