1- 5 (10-15 mostly) FPS after update (impossible to play) — Guild Wars 2 Forums

1- 5 (10-15 mostly) FPS after update (impossible to play)

Hello
I will not write too much... becuase it's not needed as you can see in the title. My FPS harshly go down a specialy when I mount up ... then FPS = 1 . The problem started after update.

Comments

  • vaper.3586vaper.3586 Member ✭✭
    edited June 29, 2018

    The same is happening to me. I thought I was the only one till I've seen this post. Did a computer reboot, tried to downgrade graphics card drivers... Nothing seems to work. This happened to me in every map I played. I've also tried WvW and playing there is impossible for me... I don't get over more than 20 FPS and I always play on minimum graphics mode. My network seems to work fine too so I don't think it can be the problem. By the way I'm not using any software like arcdps. Nothing was running on the background, just the game.

  • I thought it was just me. I can't even do the simplest of things when suddenly the game goes unresponsive or plays as a slide show....a very slow slide show.

  • and everything graphics related I have is also set at low

  • alphafert.6730alphafert.6730 Member ✭✭✭

    I was having issues with fps drop with a beefy pc & NVIDIA 1080. Turning off shadowplay brought be back up to 90-120fps

  • vaper.3586vaper.3586 Member ✭✭

    I think I've found something interesting looking on reddit. I was able to solve the problem doing these steps.

    1, Hit start menu and type "Defender", it should bring up "Windows Defender settings" entry, so open it.

    2, Another juicy part - if you use another AV software, like for example in my case - ESET, then you would naturally assume everything Defender related is disabled, and you would be wrong. If you use Defender, you will be brought to the Windows Defender Security Center straight away, but if you don't, you will end up on a Settings page saying that Windows Defender is not available because it's turned off. Click "Turn on Windows Defender Antivirus" - don't worry, your AV software will disable it again straight away.

    3, Once you are in Windows Defender Security Center, Click App & browser control button

    4, Scroll all the way down, to Exploit protection, and click Exploit protection settings text

    5, Once on Exploit protection page, set Control flow guard (CFG) to OFF.

    6, It will prompt you to restart your PC

    7, After the restart, enjoy your smooth Windows experience again

    This is thanks to these guys, I've been able to play in the same way I did before. I hope it works for you guys : )

    Source: https://www.reddit.com/r/Guildwars2/comments/86ip2w/extreme_low_fps_after_latest_patch/

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.