I can not activate the gem code - Page 2 — Guild Wars 2 Forums

I can not activate the gem code



  • Just to log - same problem!

  • Working now for me just redeemed at last :)

  • Guys.
    I do not know whether it is connected with our post with you, or just so lucky. But now I entered the game, and both codes worked! Try it and you!

  • OK it works again =)

  • I had issues all day yesterday, but it worked as expected this morning. Good luck everyone, hope you have the same luck as well!

  • Game of Bones.8975Game of Bones.8975 Member ✭✭✭✭

    I ran into this problem a couple years ago. Customer support worked with me, but ultimately found out I didn't input the code in correctly. I needed to be careful when scratching off the protective covering.
    Until we figured that out, I thought I was going to throw $25 down the drain.

    Ask a child a question and you'll get a childish answer.

  • Torzini.1523Torzini.1523 Member ✭✭✭

    Had issues with this all last night, but like others, today it seems to be working normally again. :) The 'redeem' and language options are back.

  • I can confirm, all good for me as well!

  • I'm so glad that things are working properly for you now. I was not told of any issues in the last few days, although I did reach out directly to CS, and it is from CS that the advice came to submit a ticket. I can't help but think those tickets made it clear there was an issue after all, and it was addressed directly by our billing provider. So thank you for following up, and again thank you for your patience and most of all THANK YOU for your support of our game! <3

    P.S. If you still are having troubles, can you update this thread with the information you receive via your ticket? That would help a lot.

    Gaile Gray
    Communications Manager: ArenaNet
    Fansite & Guild Relations; In-Game Events; Community Showcase Live

  • Gaile Gray.6029 P.S. If you still are having troubles, can you update this thread with the information you receive via your ticket? That would help a lot.
    My friend did 10 dollars worth of Gems on her debit card and it worked just fine . She decided she wanted to do another 10 dollars and now it is saying an error occurred but the text doesn't stay long enough to screenshot...It doesn't really matter much to her right now , she is gonna wait a few hours and try again but that was what was going on before the redeem window had its major issue...Just thought you should know . :)

  • @svanxx.3420 said:

    @Ellieanna.5027 said:

    @Dibbiest.8259 said:

    @Illconceived Was Na.9781 said:

    @Zero Soul.4523 said:
    I just spent a $$$$ ton of money on cards and now I can't use them ? This is a bit frustrating. Anet could at least comment on this and say WHAT happen !

    I'm really sorry you're stuck waiting. The best thing you can do to speed up the process is to create a support ticket. It's possible that it's something specifically affecting only a few people, and they won't be able to figure out what until they have data from some of those affected. It's possible it's a series of coincidences affecting people differently, so again, they need to know your specific situation.

    It seems like you didn't even read the thread. It would be a sporadic issue if nobody replied. We have 20+ people who replied who are probably all in different areas, I highly doubt it's a local problem.

    I just went and counted and it's 14, including those after you. You counted posts, not people. Considering the number of people playing the game, 14 is a very low number. And the answer actually is the best. Nothing said it was a sporadic issue. That they need the data for everyone affected to see what the issue is.

    For all you know everyone bought from the same source and it turns out it's all a 3rd party site that actually used a stolen card to buy the gem cards and resold them. You don't know. But submitted a ticket is how you will get help. It's going to be very rare if Gaile can come back to this post, and it's not even her job. They don't man these boards for help. Tickets are for help.

    Mine was bought off Amazon, so maybe that's part of the problem.

    Buying from a legit site even Amazon is always a risk because of third party sellers on there. Amazon themselves even sell "used" gem cards (not sure what could even mean)

  • Problem cropping up again. Tried with both accounts and Language window blank and redeem button stays greyed out. Will place a support ticket but this is BS

  • edited October 28, 2019

    Writing Date: October 28, 2019

    I have the same problem today, I already presented a ticket as above recommended, but I write from here to inform you that the situation is still fresh. If the issue gets solved by the CS team, I'll let you know the solution, as long as it doesn't contain private or confidential information, of course. Let's keep supporting this awesome game.