Feedback: Guild Wars 2 Mac 64-Bit Client - Page 14 — Guild Wars 2 Forums

Feedback: Guild Wars 2 Mac 64-Bit Client

1910111214

Comments

  • @Menadena.7482 said:
    Although 20 is not good ... that was in Wayfarer Foothills near hoelenbrack. So it does not seem to do any harm to upgrade it to Mojave but the problem introduced with High Sierra still seems to be there .... I would expect MUCH more than 20 fps running on this year's macbook pro. Was anyone able to resolve the high sierra slowdown with a setting change or something?

    I have the same questions, yet specifically More Cores = More Playable GW2?
    20 fps is not what I would want...

  • Good news everyone.

    Google, Valve, and Mesa community have magically created a convoluted way to support Opengl forever

    https://www.phoronix.com/scan.php?page=news_item&px=Zink-Gallium3D-OpenGL-Vulkan

    https://gitlab.freedesktop.org/kusma/mesa/commits/zink

    Opengl -> Gallium 3d -> Vulkan -> MoltenVK -> Metal.

    Opengl is dead. Long live Opengl.

    I would joke that this pipeline would be faster, more compliant and supports compute shaders, but I would fear those statements would be true.

  • DrMORO.4627DrMORO.4627 Member ✭✭
    edited September 26, 2018

    Opengl -> Gallium 3d -> Vulkan -> MoltenVK -> Metal.

    O M GW2...

    Metal please, ANET!!!

  • Menadena.7482Menadena.7482 Member ✭✭✭✭

    @DrMORO.4627 said:

    @Menadena.7482 said:
    Although 20 is not good ... that was in Wayfarer Foothills near hoelenbrack. So it does not seem to do any harm to upgrade it to Mojave but the problem introduced with High Sierra still seems to be there .... I would expect MUCH more than 20 fps running on this year's macbook pro. Was anyone able to resolve the high sierra slowdown with a setting change or something?

    I have the same questions, yet specifically More Cores = More Playable GW2?
    20 fps is not what I would want...

    I was able to get it to around 60 by selecting highest performance. Now I just have to go through things one at a time to figure out if there is one setting in particular that gives the most bang for your buck.

    New to the game? Feel free to give a yell if you need PVE help.

  • Menadena.7482Menadena.7482 Member ✭✭✭✭

    @loseridoit.2756 said:
    Good news everyone.

    Google, Valve, and Mesa community have magically created a convoluted way to support Opengl forever

    https://www.phoronix.com/scan.php?page=news_item&px=Zink-Gallium3D-OpenGL-Vulkan

    https://gitlab.freedesktop.org/kusma/mesa/commits/zink

    Opengl -> Gallium 3d -> Vulkan -> MoltenVK -> Metal.

    Opengl is dead. Long live Opengl.

    I would joke that this pipeline would be faster, more compliant and supports compute shaders, but I would fear those statements would be true.

    Nice! Although I do have to wonder what sort of a performance hit that would bring.

    New to the game? Feel free to give a yell if you need PVE help.

  • Ive had some weird issues since upgrading to mojave . Game will lag then crash back to desktop pretty frequently. Didn't have the problem with high sierra Anyone else noticing this?

  • edited October 5, 2018

    While I enjoy playing Guild Wars 2 more on the Mac client than on the Windows one (familiarity with the Command button's location being the top reason), I cannot sit idly by any longer and not mention that Metal needs to be implemented. World of Warcraft implemented Apple's proprietary rendering engine shortly after its release, so why can't Guild Wars use the same? Metal does indeed make a pretty big difference to the world of gaming on a Mac as it does boost FPS by at least 10 frames depending on the machine and the age of its hardware. If you would like to bridge the gap between the performance on Windows vs. Mac, this will have to be implemented sooner rather than later.

  • @Barine.7140 said:
    Ive had some weird issues since upgrading to mojave . Game will lag then crash back to desktop pretty frequently. Didn't have the problem with high sierra Anyone else noticing this?

    I had to repair the install to get it to even launch. I used this page to guide me through the process. Hopefully it works to sort your issues too.

  • Just reporting back to say the performance is still garbage. SO. MUCH. STUTTERING. omg.

  • I'm having a different issue now that I upgraded to mojave. We have multiple accounts for family members and only a couple computers so we have to change login info pretty regularly. Since I upgraded, I cannot change accounts without receiving an error 42:0:9001:4414. Once I reboot I can enter different account info, but as soon as I log out and change I get the same error again. I am absolutely certain too that I have not been mistyping the password either. and it happens every . . . single . . . time.

  • I am quite disappointed in the performance on Mac only after my friend told me he is playing on a 7 year old Win machine and has much better performance than I do on my late 2017 15" MacBook Pro. I was looking into settings to make a difference, but with 4core i7, 16GB RAM and 4GB radeon 560, I'm stuck at 20-30 FPS. I was trying to find some help online, to see if I could improve performance, but it is not to be found. If anyone knows how to help me, I'd appreciate it a lot. The game is playable, but it would be much better to actually be able to play a smooth game instead of laggy game. Lion's Arch is the worst on this and now with the Mad King events going on and millions of added features in the city, it is quite sad...

  • I seem to have a lot of weird flickering issues lately. Sometimes it is just beams of light radiating out from the character, especially if the character has some sort of effect on their clothing or mount (like storm mounts or fire mounts.) Other times it is chunks of solid color that seem to belong to the local terrain: near a building in the Crystal Oasis, blocks and rectangles of dark blue appear. Running down the cleared corridors to the vinewrath in Silverwastes, a lot of flat green vine images flicker on and off, and even some big planes of what seemed like a mottled green textured pattern. It was practically impossible to see through.

    These do not appear on screenshots. I tried running a repair on the client, and it made no difference, plus Terminal gave me repeated error messages of: [33753:1291:WARNING:resource_bundle.cc(303)] locale_file_path.empty()

  • Having issue since I upgraded to Mojave.

    Thing is, the game won't even start anymore. In fact as soon as I start the launcher, the screen freezes.

  • Menadena.7482Menadena.7482 Member ✭✭✭✭

    @mrJeyK.6317 said:
    I am quite disappointed in the performance on Mac only after my friend told me he is playing on a 7 year old Win machine and has much better performance than I do on my late 2017 15" MacBook Pro. I was looking into settings to make a difference, but with 4core i7, 16GB RAM and 4GB radeon 560, I'm stuck at 20-30 FPS. I was trying to find some help online, to see if I could improve performance, but it is not to be found. If anyone knows how to help me, I'd appreciate it a lot. The game is playable, but it would be much better to actually be able to play a smooth game instead of laggy game. Lion's Arch is the worst on this and now with the Mad King events going on and millions of added features in the city, it is quite sad...

    An event with a lot of people at it is not a good indicator. Even a gaming PC will take a nose dive into the single digits there. What counts is when you are in the open world with nothing much going on in the region that would attract people.

    New to the game? Feel free to give a yell if you need PVE help.

  • Menadena.7482Menadena.7482 Member ✭✭✭✭

    Has anyone else got a message that you should upgrade (how) when running mojave? Unfortunately I did not get a screen grab.

    New to the game? Feel free to give a yell if you need PVE help.

  • When I started GW2 I got a message from Apple saying 32 bit apps will not work in the future. Weird but I restarted and didn't get it again.

  • Guys my game has been crashing constantly recently, especially when I'm in Lion's Arch or Mistlock sanctuary, I don't know if its cuz my memory I mean I just have a regular Mac Pro.
    Below is the crash log:
    --> Crash <--
    Assertion: !transferRejected
    File: \Users\buildsrv\Gw2\Live\NAEU\v2\Code\Arena\Engine\Gr\GrTex2d.cpp(4159)
    App: Gw64
    Pid: 24706
    Cmdline:
    BaseAddr: 0x0000000000010000
    ProgramId: 101
    Build: 93060
    When: 2018-10-29T03:47:43Z
    Uptime: 00:34:23
    Flags: 0x0

  • I'm getting the compatibility warning on Mojave with the 64-bit version as well, so presumably some components of it must still be 32-bit.

  • lol i have just got the same warning...

  • Same error. Game crashes always on startup

  • PiXY.6841PiXY.6841 Member ✭✭

    I got a warning as well but it didn't mention 32-bit. It just said that it won't work in future versions. I thought it was due to OpenGL being deprecated in Mojave. #Metal

  • QikSilvr.4690QikSilvr.4690 Member
    edited November 4, 2018

    I upgraded to Mojave in early October. I am also getting this warning about 32bit apps. I contacted Apple support and they say the developer(Anet) must need to update some software used in the client. My husband is a software developer and he says its probably the WINE software used to emulate windows systems. I have a long support ticket with ANET support about the serious lagging. They could not resolve it. I have to put my settings on boring Best Performance now. So much for all the skins and outfits I bought.

  • Talek.6795Talek.6795 Member ✭✭
    edited November 4, 2018

    @loseridoit.2756 said:
    Good news everyone.

    Google, Valve, and Mesa community have magically created a convoluted way to support Opengl forever

    https://www.phoronix.com/scan.php?page=news_item&px=Zink-Gallium3D-OpenGL-Vulkan

    https://gitlab.freedesktop.org/kusma/mesa/commits/zink

    Opengl -> Gallium 3d -> Vulkan -> MoltenVK -> Metal.

    Opengl is dead. Long live Opengl.

    I would joke that this pipeline would be faster, more compliant and supports compute shaders, but I would fear those statements would be true.

    @Jon Olson.8439 Jon, is any of that could be used inside your office in a future?

  • @QikSilvr.4690 said:
    I upgraded to Mojave in early October. I am also getting this warning about 32bit apps. I contacted Apple support and they say the developer(Anet) must need to update some software used in the client. My husband is a software developer and he says its probably the WINE software used to emulate windows systems. I have a long support ticket with ANET support about the serious lagging. They could not resolve it. I have to put my settings on boring Best Performance now. So much for all the skins and outfits I bought.

    Wait, if you are using/playing the 64-bit GW2 Mac app, then it should NOT contain any trace of WINE Windows emulator, right?
    The 64-bit GW2 Mac app should be a Mac-native app, correct? Are some somehow still playing the depreciated 32-bit Mac app?
    Or, am I totally missing something here?
    Could someone please provide me/us with the correct information about how the 64-bit GW2 Mac app is written/programed?
    Thanks!

  • Moira Shalaar.5620Moira Shalaar.5620 Member ✭✭✭
    edited November 7, 2018

    I just received the following error when trying to start up GW2.
    "Guild Wars 2 64-bit.app" is not optimized for your Mac and needs to be updated. This software will not work with future versions of macOS and needs to be updated to improve compatibility. Contact the developer for more information.

    I am running macOS 10.14 on a late 2015 iMac. Is anybody else seeing this? Is there someone from Anet that can bring this to the appropriate person's attention?

    EDIT: when I clicked on the "learn more" it took me to this page, which makes it seem that the Guild Wars 2 64 is actually 32 bit, but when I do the system report it confirms the app as 64-Bit (intel) Yes.
    https://support.apple.com/en-us/HT208436

  • Gaile Gray.6029Gaile Gray.6029 Member ✭✭✭✭

    @Moira Shalaar.5620 said:
    I just received the following error when trying to start up GW2.
    "Guild Wars 2 64-bit.app" is not optimized for your Mac and needs to be updated. This software will not work with future versions of macOS and needs to be updated to improve compatibility. Contact the developer for more information.

    I am running macOS 10.14 on a late 2015 iMac. Is anybody else seeing this? Is there someone from Anet that can bring this to the appropriate person's attention?

    EDIT: when I clicked on the "learn more" it took me to this page, which makes it seem that the Guild Wars 2 64 is actually 32 bit, but when I do the system report it confirms the app as 64-Bit (intel) Yes.
    https://support.apple.com/en-us/HT208436

    Thanks for letting us know. The team is aware of this issue and is working on a fix for it.

    Gaile Gray
    Communications Manager: ArenaNet
    Fansite & Guild Relations; In-Game Events; Community Showcase Live

  • Menadena.7482Menadena.7482 Member ✭✭✭✭

    @Gaile Gray.6029 said:

    @Moira Shalaar.5620 said:
    I just received the following error when trying to start up GW2.
    "Guild Wars 2 64-bit.app" is not optimized for your Mac and needs to be updated. This software will not work with future versions of macOS and needs to be updated to improve compatibility. Contact the developer for more information.

    I am running macOS 10.14 on a late 2015 iMac. Is anybody else seeing this? Is there someone from Anet that can bring this to the appropriate person's attention?

    EDIT: when I clicked on the "learn more" it took me to this page, which makes it seem that the Guild Wars 2 64 is actually 32 bit, but when I do the system report it confirms the app as 64-Bit (intel) Yes.
    https://support.apple.com/en-us/HT208436

    Thanks for letting us know. The team is aware of this issue and is working on a fix for it.

    Great Gaile, if it is the same one I saw it comes up once and never again. I am guessing a tie to some 32 bit thing somehow.

    New to the game? Feel free to give a yell if you need PVE help.

  • @Menadena.7482 said:

    @Gaile Gray.6029 said:

    @Moira Shalaar.5620 said:
    I just received the following error when trying to start up GW2.
    "Guild Wars 2 64-bit.app" is not optimized for your Mac and needs to be updated. This software will not work with future versions of macOS and needs to be updated to improve compatibility. Contact the developer for more information.

    I am running macOS 10.14 on a late 2015 iMac. Is anybody else seeing this? Is there someone from Anet that can bring this to the appropriate person's attention?

    EDIT: when I clicked on the "learn more" it took me to this page, which makes it seem that the Guild Wars 2 64 is actually 32 bit, but when I do the system report it confirms the app as 64-Bit (intel) Yes.
    https://support.apple.com/en-us/HT208436

    Thanks for letting us know. The team is aware of this issue and is working on a fix for it.

    Great Gaile, if it is the same one I saw it comes up once and never again. I am guessing a tie to some 32 bit thing somehow.

    Unless I'm mistaken, the main game is 64bit but the launcher still uses some 32bit components.

  • KiraZ.1934KiraZ.1934 Member
    edited November 23, 2018

    “Guild Wars 2 64-bit” is not optimized for your Mac and needs to be updated". I too have gotten this message the last two days when signing in.

    Also I will state that since the week of the WVW bonuses, I have had ongoing LAG so much that I am unable to play with my WVW guild if we come up against an enemy zerg. SO SAD! This lag has not been a problem for years! Hopefully it will get resolved :)

  • I'm running Mac OS Mojave, version 10.14.1; when I went to log in this morning, I got an error message after the launcher appeared, telling me that this app is 'not optimized and that the developer will need to update it' and will not work with future versions of Mac OS. It only happened once, I didn't write down the exact message, and now the error is no longer appearing (it launches properly).

    Is this something I should be worried about?

  • I just want to post a feedback note about performance. I have a brand new MacBook Pro 2018 with the updated processor. The Mac GW2 client does not run smoothly. The game is laggy, and the only time it is really playable and actually enjoyable is at the lowest settings. I tested this computer using bootcamp and GW2, and on a pc side with the pc client, the game runs much much faster, and every setting can be on at least medium and still have a good frame rate and an enjoyable time playing.

  • Mac Pro (2017)
    Mojave
    3,5 GHz 6-Core Intel Xeon E5
    Dual FirePro D700 6GB
    32 GB 1866 MHz DDR3
    Game installed to local SSD

    No crashes, no troubles but not so good graphic performances... The graphic card is ALWAYS at 100%, even setting low graphics / best performances.

    At the beginning there are a lot of panning defects, a little bit better after some handfuls of seconds

  • inaho.2046inaho.2046 Member ✭✭

    I'd very much like to see the customized sountrack feature working on the mac. The wiki page says it works - and yet i have tested every conceivable way to get it working as well as searching for any other mac player who has it working and come up with nothing. I would very much appreciate it being looked into. It works like a champ on my wife's PC - easy as pie, and I'm feeling frustrated and hoping you can help.

  • inaho.2046inaho.2046 Member ✭✭
    edited January 9, 2019

    @Knopflerus.9587 said:
    Mac Pro (2017)
    Mojave
    3,5 GHz 6-Core Intel Xeon E5
    Dual FirePro D700 6GB
    32 GB 1866 MHz DDR3
    Game installed to local SSD

    No crashes, no troubles but not so good graphic performances... The graphic card is ALWAYS at 100%, even setting low graphics / best performances.

    At the beginning there are a lot of panning defects, a little bit better after some handfuls of seconds

    I'm on a 2017 macbook pro and it runs like a champ 30 FPS in cities and world events and 60 FPS in ractals, raids and open world - everything high but shadows and textures set ot medium. My macbook has the Radeon Pro 560 graphics built in. Respolution is 1080p - a cant run on high above that.

  • Menadena.7482Menadena.7482 Member ✭✭✭✭

    @inaho.2046 said:
    I'd very much like to see the customized sountrack feature working on the mac. The wiki page says it works - and yet i have tested every conceivable way to get it working as well as searching for any other mac player who has it working and come up with nothing. I would very much appreciate it being looked into. It works like a champ on my wife's PC - easy as pie, and I'm feeling frustrated and hoping you can help.

    I have different tracks set up in itunes. What would be wonderful is if there was a way to get information like active character then an applescript could play the right track. Priorities though.

    New to the game? Feel free to give a yell if you need PVE help.

  • Hi, I'm hoping someone can help me. After playing maybe 15 minutes or so suddenly my game will randomly freeze and I wind up having to hit the power button behind my mac and reopen the game. I've already tried deleting and reinstalling the game, going to Library > App Support > delete the GW2 folder and let the game download a new one, and I've gone to the terminal to try and repair the game like the support site suggested. So far, nothing's worked. Oddly enough, my brother has the exact same iMac as I do with the exact same hardware and our game is using almost the same settings, but he isn't experiencing any freezing/crashes. O.o

    I'm using an iMac (Retina 4k, 21.5 inch late 2015)
    Processor: 3.3 GHz Intel Core i7
    Memory: 16 FB 1867 MHz DDR3
    Graphics: Intel Iris Pro Graphics 62000 1536 MB

    Thanks

  • I've the exact same problem. After a while gw2 freeze suddenly (including my computer). It's no more fun to play. I think it's since one of the last updates after Episode 5.
    Also the game isn't run smoothly last days, like before.
    I've done filerepair too.

    I've Mac 27' late 2013
    3,4 GHz Core i5
    8 GB DDR3
    NVIDIA GeForce GTX 775M

  • I'm getting "Connection error(s) detected." error.
    This is the third occurrence. The first time I fixed it by updating my DNS server list.
    The second time it just started working after a few weeks away.
    Home network works (wife is playing GW2 right now on her PC - same network).
    GW2 is already an exception in my Firewall.
    My DNS settings have not changed.
    Traceroute fails on about the 12th hop.

    Anyone got a fix? Bought Path of Fire a week ago and I really don't like being shut out of the game.

  • Menadena.7482Menadena.7482 Member ✭✭✭✭

    @Catfish Jon.7038 said:
    I'm getting "Connection error(s) detected." error.
    This is the third occurrence. The first time I fixed it by updating my DNS server list.
    The second time it just started working after a few weeks away.
    Home network works (wife is playing GW2 right now on her PC - same network).
    GW2 is already an exception in my Firewall.
    My DNS settings have not changed.
    Traceroute fails on about the 12th hop.

    Anyone got a fix? Bought Path of Fire a week ago and I really don't like being shut out of the game.

    Unless you have a huge LAN seeing a traceroute fail that far away from you probably has nothing to do with your network settings. I assume the traceroute was to an anet server, right? They may have something misconfigured on the server end or are just not accepting ping traffic (a common anti-ddos strategy but frustrating for diagnosing network issues).

    New to the game? Feel free to give a yell if you need PVE help.

  • I'm getting "Connection error(s) detected." as well trying to install GW2 on mac.
    Fresh install on a mac (MBook Pro 2017, Mojave 10.14.2, Firewall OFF), downloaded the client, launched and straight to error.
    The mac shows no other signs of network issues either. All browsers and other apps connect just fine.

    Now, I'm literally logged in and playing with 2 accounts on 2 PCs on the same network. How do I fix this Mac install? I'm heading out of town with the MacBook Pro and would love to continue playing while I'm away from my gaming PCs.

  • @DougTheSlug.3920 said:
    I'm getting "Connection error(s) detected." as well trying to install GW2 on mac.
    Fresh install on a mac (MBook Pro 2017, Mojave 10.14.2, Firewall OFF), downloaded the client, launched and straight to error.
    The mac shows no other signs of network issues either. All browsers and other apps connect just fine.

    Now, I'm literally logged in and playing with 2 accounts on 2 PCs on the same network. How do I fix this Mac install? I'm heading out of town with the MacBook Pro and would love to continue playing while I'm away from my gaming PCs.

    open your settings, go to security and privacy, click the firewall tab, turn it off.
    Now try to do GW2. If that works, then you cna go back later and adjust the firewall settings or use a packet tracer to find out what needs ot be opened in your mac's firewall.

  • @inaho.2046 said:

    @DougTheSlug.3920 said:
    I'm getting "Connection error(s) detected." as well trying to install GW2 on mac.
    Fresh install on a mac (MBook Pro 2017, Mojave 10.14.2, Firewall OFF), downloaded the client, launched and straight to error.
    The mac shows no other signs of network issues either. All browsers and other apps connect just fine.

    Now, I'm literally logged in and playing with 2 accounts on 2 PCs on the same network. How do I fix this Mac install? I'm heading out of town with the MacBook Pro and would love to continue playing while I'm away from my gaming PCs.

    open your settings, go to security and privacy, click the firewall tab, turn it off.
    Now try to do GW2. If that works, then you cna go back later and adjust the firewall settings or use a packet tracer to find out what needs ot be opened in your mac's firewall.

    appreciate the attempt, but as highlighted in the post, firewall setting is already off.

  • I am suddenly crashing a lot, mostly at the beginning and end of 'adventures', and sometimes just randomly in Thunderhead Peaks. Running the repair app and rebooting the computer did not stop it.

  • Yep, same problem, I've given up on the Firecracker Lighting adventures because of this - constant crashes, usually near the beginning, or as soon as you hit the last firecracker, which is particularly demoralising.

    Speaking of New Year content, good luck playing Dragon Ball. There's so much stuttering and hitching that it's unplayable (one of the main complaints in general about the Mac client which still hasn't been addressed after all this time). I guess Mac players just aren't a priority, so it's rubbish performance until OpenGL goes from deprecated to removed, then it'll be adiós anyway.

  • PiXY.6841PiXY.6841 Member ✭✭

    As Feedback to the Devs: I can't remember the last time I saw texture flickering 🤔

  • Same here, random crashes every 20 to 30 minutes, it won't allow me to continue in the story mode because I usually crash by the end of an episode :disappointed:.

    Logs are pretty cryptic:

    --> Crash <--
    Signal: Segmentation fault: 11 (addr=0x0000000000000000)
    App: Gw64
    Pid: 63841
    BaseAddr: 0x0000000000010000
    ProgramId: 101
    Build: 95112
    When: 2019-02-08T14:15:54Z
    Uptime: 00:00:04
    Flags: 0x0

  • I just had a good two hour gaming spell on my MacPro, no crashes, and very few lags once the content / textures had loaded. That horrible lag when you mount the raptor / springer is gone as well. In bloodstone Fen I was averaging around 25-35fps. Latest 10.13.6 updates. I'm happy with this for now, means I don't have to boot into Windows 10.

    2010 Mac Pro (2x 2.93 Ghz 6 core)
    48Gb Ram
    Radeon RX 580 8Gb GFX card
    Game content is on a 7200rpm drive
    Main OS drive - Evo 960 nVME PCI

  • I have found that the game crashes systematically when holding the OPT key (CMD key) for a few seconds. I've tried over 10 times, 10 crashes and now have had 0 crashes by avoiding this key at all costs.

    Another point I've noted: GW2 64-bit has a very high energy consumption on my Mac, averaging at 155.84 in my activity monitor.

  • I've been crashing every time I try ANY adventure, which means that I mostly have stopped trying them. :(

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.