Jump to content
  • Sign Up

Map Completion problems


Recommended Posts

Explore the world they said. Have fun they said.

 

I finished my map completion today on one of my 2021 created characters that I almost never played. The character had finished the vanilla story a while ago and was at 87% map completion. So I decided to get this toon to 100%.
After finishing Southsun Cove, I wondered why I didn't receive my 100% reward (it showed 100% in the Login Screen before that already), so I checked the Wiki and found out that completion excludes Southsun Cove but includes Chantry of Secrets. So I went to the Chantry of Secrets (Bloodtide Coast was at 100% and 12/12 POI already) and discovered that I already was there. (naturally because my character chose Order of Whispers in the main story) but I still received the reward for it.

Now I found out that my map shows me 652/653 POI and 99% map completion (differs from the login screen). So I checked every Tyria map again but all show 100% POI. A friend (thanks Veni) showed me some of the newer story POI introduced in later Living Stories - but even those I alread had (Tower of Nightmares, Cragstead, North Nolan Hatchery).

After checking all the Tyria maps again I'm out of ideas.

It still shows this:
 

Map Completion Screen

 

What I wonder is why can I click the  "Badge Symbol" from World Completion (top left) and nothing happens, why doesn't it show me the missing thing? I can hover over normal map icons and they blink on the map. Going through 653 POI per hand and doing a full map completion again isn't what I want to do.

 

Anyone else having that issue? Anyone solved it? I have a ticket open, but don't expect a response today.

 


Frustrated Explorer I guess.

 

 

SOLVED! Thanks to everyone.

Edited by gebrechen.5643
Solved the problem
Link to comment
Share on other sites

Well if you already completed maps before new pois are added you wont get the chest again.

 

If I remember right there was 1 added to caledon forest, but your best bet is to just hover your mouse over each map mate.

 

Edit

And that chantry of secrets poi dont show up on bloodtide coast map its a seperate instance.

Edited by Linken.6345
Link to comment
Share on other sites

Thanks, I found the issue. It solved after visiting Kiels Office in Lions Arch. I obviously was there but had to enter it before popped the completion.

 

And LA was one of my first completed zones. So, I think the problem started with PoF (LS) adding that POI. 

Edited by gebrechen.5643
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...