Jump to content
  • Sign Up

Spacebar/Mouse Scroll (Zoom, Jump) Issues Connected to Chat Panel

Recommended Posts

The Issue:


Hi! Every now and then* when I activate the chat panel, either by clicking in the chat box or pressing the hotkey (backslash '\'), there are several issues with various inputs, as described in the list below. It seems to effect them equally. That is, when one issue occurs, the others in the list occur as well. This happens after pressing ENTER to send a message in the chat panel:




  • * The spacebar stops responding--pressing it does not allow my character to jump.
  • * On the world map screen (accessed with hotkey 'M' or by clicking on the world map button at the top left of the screen), when scrolling with the mouse wheel, doesn't zoom in or out as usual, but rather changes the layer of the map (e.g., top level, middle, lower level, etc.).
  • * I am unable to use the keyboard (with ENTER or another key) to re-enter the chat panel and type another message. In order to do so, I have to (left-)click inside the chat panel's input box.


There may be other minor issues as well, but I haven't noticed them. These are the most prominent, as well as annoying, problems I've encountered. Again, it happens after I type a message and send it by pressing ENTER to any chat channel, and it only occurs sometimes, in a seemingly random way; not every time. It's not that often, but I've been playing over 2 years now and have noticed it even on my new laptop and new OS (Windows 10 instead of 8.1), even in an entirely different state (Utah instead of California)! 🤔 It doesn't have a *huge* impact on my ability to play and enjoy Guild Wars 2, but it is somewhat of a "quality of life" issue, and it is pretty annoying, especially if it happens during a fight with a bandit leader or in a raid/fractal lol!


Temporary Fix:


Now here's the funny thing. I can get the client to resume normal functioning and the issues to stop, but only temporarily. This is accomplished by left-clicking (i.e., selecting) the chat panel box and then pressing ESC with or without entering any text. It doesn't work if I click the chat box and then press ENTER. In order for it to fix things (temporarily 😒, of course), I have to select the chat box (left-click) and then press ESC.


In Summation:


Anyway, it might seem like a small problem not worth bothering with, but given the fact that it occurs regardless of the PC or even operating system I am using (regardless of the account--I have experienced it on both of my Arena.net accounts), logic dictates it must be a problem with the client itself or the server. And it does interfere with my ability to play and enjoy the game, albeit not in a huge way. Any help from anyone or input by anyone else who has had this or similar issues would be greatly appreciated. Thanks in advance and happy Festival of the Four Winds btw!



*I apologize that I can't be more specific as to when it occurs or what factors cause it to occur. It seems like it is just at random, occasionally. If I had a client log or something I could perhaps offer more insight, but since players aren't given access to the game's inner workings it's not possible.

Link to comment
Share on other sites

  • 2 weeks later...
On 9/11/2021 at 10:25 PM, Inculpatus cedo.9234 said:

Isn't it forward slash  '/' ?

Yeah '/' or ENTER. I have a habit of using ENTER since I type a LOT for my work (software engineering). But you're right it'd be easier probably to just use forward slash. And thanks. I tried when it happened again using forward slash instead of ENTER and it worked to fix it, but still only temporarily unfortunately. It's gotta be some kind of bug. On another note, an even more obnoxious "bug" is the "Remember Password" checkbox on the launcher. I have to type the same long password every single time I start the launcher because the remember password feature doesn't work. I thought maybe it wasn't supposed to, but after talking in map chat to a lot of different people they say it works fine for them (i.e., they don't have to enter their password to sign into the launcher). Go figure. O.o Thanks for your tip though. 🙂

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...