Jump to content
  • Sign Up

DirectX 11 beta graphics issues


Recommended Posts

  • Replies 462
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, just wanted to let you know that we are working on this and I'll update you as soon as I have more info! 

Not really sure what else to say. Can't see chat and names are just a block of pretty tie dye. Very strange. https://imgur.com/a/DupBvX5  

We’re continuing to track issues with the DX11 beta and work on fixes. The next game update will include a fix for the issue that’s causing the purple blur in your text boxes. Thank you all for contin

Well, i had high hopes for the Beta directX11 functionality.

They got crushed pretty fast.

On the character selection screen ALL text was just unreadable colourful area-fields - had to fight my way back to uncheck the BetaBox. Completely unplayable unfortunately.

Windows 7 Service Pack 1, CPU Intel i5-3570, 16 GB RAM

NVIDIA GeForce GTX 1060 6GB, Driver 30.0.14.7111 (06.21.2021)

 

 

Edited by Necrid.6247
  • Like 2
Link to post
Share on other sites

Enabling dx11 for ultrawide, nv surround, or eyefinity causes the UI to move to the far edges of the screen where you can't see it very well. I've enjoyed this game on 3 screens for many years now and it would be disappointing if the UI will no longer be centered on screen.

 

Certain on-screen indicators (like the new mail animation) are scaled up enormously from the move to scaling based off horizontal resolution and not vertical resolution. The character select screen is also extremely zoomed in, only showing the midsections of all my characters. The UI there is also spread out

 

UI on DX9

UI on DX11

Edited by Erazai.7054
  • Thanks 1
Link to post
Share on other sites

Like in the title, happens only in DX11 mode. Happens even in "Windowed Fullscreen" setting.

 

I'm guessing this isn't intentional, but just in case it is - this should be an opt-out feature in the graphics options. Forced V-sync causes horrendous input lag when dragging interface elements or simply panning camera around the character, sometimes chugging around half a second behind the movement of your hand.

 

WORKAROUND FOR NOW:

In case anyone has problems with this, you can turn off V-sync in your GPU settings. For me it's in Nvidia Control Panel -> Manage 3D Settings -> Scroll down, set Vertical Sync from "Use 3D Application settings" to "Off". Click Apply and restart the game client.

  • Like 7
  • Thanks 1
Link to post
Share on other sites
  • Erazai.7054 changed the title to DirectX 11 UI on ultrawide

Well, I've experienced a few complications there with GW2Hook so far. It really kittens with the visuals when having both enabled. Also it forces me into windowed mode even when fullscreen is selected and thus I'm locked at 60fps (I usually have to tab in and tab out to fix the fps lock that might come from the addon but since I'm forced into windowed I can't tab out correctly). Don't want to ditch hook for the beta because it removes fog which improved performance for me and also makes the game less vibrant and eye hurting. Also it took far to long to get hook working properly back then (maybe because I also had the DX12 one as well which I removed after the incompability with hook) and I don't know how to disable it again for the duration of the beta anyways.
As far as the text goes, it's blurry but that comes from the addon and the DX11 incompability I noticed now. 

Link to post
Share on other sites

I get the same issue as everyone here. My build:

- Win7 Ultimate (64-bit)
- 24GB memory
- Intel i7-970 cpu (OC'd to 4GHz)
- Dual NVIDIA GTX 770 (in SLI mode) (2GB each) with latest drivers (472.12)

I force AFR2 in nvidia control panel to take advantage of SLI. This works fine for DX9. Turning off SLI didn't help.

Edited by firewire.4813
  • Like 1
Link to post
Share on other sites
5 minutes ago, styrefr.1360 said:

Nope got it on Win10 and 1080 graphic card. This is the kind of technical nightmare that make dev's life interesting.

Hmm, seems to be fine on my win10 laptop (Geforce MX250). I noticed there is no Fullscreen option, only windowed ones.

Edited by firewire.4813
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...