Jump to content
  • Sign Up

DirectX 11 beta graphics issues


Recommended Posts

On 9/28/2021 at 2:54 PM, Incurve Giidis.7829 said:

btw did everyone's encounter fps get nuked down to 30 range? like 5man fractals and 10man raids, where its not even that demanding

like my addons broke so i first removed everything

default was really bad

default with dx11 beta was also really bad

 

and then opting out of that and reinstalling the dx12 mod its still bad. is dx12 the cause or this update?

 

I think the drop to 30 fps you see might be the issue I have. My understanding is it's what happens if you turn Vertical Sync on: once it drops slightly below 60fps, eg 55, it'll force you to the next 'checkpoint' which is 30, even though it can pull say 45.

 

I have Vertical Sync OFF, and this is still happening when I opted into Directx 11. I'm not sure if it happens if I opt out - maybe it is a gamewide bug that got introduced, or just Directx 11.

 

I'd like to see my 45fps back pls!

 

I have:

- Windows 10

- Nvidia 3060

 

So far for me Direct11 has been amazing. Lower GPU utilization, higher framerates. I play in 4k. The only problem I have is this bug: it pulls fps by force to 30 around events, in expansion maps, which causes constant jump back and forth from 60 to 30 to 60 to 30. That jump is like walking thru jello suddenly, very bad. Eg in HoT it seems to happen on mob animations/my fighting animations maybe.

 

Another issue I saw was in Aetherblade Fractal. After the laser room stuff just stopped loading. Not even game UI. So i quit/restarted - it fixed the issue. I did not disable DIrectx11.

Link to post
Share on other sites
  • Replies 297
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, just wanted to let you know that we are working on this and I'll update you as soon as I have more info! 

Not really sure what else to say. Can't see chat and names are just a block of pretty tie dye. Very strange. https://imgur.com/a/DupBvX5  

We’re continuing to track issues with the DX11 beta and work on fixes. The next game update will include a fix for the issue that’s causing the purple blur in your text boxes. Thank you all for contin

I generally have a midgrade laptop, been playing the game on medium graphics, DX9 no issues. Switched to DX 11, I haven't noticed any serious issues like missing textures or anything you guys have reported so far but I feel like my game is slowed down. When I move to certain areas, there's like a freeze for a micro second, I feel like its rendering or something but it never happened with the DX9 which really promotes smooth gameplay for my system.

 

The combat is also a little wonky, I feel like something's holding me back, some kind of lag, input lag or something..... I have tried like disabling (forcing) v-sync off and all that and it has improved but still doesn't feel as smooth as it used to.

 

Right now I switched back to DX9 and I'm just enjoying my game.  I would honestly rather choose for the Devs to keep DX9 and leave it as an option once DX 11 rolls out or else iron out and fix DX11 completely. I just want my game to be smooth without the cost of risking to change the Med graphics to low, 🙁.

  • Like 1
Link to post
Share on other sites
22 hours ago, Dawdler.8521 said:

Have you tried pressing the windows key? Yeah. Its not fullscreen no matter how much you set your resolution to fullscreen. Its windowed fullscreen.

 

18 hours ago, firewire.4813 said:

That's not true fullscreen if you can see your taskbar at the bottom when you press the Windows key with the game in the background. That's "fake" fullscreen (aka, borderless window).

Aha, thank you for letting me know.

Link to post
Share on other sites
On 9/28/2021 at 9:53 PM, Ornitha.5862 said:

i haven't really experienced anything weird with dx11 until i played the "descent" instance of war eternal

 

some screenshots i took of the final cutscene + aftermath:

https://imgur.com/a/6UZ7zTd - kralk's death seemed to have some unexpected consequences for rytlock

https://imgur.com/a/DYBXq1u - chat bubbles would not appear over character's heads or in the chatbox

https://imgur.com/a/39i0JFf - everything would disappear when i moved my camera at certain angles, experience bar would also randomly appear + disappear as i ran around

 

screenshot of after returning to lion's arch:

https://imgur.com/a/ACYiaY5 - everything except for terrain disappeared. i could move normally and collision/physics/whatever still worked properly even though i couldn't see anything. my ui would not work at all

I had the same problem with the final cutscene, the ship and LA. Although Rytlock's problem was only the start of many more problems in the cut scene. After a few seconds the screen was mostly black. Luckily I had done the story before so I have seen the final cutscene on another character. Didn't have many more issues with DX11, only some problems with ALT-TAB.

Link to post
Share on other sites
On 9/28/2021 at 4:41 AM, malevolence.9487 said:

Got a weird issue here with DirectX11 on my high end PC (RTX 3090 + i9 10900k). In DirectX11 the GPU Utilization is around 30%~40% but with DirectX9 the GPU utilization is around 70%~80%, obviously the performance in DirectX11 is worse than DirectX9.  

  

Utilization went down for me, as well (specs listed in an earlier post), but because I play with vsync on.. all this means to me is that I'm using FAR less GPU power to do the exact same work as before. If you compare the GPU clock between them, you should also notice a difference. You shouldn't even be using that much of your GPU in DX9, unless you're running 4k + supersampling and uncapping your FPS.. which just means unnecessary strain on your system and a higher electric bill.

 

22 hours ago, Gimli.9461 said:

I think the drop to 30 fps you see might be the issue I have. My understanding is it's what happens if you turn Vertical Sync on: once it drops slightly below 60fps, eg 55, it'll force you to the next 'checkpoint' which is 30, even though it can pull say 45.

 

This has actually been an ongoing issue for years. I see it every time I run CM's, early in the fight with Siax and Ensolyss. After 10-15sec it usually normalizes.

Link to post
Share on other sites

Graphical issues that sometimes show:

Ice and Raven Statues at Drakkar Lake turn green

The cinematic at the end of War Eternal couldn't render the sky box (or Rytlock's legs)  This later led to text from npcs not to show in chat, and their speech bubbles were half blank.  It then had a hard time keeping the airships rendered, even after returning to Lion's Arch but still on the Phoenix Dawn airship.  Restarting resolved both of these.

Logan's Dragonfall outfit, and several of the map currency merchants glow bright in white and/or gold.

Rubble in the 'The Crystal Dragon' instance rendered in a rainbow of colors, making it look like lego (I feel this has happened in Dx9 too though.

Branded Crystal rarely shows blue and I'm pretty sure it wasn't Aurene's version.

One crash that didn't launch the crash report happened in Dragonstorm approaching the first Jormag Ley Collector.

I run Dx11 at Best Appearance, with Low Model Counts.

 

Link to post
Share on other sites
On 9/28/2021 at 8:18 PM, TristisOris.2165 said:

 

Same here. https://imgur.com/a/Jdv2c8F

 

Also: Not really a but but just not implemented I guess: Will you bring back multi screen / ultra wide support with DX11?

So that when you use 3 monitors as one (NVIDIA Surround / AMD Eyefinity) that the HUD elements are centered on the middle one? Niche case I guess but without, ultra wide isn't really playable.

Link to post
Share on other sites
On 9/30/2021 at 8:23 PM, HotDelirium.7984 said:

I see random bright red dye jobs on skins of doors, weapons, mounts, back items etc. I don't love it.

Could be related to the bug I have been noticing with DX11.

When I

1. use the "Dark Monarch" skyscale skin and

2. change the map or use a teleport on a given map

sometimes the 3rd colour channel (the flamy bits on the wings) gets partially replaced by a reddish flesh-coloured hue.

Restarting the game fixes it. Going back to login sometimes fixes it. This bug does not happen on DX9.

 

One thing of note is that there is a strong correlation with my client becoming tremendously unstable when I play my necromancer (who uses that skin for his skyscale). I can not say if there is a causal relation in either direction, but going from hardly any crashes at all to crashing up to three times in the course of 10 minutes just by playing as scourge sets a couple of red flags that I thought I should mention.

  • Like 1
Link to post
Share on other sites
On 9/23/2021 at 8:47 AM, DemonAtTheWheel.1804 said:


First, glad you do not suffer from the bugs others have.  It is good to hear that some configs don't see issues.

It is "disproportionately affecting GTX/RTX users" because most people use Nvidia cards. According to the most recent poll data from Steam (March 2020 - August 2021), about 77% of their gaming market is Nvidia, and only 14% in AMD. And to make those numbers even more bleak, Intel has a smidge over 8%, which means that those AMD 14% includes iGPU numbers, not just discreet cards like Nvidia numbers. 

I would find it rather hard to believe this MMO community is far off those numbers.

That's the entire market.  If you section out just the gaming market, then my guess is the numbers for AMD jump up considerably, and Intel all but evaporates.

 

Marketshare numbers lump in markets that are dominated almost completely by Nvidia, while also dumping in productivity machines that never run a game.  They're misleading when evaluated in the manner you're displaying here.

 

The MMO community is going to be quite a bit off those numbers.

 

I'm not saying AMD is going to jump up to 50% market share, but they will be much higher than 14%.

 

The RX 5700 XT - for example - performs better than a 2060S and practically as well as a 2070S for a lower cost.  Unless someone was a content creator, there were not many reasons for them to bias to Nvidia over AMD and spend more money for negligible performance gains, or spend negligibly less for a performance loss.  The only time Nvidia becomes a no brainer is if you also do content creation on that Desktop or Laptop, in which case CUDA support is wide and optimization towards Nvidia often gives them a sizable lead in those application segments.  Also, streamers will bias to Nvidia for their Encoder Tech (though that disparity was taken care [largely] of with RDNA, lots of software didn't update for the newer API quickly/at all).

 

The current gen are going to better that.

 

And everyone knows that Intel's market share in GPUs is carried solely on the back of their dominance in Laptops - many of which can barely - if at all - run this game with acceptable playable performance.  They also get counted on machines that would never run a game on the Intel iGPU, anyways, due to the presence of a discrete graphics card.

Link to post
Share on other sites

The lightning on Dx11 is way off for me,everything is too dark
Theres several graphical issues where textures or objects arent being shown in the right colour,black/orange.
Crashes in WvW blob fights

My Gpu reaches 80c on Dx11 but when on Dx9 it hovers around 60 - 66, also when using the dx12 mod.



Performance does seem better but i switched back to Dx9 for now because of the crashing and lightning issues.

Edited by Caedmon.6798
Link to post
Share on other sites

A few days ago I had all the awakened at the Fortress of Jahai show up in bright neon green.

Also, (don't think this is DX11-related) I just had a random Lunar New Year decoration floating in the air near the portal to Lion's Arch in Divinity's Reach.

Edited by Kaliwenda.3428
Link to post
Share on other sites

so is there an issues with brightness since the update? whites are just crazy bright, almost their own lightsource. and just getting the game to look normal again even with the DX11 Beta switched off doesn't seem to be possible at the moment. Any advice or is this being looked at? I can change game settings, display settings etc but nothing really fixes as i'll just get a slightly darker screen but the whites are still a problem. hopefully it's just a colour/light calculation issue that's still being worked on. i noticed the gamma slider wasn't working last week, i wonder if these are connected. i hope it's just a gamma calculation issue as it seems like whites are shining through everything, for example shines on leather clothing etc.

Link to post
Share on other sites
13 hours ago, Aradia.9370 said:

so is there an issues with brightness since the update? whites are just crazy bright, almost their own lightsource.

I have not experienced this particular phenomenon, nor have I heard about it before. Interesting.

Are you playing on low settings? Are you using any add-ons?

20 hours ago, Caedmon.6798 said:

My Gpu reaches 80c on Dx11

I suggest you install software that allows you to control the GPU fans properly. Mine were definitely running on higher speeds when I had DX11 activated, which means the workload was higher, just as you described.

Edited by Ashantara.8731
Link to post
Share on other sites

Decided to change my graphics settings this morning to get more FPS by lowering some things and then try the DX11 Beta again (after not using it much at all because GW2Launchbuddy doesn't allow it). This time, ran the normal client so I could use the beta and welp, during a fight with Zirh the Venomous, my client froze, completely. Never came back. Had to click multiple times to get the dialogue box to come up that asks if I want to close it. Ran the client again, thought maybe it was a one time issue, despite the fact it was running just fine while I was in Bitterfrost a few minutes earlier before Zirh and it only happened halfway through the fight. Nope. Took only a couple of mins this time before it completely froze again. Not sure why...

Here's my GFX settings and rig setup:

https://imgur.com/a/UybH26r

CPU: Ryzen 5 2600
Video: Radeon RX 570 4GB
RAM: 32GB
OS: Windows 10 ver 20H2 build 19042.1237
Resolution: 1920x1080

Link to post
Share on other sites

Im having the same problems i had from last patch. I closed the game a couple minutes short of update in anticipation of a patch. after 11am central time i opened up my regular launcher and launcher auto closes. i tried several different commands, -dx9, -repair, nothing worked. I deleted the .dat file, still, nothing worked. I totally uninstalled the game and deleted all folders and went to do a fresh install and now the game installer launcher is doing the same exact thing. Opens for 1 or 2 seconds then closes out. Please help. This is my day off work and this is beyond frustrating.

Link to post
Share on other sites

So far so good.  The plants in the branded area above Yahtendi Village in Jahai look OK. I haven't noticed my skyscale turning red, either.

ETA: the Windy Cave minidungeon is looking less psychedelic, too. Yes, I didn't eat the mushrooms in there. 😉

Edited by garpu.6210
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...