Jump to content
  • Sign Up

DirectX 11 beta graphics issues


Recommended Posts

44 minutes ago, inbadplace.7329 said:

From that page:

"With the release of Windows 10, we added Fullscreen Optimizations – which takes full screen exclusive games and runs them instead in a highly optimized borderless windowed format that takes up the entire screen."

Later they give solution how to disable it for specific game but in case of GW2 it doesn't fix the issue.  Even with “Disable Fullscreen Optimizations" option turned on in Compatibility tab - game still runs in windowed borderless instead of true full screen.

Again - this is not the issue with DX9 renderer - that's why I put post about it here in beta graphics issue thread.

If I select "Full Screen - 2560x1080" in DX9 mode - game is running at that exact resolution with crisp UI.

I'm pretty sure it's GW2 issue with how they implemented fullscreen things on their end because I'm not having this issue in any other game like Cyberpunk 2077 and Pathfinder Wrath I'm playing right now.

This has nothing to do with win10 fullscreen optimisations. The game is just doing internal bilinear upscaling from lower resolutions to the monitor's native resolution. Your monitor's aspect ratio doesn't matter. The game is doing this at 1080p displays as well. The lower the resolution you set the more unsharp the image becomes. 900p @ 1080p is slightly unsharp and 720p @ 1080p is a blurry mess.

I've the same issue (and I guess everyone has) and experimented a bit with OS and driver related settings like disabling fullscreen optimisations in windows and disabling gpu scaling in the gpu driver. You can not get rid of this issue.

Btw.: I am using an AMD gpu. Since you have Nvidia hardware it is obviously also not a gpu vendor (=driver) issue.

That's quite a fail from ANet. All modern gpus (even from Intel) support integer scaling which means you get a clear image when upscaling from 1920x1080 to 3840x2160 or 1280x720 to 2560x1440 or like in your case from 2560x1080 to 5120x2160 to safe gpu performance. Their upscaling destroys this.

Edited by KrHome.1920
  • Thanks 1
Link to post
Share on other sites
  • Replies 443
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, just wanted to let you know that we are working on this and I'll update you as soon as I have more info! 

Not really sure what else to say. Can't see chat and names are just a block of pretty tie dye. Very strange. https://imgur.com/a/DupBvX5  

We’re continuing to track issues with the DX11 beta and work on fixes. The next game update will include a fix for the issue that’s causing the purple blur in your text boxes. Thank you all for contin

The 3D Screenshots under DX11 (CTRL+Print) are not working (no save message and no file is saved).

After using CTRL+Print once, the normal screenshots stop working too.

 

Under DX9 3D screenshots work without problem and using them doesn't break the normal screenshot function.

Link to post
Share on other sites

Can we please just fix dx11 for triple monitors first? The menus like guild chat and mini map are on the left and right screen when running dx11 mode. In dx9 mode they are on the center monitor. When they are not on the center monitor it is extremely difficult to play. Thanks.

Edited by squallaus.8321
  • Thanks 1
Link to post
Share on other sites

Tried this again - after I had problems months ago when the beta first was enabled. (Visual problems with the UI and needed to disable it again with a command-line option - to get into the game.)

It seems performance-wise the loading (old computer) to log in from char selection to a map ... felt much better/faster. Also closing the game. (Less stuff in memory to "free" when closing the game?)

What I noticed though: I did not change anything at my resolution or UI settings but at the car selection all my 11 char slots (9 used, 2 empty) were visible. Before that I only could see 10 (without DX11). Ingame the UI felt "smaller". As if I had a bigger overall resolution or a smaller UI size.

(Changhing the UI size did not change anything at the char selection screen though. But ingame from normal to "large" felt more like what I had seen before with DX11 disabled and "normal" as setting.)

Not a big deal - this can be changed as needed.

Main problem though - I do not know if it needs anti-aliasing enabled or other stuff (have this disabled on my old machine): The UI text seems blurred - still possible to read compared to DX9 (DX11 beta disabled). I prefer the sharper and clean text borders of the DX9.

I am at 1440x900 resolution. (Yeah old computer. Small screen - but it is enough for me.) Windows 7 and the hardware barely meets the minimum requirements. 😄

Edit: On 2nd thought ... and checking again with screens ... it does not look blurred. Felt just a bit weird too me - cause the UI has different sizing and is smaller (and therefore harder to see). Might need to play around with different UI size settings (the larger ones) to find the one that best suits me.

Actually the "larger" (biggest possible!) with DX11 seems as close as possible as I can get to the looks with "normal" UI size and DX9. The "Large" one looking good as well - just needs time to get used. I guess I will try that one.

Maybe a fee more options there would be nice - now that DX11 makes the "normal" setting look much smaller. (Normal too small for ma taste at least at keeping the current resolution and for the buttons at the very bottom - logout, world selectoin and stuff.)

I have 4 screens. 1 with my normal settings in DX9. (normal UI size) - then 3 for DX11 beta enabled with the UI at normal (now too small) and then "larger" (close to the normal in DX9) and "large" (still smaller than normal in DX9 but I could get used to that).

DX9, normal UI size: https://i.imgur.com/OgN6ZC4.jpg
DX11 beta, normal UI size: https://i.imgur.com/3oawiBw.jpg
DX11 beta, "larger" UI size: https://i.imgur.com/rH181Ef.jpeg
DX11 beta, "large" UI size: https://i.imgur.com/Ul3m7es.jpeg

Have not tried the DPI scaling option yet - I think that one is related to text stuff as well.

Edit2: Staying at DX9 for now. On the screen it looks different a bit ... than actually in the game. And ingame it feels still weird/blurred with the text. Would prefer if the text looked identically to DX9. Larger UI size actually feels more blurred and the smaller (normal) one too small now that the normal setting has gotten a lot smaller with DX11.

Edited by Luthan.5236
Link to post
Share on other sites

Now I'm hoping they fix the DX11 issue before moving DX11 out of beta. When you walk through grass, currently with DX11 it does not move, with DX9 it did.  Also with DX11 the sun is more white than it used to be compared to using DX9. With DX9 it was a bit more yellow. 

Edited by Tony.8659
  • Like 2
Link to post
Share on other sites
Posted (edited)

I recently bought a new pc and I've encountered bug with the camera using DX11 that I have never experienced before. Basically, the camera zooms in and out while moving at high speed on a roller beetle or griffon. I have made a comparison video with and without DX11 so you can see what it does: https://youtu.be/hrlUp4qXO_E

 

It seems to only happen near the edge of guild hall maps. I have tried other maps and the camera is perfectly fine. The camera is fine even in parts of the track in the video closer to the centre of the guild hall.

 

My PC specs are:
- Processor: AMD Ryzen 9 5900x 12-core

- Graphics Card: Gigabyte GeForce RTX 3080 Gaming OC LHR 10GB (driver version 512.59)

- Motherboard: Gigabyte B550 AORUS ELITE V2

- RAM: Team T-Force Delta RGB 32GB (2x16GB) 3600MHz CL18 DDR4 Black

- OS: Windows 10 Home 64bit

Edited by Pingu.6871
Link to post
Share on other sites
On 4/28/2022 at 5:57 PM, MithranArkanere.8957 said:

Is anyone else seeing cobwebs dyed murky green instead the usual grayish white?

Nope.

On 4/28/2022 at 5:13 AM, Tony.8659 said:

Now I'm hoping they fix the DX11 issue before moving DX11 out of beta. When you walk through grass, currently with DX11 it does not move, with DX9 it did.  Also with DX11 the sun is more white than it used to be compared to using DX9. With DX9 it was a bit more yellow. 

👍

Link to post
Share on other sites
  • 2 weeks later...

I turned DX11 on today for the first time in a while, and since then I've had 2 crashes (which for me is very unusual). Both times the whole screen went black and the entire computer was unresponsive (even ctrl+alt+del didn't work). I could also hear the fans on my graphics card running very loudly. I had to use the power button on the PC to shut it off and restart it because nothing else would work.

My PC specs (if I've missed anything important please let me know):
Processor: Intel i5-4670
Graphics card: Radeon RX480 (Drive version 21.50.21.11)
OS: Windows 10 Home 21H1

Link to post
Share on other sites
Posted (edited)

I don't know if it really was the morphing of refresh rates into default mode.
but that week i did lose a ton of good hardware performance, and i'm not sure why,

so i will list it under potential dx11 bugs:
its almost like a lag-delay bug , buttons consistently aren't responding fast enough, mesmer blink/jaunt has a long delay before reaching location, etc.
anyway its really weird that i had to mention it and strange too as i had amazing performance at EoD release, but in the past 2 weeks it floundered.

edit:     with ryzen 7 & gigabyte navi / lpx corsair ram
but i think its just with the game, not especially my system as other things seemed okay, but i will check more

Edited by Jozeiax.8465
  • Haha 1
Link to post
Share on other sites
  • 2 weeks later...

There is a dx11 bug in which some postprocessing effects are not applying to the image. I took some screenshots showing the difference between the dx9 version and the dx11 version:

  • Example #1:   Dx9 - Dx11 - At the grotto in Dragon's End

  • Example #2:   Dx9 - Dx11

  • Example #3:   Dx9 - Dx11 - Void's reality distortion

  • Example #4:   Dx9 - Dx11

  • Example #5:   Dx9 - Dx11

Also, the postprocessing effect used while underwater in the Dragon's End map remains in the image even after resurfacing: before  -  after

Note: I've reported this on a separate threat without knowing this one existed, but I think it fits here, in case that is how the dev team looks for DX11-related bugs. LINK

Edited by Kilty.4906
grammar
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...