Jump to content
  • Sign Up

DirectX 11 beta graphics issues


Recommended Posts

2 minutes ago, firewire.4813 said:

If only MS would release a "power user" version of win10/11 with out all of its wonderful "telemetry" baked into every sub-system, I'd gladly move over, until then, I can take care of myself, thanks.

Heh same. Frankly I didn't find win10 to be any sort of material improvement over win7 for me. Nothing I do now from a productivity standpoint suffers from being done in win7 (the most intensive thing I do is some massive spreadsheets, which my current setup handles with zero issues). The only two games I play (this and Black Desert) work fine, and hilariously this game - until today - didn't even make use of win7's dx11 capacity.

All of this will be moot for me when I finally take the plunge and stop booting into windows and boot exclusively into linux. I'll just live with a whole new level of glitches there (when it comes to wine) when the time comes.

  • Thanks 2
Link to post
Share on other sites
  • Replies 440
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, just wanted to let you know that we are working on this and I'll update you as soon as I have more info! 

Not really sure what else to say. Can't see chat and names are just a block of pretty tie dye. Very strange. https://imgur.com/a/DupBvX5  

We’re continuing to track issues with the DX11 beta and work on fixes. The next game update will include a fix for the issue that’s causing the purple blur in your text boxes. Thank you all for contin

My framerate on Dx 11 in Gw2 is about a third of what it is in Dx 9.

Using Dx 9 I can run the game fully maxed on 1080p and never dip below 60 but in dx 11 I get framedrops as low as 10-15.

Note this is on a recent, Dx 12 compatible Nvidia GTX gpu fully up to date on all software and firmware fronts with all Control Panel and Experience options turned off.

 

-Screenshots made in Dx 11 don't save in the screenshots folder and are completely lost

Edited by Pheex.8932
Link to post
Share on other sites

The main issue I encountered is that the world map is slightly blurry even when fully zoomed in (but not the minimap).

Aside of that there was one case when every visible object flashed in technicolour for a moment before they went back to normal. And Grothmar Blood Keep coconuts were fully black.

On the upside, in some areas it makes my CPU 10-15 degrees cooler with ultra shadows than it was on DX9 🙂

Link to post
Share on other sites

Speaking of me, I don't have any graphical issue at all. But I have a huge problem with fps and input lag:

Basically the game had the max fps at 60 instead of 63 and that might not be seen as a problem, but when fps drops the input lag become huge. I can move a window in game with mouse and drawing a circle and the window has some difficulties follow the cursor, it is like in slow motion. Also fps drops randomly at exactly 30fps  (not 31 or 29), but it become unplayable because when I change camera position it happens most of the time. Even in the character creation screen, if I move the character there is the input lag even at 60fps.

Another weird example is that sometimes animations goes in slow motion and then double the normal velocity for a second or two, and finally back to normal.

I was thinking that was a problem related to vertical sync, even though in-game the option was off. I use Nvidia card, so I went to control panel, 3d settings and tried to forcing turning it off. And it is better, but still sometimes it isn't off. Randomly the v-sync turn it on and the input lag become clear again. It happens like every 10 minutes or so. I can see the solution is by turning off the v-sync but I am not able to do it permanently. For now I'm going back to Dx9.

i5 8400 4.0Ghz - 8GB RAM - GTX 1050 2gb

Edited by Fedexer.2486
  • Like 3
Link to post
Share on other sites

This morning my game froze three times in Mistlock Santuary the moment i login. Only on the fourth login then it was ok.

Just now, in a zerg fight against the second area boss in Frost Citadel, again the game froze and it prompted that the game client is not responding and i have to close the program. But when i logged back in, suddenly i was teleported to Mistlock again and all the chests and rewards i got during the north meta are gone >.< The Dx11 can cause a rollback? I am unchecking it for good.

This frozen screen problem only happened today after a quick patch update when i login this morning.

Edited by Mil.3562
Link to post
Share on other sites

I think it would help a lot if you all said what graphic setting you have

 

Anyway here my setting:

NVIDIA 3080  driver 472.12

 

 

 Resolution : 1920x1080

Fullscreen

 

Animation: High

Antialiasing: SMAA (HIGH)

Environment : High

LOW Distance : Low

Reflection : ALL

Textures : High

Render Sampler: Nativ

 

Rest:  High

 

 

My problem is the map (M key) is blurred which results in my eyes trying  to get focus on this which really hurt my eyes.

I can only guess that seems like the result of too aggressive Antialiasing like some other bugs here too. I will test this but this shouldn't happen normally

 

Some WvW Map

 

 

 

Link to post
Share on other sites
17 hours ago, Shinjiko.1352 said:
  • Super Cloud Glider

Looks completely different in dx11 vs 9, less vibrant and a bit glitchy. This difference glitches on different maps and the colour changes. Super cloud has always had some issues with certain maps changing it slightly, but it always stayed looking mostly alright and vibrant.

I have original screenshots if needed, but figured it'd be easier to look at if they were all in one picture. I tried to take them in the same locations.

https://i.ibb.co/LPy7rDf/supercloud.png

  • Otter Infusion

Not sure if this is me imagining it or not but it's a lot harder to test atm. But on dx11 the otter seems less transparent and more solid. I could be wrong and I don't have any pictures to go with this yet.

Specs

6700k, 16GB DDR4 3200Mhz, GTX 1070, Latest NVidia Drivers

adding this here since this seems to be the main glitch thread.

Link to post
Share on other sites
Initial observations on DX11 with a 5760 x 1080 triple-monitor setup: (All graphics settings on max. GTX 1080)
FPS is definitely higher. Almost always above 100. Haven't been to a boss fight yet.
Initial splash screen on character selection is oversize.
Menu, map, chat window, & Achievements notifications have moved to the outside of the left & right monitors. Without DX11 enabled, they are on the outside edges of the center monitor.
I can get used to playing it like this except for having to turn far to the right to view the mini-map.
Link to post
Share on other sites
10 hours ago, voltaicbore.8012 said:

All of this will be moot for me when I finally take the plunge and stop booting into windows and boot exclusively into linux. I'll just live with a whole new level of glitches there (when it comes to wine) when the time comes.

It ain't problem-free, for sure. But one thing I noticed was that translation from DirectX 9 to Vulkan made the camera stutters go away, similar what the native DirectX 11 implementation is doing now.

Edited by Hell Nirvana.9045
Link to post
Share on other sites

Same tie-dye blue text boxes here. Win7, GTX 1660, otherwise pretty old. Worked fine on my Win10 laptop with a mobile nVidia card (forget which and currently can't check). Cleared temp files, uninstalled all add-ons and reshade, etc.

Edited by Boho.2698
Link to post
Share on other sites
22 hours ago, Necrid.6247 said:

Well, i had high hopes for the Beta directX11 functionality.

They got crushed pretty fast.

On the character selection screen ALL text was just unreadable colourful area-fields - had to fight my way back to uncheck the BetaBox. Completely unplayable unfortunately.

Windows 7 Service Pack 1, CPU Intel i5-3570, 16 GB RAM

NVIDIA GeForce GTX 1060 6GB, Driver 30.0.14.7111 (06.21.2021)

 

 

That's why it's in beta...since you got no idea what that is supposed to do I don't think you can even understand what I am about to explain. They released beta to test it and see player feedback so they can inprove. This isn't final version making the game unplayable for you. They still gather error and bugs and moving on fixing them. Immagine expecting a fully 100% working feature on the first day of beta...some people...

Link to post
Share on other sites

So far I have not had any of the issues others reported. I was expecting at least a little increase in FPS as DX9 only runs my GPU to maybe the mid 40% usage range on full maps, but so far have not seen any real increase.

The odd issue I am seeing is that if you are in game, running full screen and ALT+TAB to minimize the game and look at something else it does not actually minimize the game.... it acts almost like the game is moving desktop.... you can see the Windows bar and like your browser, but the game is still up and visible in the background. Then, if you click what would normally be your desktop, it takes you back into full screen game mode.

I guess more accurately, it is acting like you are running in "windowed fullscreen" mode when you are full-screen. I attempted to change to "windowed fullscreen" mode and there was zero change (it stayed at normal fullscreen)

https://ibb.co/dW7NNzD

(system spec: AMD 3950X, 32G RAM, 3080Ti, Windows 10 build 21H1, running at 4K res with most settings maxed)

Edited by DemonAtTheWheel.1804
Link to post
Share on other sites

5800x. 3080 on 472.12 driver. Game runs fantastic now but I noticed in some specific parts of the map (like running through doorways at the high jump ranch) causes the game to blink black for exactly one frame. UI/chat box don’t blink just everything behind it.  It’s repeatable by just walking back n forth… like you suddenly walk into a black hole for a split second. Very strange

Link to post
Share on other sites
10 hours ago, DemonAtTheWheel.1804 said:

Additional note....

I just attempted to change from my normal 4K to 1080 resolution to see if that might make a change..... the screen became burry, but the res did not change at all, it remained in 4K, just with bad rendering.

 

This! Finally found someone with the same problem. I usually run the game on 1920x1080 because otherwise my potato laptop catches flames. With the dx11 beta the game doesnt change the resolution anymore, it just becomes super blurry. It appears as if it tries to scale in windowed fullscreen.

(Specs: Win10, GTX 950M, 64bit, everything is freshly updated)

Link to post
Share on other sites

The Telemetry from Windows 10 was backported to Windows 7-8.1 and delivered via Windows update, so chances are you have it even if you're using that ancient OS.  There is literally no reason to stay on "New XP," and games will start dropping support for it.  Even drivers are going to start dropping support, soon.

 

In any case, issue doesn't present itself on my machine, with a Radeon 5700 XT running the latest AMD drivers.  I haven't tried on my laptop with Nvidia, but there are a lot of older Nvidia cards being featured in these "reports."  It's possible that it may be disproportionately affecting GTX/RTX users.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...