Jump to content
  • Sign Up

DirectX 11 beta graphics issues


Recommended Posts

Crashes occcuring when taking part to large crowds events (even if I have all characters settings on low). Didn't happen before with Dx9. I had crashes at Piñata, Triple Trouble and in the Silverwastes, but these are all that I tried so other large scales events might also be included. 

 

Running Windows 10 (64-bits), with a Ti-1050, intel core i5 8400 (16Gb ram)

Link to post
Share on other sites
  • Replies 297
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, just wanted to let you know that we are working on this and I'll update you as soon as I have more info! 

Not really sure what else to say. Can't see chat and names are just a block of pretty tie dye. Very strange. https://imgur.com/a/DupBvX5  

We’re continuing to track issues with the DX11 beta and work on fixes. The next game update will include a fix for the issue that’s causing the purple blur in your text boxes. Thank you all for contin

My glider (https://wiki.guildwars2.com/wiki/Feathers_of_the_Zephyr)  stopped showing since this update..

 

Also..I'm getting constant crashes, specially in more intense areas, like wvw, Drizzlewood and Thunderhead Keep.

I've submitted reports ingame but I thought it would be a good idea to post in this forum.

 

To whom it may concern my machine is composed of:

 

        Operating System
            Windows 10 Pro 64-bit
        CPU
            Intel Core i5 6600 @ 3.30GHz    45 °C
            Skylake 14nm Technology
        RAM
            16,0GB Dual-Channel Unknown @ 1064MHz (14-14-14-32)
        Motherboard
            ASUSTeK COMPUTER INC. H110M-C/BR (LGA1151)    51 °C
        Graphics
            Philips 236V4 (1920x1080@60Hz)
            3071MB NVIDIA GeForce GTX 1060 3GB (Gigabyte)    40 °C
        Storage
            111GB SanDisk SDSSDA120G (SATA (SSD))    31 °C
            931GB Western Digital WDC WD10EZEX-00WN4A0 (SATA )    36 °C
        Optical Drives
            HL-DT-ST DVDRAM GH22NS50
        Audio
            Realtek High Definition Audio
Operating System
    Windows 10 Pro 64-bit

Link to post
Share on other sites
4 hours ago, malevolence.9487 said:

Got a weird issue here with DirectX11 on my high end PC (RTX 3090 + i9 10900k). In DirectX11 the GPU Utilization is around 30%~40% but with DirectX9 the GPU utilization is around 70%~80%, obviously the performance in DirectX11 is worse than DirectX9.  

Out of curiosity, do you run in Fullscreen mode? I'm wondering if this has anything to do with the fact that DX11 only has windowed modes.

Link to post
Share on other sites
5 hours ago, malevolence.9487 said:

Got a weird issue here with DirectX11 on my high end PC (RTX 3090 + i9 10900k). In DirectX11 the GPU Utilization is around 30%~40% but with DirectX9 the GPU utilization is around 70%~80%, obviously the performance in DirectX11 is worse than DirectX9.  

Not necessarily. Does that increased GPU utilization also come with a higher frame rate?

Link to post
Share on other sites

btw did everyone's encounter fps get nuked down to 30 range? like 5man fractals and 10man raids, where its not even that demanding

like my addons broke so i first removed everything

default was really bad

default with dx11 beta was also really bad

 

and then opting out of that and reinstalling the dx12 mod its still bad. is dx12 the cause or this update?

Edited by Incurve Giidis.7829
Link to post
Share on other sites

i haven't really experienced anything weird with dx11 until i played the "descent" instance of war eternal

 

some screenshots i took of the final cutscene + aftermath:

https://imgur.com/a/6UZ7zTd - kralk's death seemed to have some unexpected consequences for rytlock

https://imgur.com/a/DYBXq1u - chat bubbles would not appear over character's heads or in the chatbox

https://imgur.com/a/39i0JFf - everything would disappear when i moved my camera at certain angles, experience bar would also randomly appear + disappear as i ran around

 

screenshot of after returning to lion's arch:

https://imgur.com/a/ACYiaY5 - everything except for terrain disappeared. i could move normally and collision/physics/whatever still worked properly even though i couldn't see anything. my ui would not work at all

Link to post
Share on other sites
7 hours ago, Taniniver BlindDragon.9503 said:

Not necessarily. Does that increased GPU utilization also come with a higher frame rate?

 

Yes, in DX9 when there is more gpu utilization my fps is higher. DX11 gpu utilization is not right for my setup.

 

7 hours ago, firewire.4813 said:

Out of curiosity, do you run in Fullscreen mode? I'm wondering if this has anything to do with the fact that DX11 only has windowed modes.


Yes in Fullscreen mode. What do you mean with 'DX11 only has windows modes' ?

Link to post
Share on other sites

Not really sure how or why this would relate to the DX11 beta, but I was decorating in my guildhall and swapped over to the DX11 as I finished up on a project I'd been working on.  I decided to swap out one item for a similar item and was informed I had exceeded the decoration cap.  I removed probably a dozen decorations before I was back under the cap.  Frustrated beyond words (as this particular project had taken several hours to create), I decided to turn the DX11 back off.  Suddenly I was able to restore what I had built and even add another piece or two.

 

So it would seem that the DX11 affects decoration cap limits as well.

Link to post
Share on other sites
4 hours ago, malevolence.9487 said:

Yes in Fullscreen mode. What do you mean with 'DX11 only has windows modes' ?

The DX11 beta only has windowed mode options available (that includes borderless). True fullscreen usually has better performance (if you only have 1 monitor), because it gives the game full control of the framebuffer.

Link to post
Share on other sites

I noticed yesterday in WvW that spark mobs at shrines where basicly rocks with spark legs, lol.

I also noticed that bamboo fence on DBL was purple... but ONLY at lod0. All other lod looked fine. Verfied it by changing the lod setting. Jumping to another map and back again made it dissapear.

Pretty random that probably have the same origin. Wonder when we get the next DX11 update.

Link to post
Share on other sites
18 hours ago, firewire.4813 said:

The DX11 beta only has windowed mode options available (that includes borderless). True fullscreen usually has better performance (if you only have 1 monitor), because it gives the game full control of the framebuffer.

That is strange because I can put fullscreen with dx11 enabled. I have only 1 screen so usually I play fullscreen and for the performance too 🙂

Link to post
Share on other sites
4 hours ago, Ashantara.8731 said:

I would love to reactivate the DX11 beta - but only after these severe glitches have been taken care of.

Any estimate, dear devs? 🙂

I agree DX11 is defiantly a step in the right direction performance wise. A little Dev feedback would be useful. What information do you need from us to help troubleshoot and fix these graphical glitches?

  • Like 1
Link to post
Share on other sites
37 minutes ago, malevolence.9487 said:

That is strange because I can put fullscreen with dx11 enabled. I have only 1 screen so usually I play fullscreen and for the performance too 🙂

Have you tried pressing the windows key? Yeah. Its not fullscreen no matter how much you set your resolution to fullscreen. Its windowed fullscreen.

Link to post
Share on other sites
On 9/28/2021 at 3:53 PM, Ornitha.5862 said:

i haven't really experienced anything weird with dx11 until i played the "descent" instance of war eternal

 

some screenshots i took of the final cutscene + aftermath:

https://imgur.com/a/6UZ7zTd - kralk's death seemed to have some unexpected consequences for rytlock

https://imgur.com/a/DYBXq1u - chat bubbles would not appear over character's heads or in the chatbox

https://imgur.com/a/39i0JFf - everything would disappear when i moved my camera at certain angles, experience bar would also randomly appear + disappear as i ran around

 

screenshot of after returning to lion's arch:

https://imgur.com/a/ACYiaY5 - everything except for terrain disappeared. i could move normally and collision/physics/whatever still worked properly even though i couldn't see anything. my ui would not work at all

The same thing happened to me in the Descent cutscene & epilog.  The characters all appeared against a completely black background, half of Rytlock's body was gone, chat was really wonky, and panning the camera got the same glowy mess, plus lots of the ship deck glitched in and out of view.

When I got to Lion's Arch, most of the UI didn't appear, most of my skills were missing, couldn't pull up any options, the "end of chapter" award box showed only one of the  crossed swords and a few dragonite ore, with no way to click to accept it.  I forced the game to exit and came back in and it was back to normal, was able to claim the final loot.

I was looking forward to seeing Aurene's transformation again, so that was a disappointment.

Edited by Kaliwenda.3428
Link to post
Share on other sites
4 hours ago, malevolence.9487 said:

That is strange because I can put fullscreen with dx11 enabled. I have only 1 screen so usually I play fullscreen and for the performance too 🙂

That's not true fullscreen if you can see your taskbar at the bottom when you press the Windows key with the game in the background. That's "fake" fullscreen (aka, borderless window).

Link to post
Share on other sites

Daily T4 fractals had Aetherblade today. Apparently having DX11 on can cause all graphics and the UI to suddenly converge into the mists and disappear. Happened around the 50% Mai Trin boss phase. 

https://imgur.com/a/zQAT564


Had to restart a few times after this happened. Dx11 does NOT like multiple AoEs spawning on the screen. It weirdly turned the npcs invisible first.  I tried typing  out of shock and then the chat disappeared, and the floors became see-through. It then kept swapping a few things to be slightly visible, and then gone again. Wild experience. 

Edited by Manamari Tsunami.2049
Made link into hyperlink
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...