Jump to content
  • Sign Up

Can't launch game after the November 9, 2021 update


Recommended Posts

  • Replies 805
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, I just want to leave a quick note that some people are looking into this and trying to chase down a fix. 

Thank you all for your patience on this. We've been working hard to get this sorted out and have identified a fix. We'll have that out to you as soon as possible.

Right after the update, the game "launches" in the background but you can't switch to it. I can hear the music and everything but can't see the actual game. Alt Tab doesn't work and I need to end

1 hour ago, The Irish Brute.2180 said:

Same problem here. As soon as I login and press play, game doesn't launch and screen is frozen. Task manager freezes also. I thought it was just me, so I've tried the following to no avail:

-Reinstalled windows

-Reinstalled DirectX 

-Repaired game client

-Reinstalled game client 

-Ran in -windowed mode

-Uninstalled MSI afterburner & RivaTuner 

-Disk cleanup and transferred game to another drive

 

Something needs to be done about this, Anet. 

Wow you have done a LOT! But just so you know it is not you or your computer. It is due to the patch itself and Anet IS currently working on a fix.

Question: Did the -windowed mode not work for you??

Link to post
Share on other sites
13 hours ago, Vile Vials.6543 said:

  This has happened to me ever since the very first beta elite-spec preview. The launcher would launch for a second then immediately close. The first time i experienced this i had to totally uninstall the game and delete all data and reinstall.

Second time this happened was a patch after that first week, I want to say it was the Tuesday after that first beta happened. So, seeing how that worked the first time (though it gets VERY old having to delete/reinstall the game every time this happens) I continued to totally uninstall and delete all files. Downloaded the GW Installer only to have that do THE EXACT SAME THING. I couldn't even install the game because the launcher for the installer immediately closed. Came back to it a day or two later and was able to install the game and get it up and running again. Rinse repeat this scenario for every time Anet has implemented a patch/game update since that initial beta. I have posted every single time this has happened in the Bugs forum but have never had a real clear and concise answer.

    And yes, now once again, I cannot open the game. The GW launcher opened and downloaded the update after the 11am update (central time) but as soon as it finished downloading the launcher closed and never opens and STAYS running.

At this point i don't know what to do. When this happens i go and make sure i have all the updated graphics drivers, restart, etc. This got old after the first 2 or 3 times it happened to me.

 

Holy s**t, I can't believe I've actually found someone else that is having the SAME EXACT ISSUE I have been having for the past couple months! I have done everything you have done to try and fix it, and I have been able to play the game, although every patch has had it's own issue. I honestly thought I alone with this, that it was something on my end, but now I'm starting to think that it has to be a bug involving the launcher. Hopefully there are others that are in our situation to get momentum on this so they can address it. 

Link to post
Share on other sites

Adding -dx11 to the shortcut worked for me.  (Win10 x64)

 

On a side note, I ran a procmon trace while launching gw2 as a normal (non-admin) user.  In the trace, I noticed that both GW2-64.exe and CoherantUI_Host.exe processes attempted to open machine-scope (HKLM) Registry keys for the System Certificate store.... with WRITE/DELETE access.  This struck me as odd, to say the least. 

 

Attempting to open the System Certificate store with WRITE/DELETE access is fairly... malware-ish.  (This is one way that some malware will achieve persistence on an infected machine).

 

Anet:  Is this expected?

 

I'd be happy to upload a procmon trace, if that helps.

  • Thanks 1
Link to post
Share on other sites

I managed to log in by

1) turning off the windows Game Center

2) renaming the exe and then renaming it back

3) logging in and changing my graphics settings to windowed. 
 

i don’t know yet if I can get back in or not but I’m here! And Halloween is over! :( 

 

thanks Guild Wars 2!

Link to post
Share on other sites
14 hours ago, Vile Vials.6543 said:

  This has happened to me ever since the very first beta elite-spec preview. The launcher would launch for a second then immediately close. The first time i experienced this i had to totally uninstall the game and delete all data and reinstall.

Second time this happened was a patch after that first week, I want to say it was the Tuesday after that first beta happened. So, seeing how that worked the first time (though it gets VERY old having to delete/reinstall the game every time this happens) I continued to totally uninstall and delete all files. Downloaded the GW Installer only to have that do THE EXACT SAME THING. I couldn't even install the game because the launcher for the installer immediately closed. Came back to it a day or two later and was able to install the game and get it up and running again. Rinse repeat this scenario for every time Anet has implemented a patch/game update since that initial beta. I have posted every single time this has happened in the Bugs forum but have never had a real clear and concise answer.

    And yes, now once again, I cannot open the game. The GW launcher opened and downloaded the update after the 11am update (central time) but as soon as it finished downloading the launcher closed and never opens and STAYS running.

At this point i don't know what to do. When this happens i go and make sure i have all the updated graphics drivers, restart, etc. This got old after the first 2 or 3 times it happened to me.

 

I just saw this now when someone else quoted you saying they had the same problem. This sounds like a different problem than the majority are having so I suggest submitting a ticket to Anet and listing all the issues in point form going by date. I have noticed when they are overwhelmed they sometimes do not read the whole problem fully but just like when I have to talk to doctors it is the same thing: Point form and straight to the point and they usually DO actually read it all.

Many times they may try to group you in with what other problems are but reading this I would say this is not the same issue that has just came about due to this patch. People who have had no problem and then suddenly after the patch started not being able to play the game but could hear the game's music seems to be the issue the majority are having related directly to the Nov 9th patch.

So that your issue does not get grouped in with the majority I would suggest creating a ticket and follow it closely. When I told them that the temporary work around of playing windowed mode let me play, they wanted to close my ticket saying they were happy it was solved. I corrected them by telling them that is not solved but only a temporary fix. Keep that in mind when you start your ticket that it does not get closed until it is actually fixed. Make sure you attach all the things listed in Collecting Diagnostic Information for Support (Reporting Tech Issues) – Guild Wars 2 Support  and check your email that is associated with your account.

Link to post
Share on other sites
7 hours ago, Ubi.4136 said:

OK, got it to work.  The poster above who said fullscreen is the cause, is correct.

If you run dual monitors it doesn't seem to be a problem.  Only single monitors set to full screen seem to be the issue.  If you can add a second monitor to get in to the options, you can choose a windowed mode and then remove the second monitor.  After changing the setting, it works.

On a machine with just one monitor, set to full screen, I don't know how you would get it back, F11 didn't work for me.

 

I run with the game on 80% of my monitor, so I can see a small browser on the side, I had no problems.

My wife runs dual monitors, and it let me get in game on hers.  It was set to windowed fullscreen.

My daughters computer, which was the one not working, was set to "full screen" and she only has the one monitor.

Plugged my monitor in to give here two monitors, reran the game and it launched it on the side monitor.  After changing the settings to windowed fullscreen, removed the second monitor and relaunched, it works.

 

You can change it to windowed mode via the command line. You access that in the file's properties. Only edit a shortcut you make on your desktop since this will be just a temporary fix until Anet releases a new patch to fix this. They ARE currently working on things. I had submitted a ticket and they told me that. So make a new shortcut on your desktop (you can even just copy paste the one in your start menu as it is a short cut as well to the game) and then with the short cut on your desktop right click on it and select properties. Then in the shortcut tab of that where it says ...\Guild Wars 2\Gw2-64.exe"  type a space after the " and then type -windowed and click the OK button. Then that short cut will LAUNCH the game in WINDOWED MODE.

Also someone else suggested adding -dx11 to the command line. Is this with the -windowed or without?

I am running Windows 10 64-bit, NVIDIA, and DX12. 

Also ANet has been working hard on this so check periodically to see if it is fixed without all the little tricks here and there (that is why do not edit the original shortcut).

 

Edited by Katiekaboom.1980
  • Thanks 3
Link to post
Share on other sites
13 minutes ago, SexyMofo.8923 said:

I found a solution. Uninstall seems to work. I ne we encounter the problem after that. 

It is possible that it is working not because of the reinstall but because Anet has been working on it. Others have uninstalled and reinstalled and more with no success. So really consider this before taking this option. Putting -repair in the command line (best to make a new shortcut in case anything screws up) and trying that first is advisable before uninstalling.

___________

46 minutes ago, Whizzmo.8209 said:

On a side note, I ran a procmon trace while launching gw2 as a normal (non-admin) user.  In the trace, I noticed that both GW2-64.exe and CoherantUI_Host.exe processes attempted to open machine-scope (HKLM) Registry keys for the System Certificate store.... with WRITE/DELETE access.  This struck me as odd, to say the least. 

Attempting to open the System Certificate store with WRITE/DELETE access is fairly... malware-ish.  (This is one way that some malware will achieve persistence on an infected machine).

Anet:  Is this expected?

I'd be happy to upload a procmon trace, if that helps.

Submit a ticket as that is important information. 😮

 

Edited by Katiekaboom.1980
Link to post
Share on other sites
57 minutes ago, Ash.5034 said:

When I enter the game, it now starts in windowed mode. If I try to fullscreen. it crashes the client.

Yes it seems the only way we can play for now until Anet fixes the problem completely. Others have suggested adding -dx11 to the command line (in lieu of -windowed ?? Not sure). Also I am not sure -dx11 would work for everyone.

Link to post
Share on other sites
36 minutes ago, Katiekaboom.1980 said:

It is possible that it is working not because of the reinstall but because Anet has been working on it. Others have uninstalled and reinstalled and more with no success. So really consider this before taking this option. Putting -repair in the command line (best to make a new shortcut in case anything screws up) and trying that first is advisable before uninstalling.

___________

Submit a ticket as that is important information. 😮

 

Yeah very likely, i constantly tried to log in and managed to log in once but soon i cannot log in. it does feel like working in progress.

  • Like 1
Link to post
Share on other sites
53 minutes ago, Katiekaboom.1980 said:

You can change it to windowed mode via the command line. You access that in the file's properties. Only edit a shortcut you make on your desktop since this will be just a temporary fix until Anet releases a new patch to fix this. They ARE currently working on things. I had submitted a ticket and they told me that. So make a new shortcut on your desktop (you can even just copy paste the one in your start menu as it is a short cut as well to the game) and then with the short cut on your desktop right click on it and select properties. Then in the shortcut tab of that where it says ...\Guild Wars 2\Gw2-64.exe"  type a space after the " and then type -windowed and click the OK button. Then that short cut will LAUNCH the game in WINDOWED MODE.

Also someone else suggested adding -dx11 to the command line. Is this with the -windowed or without?

I am running Windows 10 64-bit, NVIDIA, and DX12. 

Also ANet has been working hard on this so check periodically to see if it is fixed without all the little tricks here and there (that is why do not edit the original shortcut).

 

The -windowed mode works for me. Thanks. Hope they do fix it soon, a slightly too big window and it crashed for me again 🙂

  • Like 1
Link to post
Share on other sites

I was using DX11 before the patch. Due to some minor graphical issues I decided to switch back to DX9, then exit the game. When I launched it I ended up with the same issue as everybody else here. Aside from the minor graphical issues, the game was running fine with DX11, even after the patch. I've found in the past when using DX11, if I end up with some graphical issues, the game will eventually crash. Happened during Halloween event when I was just running through Lion's Arch toward a carving pumpkin.

Same issue no being able to use Windows task manager to shut the game down. (The game in task manager was marked as not responding.)

But, I already knew an easy trick to solve that problem. When you bring up Windows task manager, press the up/down arrow keys on your keyboard to highlight GW2, then press the delete (Del) key on the keyboard. The game will instantly shut down and you gain control of your PC again. If pressing the arrow keys doesn't do anything for task manager, press the Tab key. You should then be able to use the arrows keys to highlight the game in task manager.

Edit: I did launch the game a second time and got to the character select screen. I opened the game options here and selected the best performance preset in the graphics options when the game suddenly crashed. (I was going to select best performance, then best appearance to make sure the graphics are OK, then adjust settings the way I like them.)

Edited by Charrbeque.8729
  • Thanks 1
Link to post
Share on other sites

Same issue here. The game doesn't launch and freezes everything. It crashed properly only the first time. Strangely enough it ran fine yesterday just after the patch and only started doing this after the Windows 10 update I did last night. Hopefully they'll notice how many people are experiencing this.

Link to post
Share on other sites

Last night patched the game and it worked ok. Shut down and then this morning attemtpted to play again. Had exactly the same issues as described by the OP. Game Launches on the Start-bar, music plays but it doesnt open the character select screen.

Tried right clicking the GW2 icon on my desktop and ran as administrator, that worked.

Logged out, shut the machine down. Clicked on the GW2 icon as normal (without right click/run as administrator) - that worked.

Machine is Windows 10 fully patched. Not using any add ons in game. Not using the DX11 beta. Latest NVIDIA drivers. Game always run in full screen mode.

Edited by Andy.5981
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...