Jump to content
  • Sign Up

Can't launch game after the November 9, 2021 update


Recommended Posts

9 hours ago, Katiekaboom.1980 said:

 

Here is the answer I have gotten:


Here is the temp fix:

Launching the game in WINDOWED MODE instead.

  1. Create a shortcut to your Guild Wars 2 client (gw2.exe, Gw2-64.exe) by right-clicking the file and selecting "Create Shortcut."
  2. Now right-click the shortcut and choose "Properties."
  3. In the line that reads "Target," add a space at the end of the line and then add the following: -windowed
  4. Your target line should now look something like this: C:\Games\Guild Wars 2\Gw2.exe” -windowed
  5. Click "Apply" and then "OK."
  • Launch your client and log into a character.

 

 

Worked for me. Thanks!!

Link to post
Share on other sites
  • Replies 805
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, I just want to leave a quick note that some people are looking into this and trying to chase down a fix. 

Thank you all for your patience on this. We've been working hard to get this sorted out and have identified a fix. We'll have that out to you as soon as possible.

Right after the update, the game "launches" in the background but you can't switch to it. I can hear the music and everything but can't see the actual game. Alt Tab doesn't work and I need to end

9 hours ago, Spire.6109 said:

I will say this from the error log, it points to 
D:\Perforce\Live\NAEU\v2\Code\Arena\Services\Handle\Handle.h(81)
My D Drive is my DVD drive and my hard Drives are C and E.  So what's it pointing to for the 😧 drive?

 

Nothing to worry about. That's not a path it's trying to access on your machine, it's just a path that refers to the file in ArenaNet's system (I assume the path on the build machine).  This way they know what file it is in their source code tree.  I think in the past it used to report a relative path (also files that do not exist on the player's system), so it wasn't nearly as noticeable as this full path.

Link to post
Share on other sites

I find the absolute lack of information in the comments amusing (and maybe a little upsetting).

"It doesn't work" isn't a useful error report.  What's your OS? What's your hardware config (CPU, GPU)? Do you use DX9 or DX11 in Guild Wars 2? Do you run the game windowed, windowed full screen, proper full screen?

I saw someone brought it up on like the second page that people should tell details — and then basically nobody continued to do so.

 

Anyway, looks like windowed mode is unaffected — and is probably why I never noticed this issue.  As mentioned in a comment above, try to run the game with the `-windowed` command line option.

  • Sad 1
Link to post
Share on other sites
19 hours ago, tom highway.9051 said:

I found out that if you change the startup parameters -dx11 then it should start again.

By me: "D:\Guild Wars 2\Gw2-64.exe" -dx11

 

This worked for me as well. For those who don't know how to do the above, you need to edit the *shortcut* to GW2. Right click the shortcut, click Properties. On the Shorcut tab of the Guild Wars 2 Properties window, look at the "Target:" line. It probably reads (including quotes) "C:\Program Files\Guild Wars 2\Gw2-64.exe". Add -dx11 *after* the quotes, like so: "C:\Program Files\Guild Wars 2\Gw2-64.exe" -dx11. Close the shortcut properties. Then double-click the shortcut and try again.

  • Like 2
Link to post
Share on other sites
48 minutes ago, Shinavast.1328 said:

I don't know if its been answered or not (there's 19 pages in this thread...)  but i had this same issue and the following worked for me:   I was having the same issue where I would fire the game client,  CPU suage would SPIKE to 97-100%, i would get audio in the game client window that was consistent with character select screen,  but no video.  Moreover, not only could i not alt-tab out,  i couldn't interface with anything (no right click, no clicking on anything period, etc).   I ultimately had to hardboot several times to get my rig to respond. 

 

This worked though and i was able to play without any issues immediately after i did this.

 

NOW... before you do this.  please understand that this will reset your hardware settings but you will also need to re-enter your login credentials if they are saved (this should only take you about 30 seconds if you're like me and forgot them and had to reset them, but still).   However as soon as you fire up the client again, the folder will be re-created and populated.

 

Hit windows key.

type "run" - hit enter

type %appdata%/Guild Wars 2/

 

Delete this folder.

 

Fire up the client,  sign in,  and hit play.    The client SHOULD execute as normal.  You may have to go in and adjust your hardware settings to your personal preference rather than the software's detected automatic settings, but you can do that as normal in the settings menu.

 

Good luck, hope it works for you all!  🙂 HAPPY UPDATE DAY. 😄

 

 

 

This Just worked for me! 

Thanks a lot man!

 

 

 

Link to post
Share on other sites

As many others I have  had the same issues but have switched to the windowed mode switch and have been able to play for the last 2 or 3 attempts without a major problem.

 

Prior to that, I noticed that when i tried to start in my normal full screen mode and if it worked or not, when i Alt-tabbed out to the other windows i had running (Mozilla browser with several tabs open and Task manager for example) it seemed like there was another layer over the normal desktop that would stop any mouse interaction. I could not select anything via mouse but could if i swapped between with the Alt tab. Once in an application i could not use the mouse to scroll down or select anything in the app but i could via keyboard commands.  Not sure if that is a beneficial observation or not.

One thing i found was it was easier and probably less damaging to the system when i was hung up was to force a sign out and sign back in vs. a hard reboot.

 

Link to post
Share on other sites
19 minutes ago, Michael Patricius.4369 said:

This worked for me as well. For those who don't know how to do the above, you need to edit the *shortcut* to GW2. Right click the shortcut, click Properties. On the Shorcut tab of the Guild Wars 2 Properties window, look at the "Target:" line. It probably reads (including quotes) "C:\Program Files\Guild Wars 2\Gw2-64.exe". Add -dx11 *after* the quotes, like so: "C:\Program Files\Guild Wars 2\Gw2-64.exe" -dx11. Close the shortcut properties. Then double-click the shortcut and try again.

Worked for me! Thank you <3 

Link to post
Share on other sites

Tried the methods in de topic such as delete the %appdata files , rename de exe file , prefix the shortcut with -windowed.

All the same issues for my atm with only black sreen with music from the character screen.

Only thing when i launch in windowed it is easier to quit the game , the computer dont crashes.

Link to post
Share on other sites
10 hours ago, Spire.6109 said:

I will say this from the error log, it points to 
D:\Perforce\Live\NAEU\v2\Code\Arena\Services\Handle\Handle.h(81)
My D Drive is my DVD drive and my hard Drives are C and E.  So what's it pointing to for the 😧 drive?

I have the same line in my error log, and I don't have a D drive at all. 

Link to post
Share on other sites

So when I click on play through the launcher, I can hear the music playing but I can still see my desktop and am not able to click on anything on the desktop. I cant even go on task manager to exit the game because I have to click on the program which I can't do. The only way for me to get out of it is to manually switch off my laptop.

Link to post
Share on other sites

I had to relogin a random number of times before I got to the character select screen.

Once I logged out, I had to start this all over again.

I could not stop GW 2 through task manager to relogin, I was able to retry by logging out of Windows through task manager and then logging back in.

Doing a repair did not work.

I then switched to Windowed full screen mode after a successful attempt.

I have now been able to login 4 times with out a problem.

Link to post
Share on other sites

yep still same problem with then not working desktop. got into the game one time after trying 2 times. then relogged and then cant get in anymore after trying/ restarting pc for 4 times. sometimes it bugs after open the client, so i can add mail and passwort, sometimes it already bugs after double click so i cant even add gw2 account datas for the log in.

i can restart pc with strg+alt+entf (german keyboard, combination to open task manager but go for restart instead open taskmanager, since task manager will be greyed out/unclickable/ even uncloseable too after opening) to avoid hardware shut down but thats it.

Edited by JazzXman.7018
Link to post
Share on other sites

So I originally posted about renaming/deleting the gw2-64.exe.  This worked at the time.  

Today not only is the game back to audio only, but deleting and redownloading the exe did not help.  So back to square one.

 

As to posting OS details and whatnot, does that even get read here?  We've had no feedback or requests for info from anet so my thought is that they're not even monitoring this post beyond the "we know there's a problem" ~18 hours ago.  No sense filling it up with everyone's system info unless asked.

 

The only real solution at this time is keep attempting to log in until you get that one attempt that works.  And then do NOT log out under any circumstances (outside of a "new build available") or you will be back to making login attempts.  /le sigh

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...