Jump to content
  • Sign Up

Can't launch game after the November 9, 2021 update


Recommended Posts

Same issue, appeared for the 1st time today. It worked fine last night. I have repaired client (successfully), cleared app data and have the latest vid card drivers. Didn't work. I used the line command to launch in windowed mode. It got to the character screen but no farther. Had to restart the computer to get out of the locked up screen.

Link to post
Share on other sites
  • Replies 805
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, I just want to leave a quick note that some people are looking into this and trying to chase down a fix. 

Thank you all for your patience on this. We've been working hard to get this sorted out and have identified a fix. We'll have that out to you as soon as possible.

Right after the update, the game "launches" in the background but you can't switch to it. I can hear the music and everything but can't see the actual game. Alt Tab doesn't work and I need to end

3 hours ago, Cymric.9185 said:

Downloaded this fresh, haven't played for years, to leave New World. And the game won't even start lol. I'll take it as an omen.


Nuuu don't do it, it's been smooth running since I started last Christmas; it's just a post-patch bug that they've already identified and will be fixed soon. >.<

Link to post
Share on other sites
On 11/9/2021 at 12:27 PM, Proxima.8264 said:

To everyone having trouble closing the game, just open task manager (Ctrl+Shift+Esc), press G to highlight the guild wars process and press delete. Might save you some restarts 😄

 

Follow the above quote. The game launched fine for me on the second attempt after this bug. I followed the directions in the above quote, and the second launch of the game worked for me. Just now logged out after running around in Icebrood Saga for an hour.

Link to post
Share on other sites
11 minutes ago, WGHII.2491 said:

Here's a simple solution @Anet how about you roll back the patch from the 9th and work on it on the development side until you get it fixed. This is ridiculous in 2021. 

This is sadly, perfectly normal for "modern" gaming, where nothing works, every update break the game, every "fix" breaks more than it fixes, and the bugs never get fixed. I just didn't expect this old kitten game to be the same.

  • Like 1
Link to post
Share on other sites

Setting the "compatibility mode" of the shortcut, or Gw2-64.exe,  to windows 8, (also selected run as Administrator option) seems  to work here.

Not sure what it does on performance, but i get into the game.

Test2: After enabeling DX11 Rendering Beta in the graphics options ingame, and setting the compatibility back to normal, the game seems to start up normaly.

Edited by Kneitor.9367
Testing
Link to post
Share on other sites

For Lutris (Linux) users, add “- windowed” as an argument to your launcher (configure → game option → argument). Then expand the window to full screen on the character selection screen (before entering the game itself, otherwise it might crash). It worked for me at least.

Link to post
Share on other sites

Yep, it was anet, and as usual ---SILENCE!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! They wasted my time trouble shooting, changing this and that, checked drivers etc and not it seems to be working. GET A DEV IN HERE TO  FIX (which I believe they have now) and APOLOGIZE!

 

  • Like 1
Link to post
Share on other sites

One of my family members suggested this to me and it worked. He thinks it is an update issue.  He told me to get to the update screen and even though it says that it is updated just leave it for at least 5 minutes.  Sure enough it worked for me.  It is like it was trying to update, but it wasn't showing it had more to update if that makes sense.

Link to post
Share on other sites

Ran okay for a while today. But since then it's been the same situation.

So, I started it up while running as Admin, got as far as selecting my character to play and it instantly CTD.

I did manage to get an error report this time.

Description
Faulting Application Path:    C:\Guild Wars 2\Gw2-64.exe

Problem signature
Problem Event Name:    APPCRASH
Application Name:    Gw2-64.exe
Application Version:    1.0.0.1
Application Timestamp:    618957db
Fault Module Name:    StackHash_6de9
Fault Module Version:    10.0.19041.1288
Fault Module Timestamp:    a280d1d6
Exception Code:    c0000374
Exception Offset:    PCH_C3_FROM_ntdll+0x000000000009D8C4
OS Version:    10.0.19043.2.0.0.256.48
Locale ID:    1033
Additional Information 1:    6de9
Additional Information 2:    6de98e2bceb1804d499c96ae8f853b4e
Additional Information 3:    4f8d
Additional Information 4:    4f8dd1759a06ec68b71caeefa70717f7

Extra information about the problem
Bucket ID:    1aab63d53d4ab5554bcbefb98866bed4 (2002958039432740564)
 

Link to post
Share on other sites

Same. Game wont launch, freezes my comp, have to restart my computer. I have all updates and drivers on my comp,  I repaired the game, cleared game cache. The game started once yesterday randomly. I walked away, and an hour later I noticed the game had opened and I could interact with it. I left if open all day even when I was afk, just in case. Today I t wont launch again. This is not our computers, anet needs to fix it.

Link to post
Share on other sites
13 hours ago, Katiekaboom.1980 said:

You can change it to windowed mode via the command line. You access that in the file's properties. Only edit a shortcut you make on your desktop since this will be just a temporary fix until Anet releases a new patch to fix this. They ARE currently working on things. I had submitted a ticket and they told me that. So make a new shortcut on your desktop (you can even just copy paste the one in your start menu as it is a short cut as well to the game) and then with the short cut on your desktop right click on it and select properties. Then in the shortcut tab of that where it says ...\Guild Wars 2\Gw2-64.exe"  type a space after the " and then type -windowed and click the OK button. Then that short cut will LAUNCH the game in WINDOWED MODE.

Also someone else suggested adding -dx11 to the command line. Is this with the -windowed or without?

I am running Windows 10 64-bit, NVIDIA, and DX12. 

Also ANet has been working hard on this so check periodically to see if it is fixed without all the little tricks here and there (that is why do not edit the original shortcut).

 

This worked for me.  Thank you, Katiekaboom!

Link to post
Share on other sites
2 hours ago, robertgippy.1302 said:

Same here.  It happens after entering name and password.   You can hear game music but nothing more.   Task manager is also frozen and I have to use control, alt, delete and use sign out to try again.   The suggestions from other players are good but I'm leaving it alone as this is a Anet problem and not my computer.   Will just wait it out and hope we get a patch soon to correct it.

Couldn't have said it better. Logic tells us, we were all able to play fine before the update, so Anet need to sort the issue, and will sort this issue.

Link to post
Share on other sites
4 hours ago, Gregg.3970 said:

Well at times like this for me the moral of the story is have a backup option of another game to play, other irl hobby, other means of escapism, or just anything to fill that void in my soul irl other than just gw2 lol

 

Perfect timing for me for pushing myself in the Gym, weight training so not gonna bother with wasting my time with repeated login issues : It's 2 hour Leg Day in the Gym. No pain, no gain?!? Will just leave the devs to sort fix whether it's tomorrow, day after or whenever as not gonna waste any spare time trying 100 different login methods most which are crashing my PC. 

Yep.  Time for that blanket I'm knitting to get some attention.  After three different fixes fail to fix, I'm done 'til the devs get around to it.

Link to post
Share on other sites

Has any of you (yes, all of you who posted above) tried to reinstall the game outside of C:\Program Files ? That is a system folder and games do definitely not belong in there.

P.S. Also, have you added the Guild Wars 2 folder to your antivirus' list of exceptions?

Edited by Ashantara.8731
Link to post
Share on other sites
18 hours ago, ShionKreth.1542 said:


I wouldn't worry too much - it was working just fine for everyone before the patch; nvidia, gaming mode or otherwise. 😛

Don't forget anet is trying to roll out to DX11 ... I'm assuming they are pushing small patches out to prepare for the update that enforces this upgrade. Same issue happened with League ... they just have never found a solution to their problem and probably blame Nvidia 😧 GW2 is better though so I have faith.

  • Like 1
Link to post
Share on other sites
3 hours ago, Moe.2310 said:

Changing The compatibility of the Gw2-64.exe to Windows 7 made the game work for me.

 

https://imgur.com/7LDmpPB

This worked for me as well. Using Windows 10 Home 64bit 21H1, Nvidia driver 496.49.

 

4 minutes ago, Ashantara.8731 said:

Has any of you (yes, all of you who posted above) tried to reinstall the game outside of C:\Program Files ?

Also, have you added the Guild Wars 2 folder to your antivirus' list of exceptions?

I've always had the game installed in C:\Games\GW2 and had C:\Games in my exception list. So not the problem. Above noted solution did fix the issue however.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...