Jump to content
  • Sign Up

Can't launch game after the November 9, 2021 update


Recommended Posts

  • Replies 805
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, I just want to leave a quick note that some people are looking into this and trying to chase down a fix. 

Thank you all for your patience on this. We've been working hard to get this sorted out and have identified a fix. We'll have that out to you as soon as possible.

Right after the update, the game "launches" in the background but you can't switch to it. I can hear the music and everything but can't see the actual game. Alt Tab doesn't work and I need to end

This is how I just got it to work. Right click on your gw2 shortcut, click Properties, then under Target put a space then type -windowed ,Apply, then go ahead and use your shortcut. This forces it into windowed mode (minimized) from which you can click on the fullscreen symbol on the top right.

  • Like 1
Link to post
Share on other sites

I had this issue yesterday on 4 of my computers I was able to launch the game on all four this afternoon by running the GW2.exe as an Administrator. Now a few hours later and that process no longer works. Back to locking up entire computer and doing hard resets. Please fix this.

 

Edited by Grawl.3746
  • Thanks 1
Link to post
Share on other sites
34 minutes ago, Mogster.7429 said:

Thanks, this worked for me. I nuked the Guild Wars 2 folder in Roaming and any gw2cache folders in Temp and the game launched without a problem.

You could have just deleted the Local.dat and all the gw2cache-{ temp folders. No need to rename anything for that purpose.

Link to post
Share on other sites

For now I just put -windowed like this Guild Wars 2\Gw2-64.exe" -windowed and it works. When I'm in game I just make it fullscreen and it works right now. I also have -autologin - bmp in their as well.  Someone on the forum suggested this I'm not taking credit for it. So if your that person, thank you! 😀👍

Edited by Tony.8659
Link to post
Share on other sites

I just experienced the same issue (sound but nothing launches), however, the game client worked just fine earlier in the day. I also just tried running the program as an administrator and it's working fine now. Maybe that can help some of you out as well

Edited by Patryk.8230
  • Like 1
Link to post
Share on other sites

I did what one person said. I went to start menu, and "pinned" Guild Wars 2, by right clicking  it on the left side,  so it is now one of those blocks on the right side. Clicked that block of GW2 and it worked! Give it a try, you are not messing with computer or the software at all. 

Edited by Belgarath.1872
Link to post
Share on other sites

Since the patch on Tuesday, November 9th, whenever I disconnect, I cannot reconnect.  I log back in, hit play, and then nothing happens.  There is some sort of flash on my screen and then my whole computer becomes unresponsive except to CTRL+ALT+DEL and hitting sign out or shut down.  Since I have hourly disconnects, thanks to my awful I.S.P., this makes the game unplayable.

Link to post
Share on other sites
37 minutes ago, Grawl.3746 said:

I had this issue yesterday on 4 of my computers I was able to launch the game on all four this afternoon by running the GW2.exe as an Administrator. Now a few hours later and that process no longer works. Back to locking up entire computer and doing hard resets. Please fix this.

 

This is exactly my issue.

Link to post
Share on other sites

Was trying to fight just now in game, the window kept doing the shaky stuff and trying to quit on me, so I tried to go to full screen, and crashed. Sighs. To add insult to injury, I came back dead and had to use coins to port. Maybe a little thing the porting part, but...Please fix this. 😞

Edited by SimulationOfLife.4657
Link to post
Share on other sites
On 11/9/2021 at 12:20 PM, Brasetvik.1609 said:

I might have a fix, in windows 10 turn off "windows 10 game mode"

You can search for: Game mode
and should find it.

Still Anet should really fix this so we can run the game with Game Mode ON. 🧐

Turn off game mode works for me! Thanks for the save!

------------------------

Edit: Actually this only fixed one time, and unfortunately when I tried again,  it failed... 

Edited by Zoe.2164
adjust my inaccurate findings after repeated experiments.
  • Sad 1
Link to post
Share on other sites

Also 0 or almost 0 participation in wvw for me in the past few days, even after fighting and dying a few times. I know that's not this issue, but it seems to have started almost at the same time for me. Yes, I'm very sad about my game not working, but I'm also very sad to think going to wvw might be something I can not do anymore. I don't pvp, but went to wvw for achieves and now I want to stay. Why so many bugs all of a sudden ? 😞

  • Sad 1
Link to post
Share on other sites

I had roughly the same issue as everyone else. The game "launched" with the intro music in the background and would not switch over to the game screen. I have a solution. If you're on 64-bit windows, right-click the gw2-64.exe file and run the compatibility troubleshooter and select the recommended settings. That is one way I got it to work.

Link to post
Share on other sites

I rolled back the Realtek PCIe GeB family network adapter to the previous driver and it now works just fine .

I have more than one PC capable of playing and I couldn't understand why one couldn't and I noted

the different adapters .

Easy possible fix and certainly worth a try - I had tried everything else before as others have pointed out .

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...