Jump to content
  • Sign Up

Can't launch game after the November 9, 2021 update


Recommended Posts

Once again, I've lost the ability to have the game up at all, past the launcher, with the daily reset. This is despite having tried every solution I've seen suggested, including running as administrator while game mode is turned off and more. I don't know what they broke, but they broke it good and hard =/

Link to post
Share on other sites
  • Replies 805
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello all, I just want to leave a quick note that some people are looking into this and trying to chase down a fix. 

Thank you all for your patience on this. We've been working hard to get this sorted out and have identified a fix. We'll have that out to you as soon as possible.

Right after the update, the game "launches" in the background but you can't switch to it. I can hear the music and everything but can't see the actual game. Alt Tab doesn't work and I need to end

Interesting. I had this bug creep up once in a while before ( I want to say since last summer there about ) and it started happening repeatedly this week. ( same as OP ).... and then it stopped when I tried launching the game with a browser window opened ? 

It's just magic to me at this point so I'm glad they have a fix in the works.😄

Link to post
Share on other sites

I've had the same issue and have a workaround that's been 100% successful for me.

All that I do is start the game in windowed mode (not windowed full screen) until the character screen loads completely.  I then maximize the game window and play as normal.

Edited by mythical.6315
Link to post
Share on other sites
4 hours ago, mythical.6315 said:


Check Twitter.

They've also posted twice in this thread. 

True, but posts saying we are aware and fixing well after the problems was being reported seems like an after thought on their part. Not posting on ALL platforms they interact with is inexcusable. Not posting an important message to not waste time with drivers, verifying, reinstalling and all the other so called work arounds, likewise. They could have a locked post about the windowed option as well as their working on post much earlier than they did, and on and on. They to need respect their customers.

 

Edited by Blude.6812
  • Confused 2
Link to post
Share on other sites
11 minutes ago, Blude.6812 said:

True, but posts saying we are aware and fixing well after the problems was being reported seems like an after thought on their part. Not posting on ALL platforms they interact with is inexcusable. Not posting an important message to not waste time with drivers, verifying, reinstalling and all the other so called work arounds, likewise. They could have a locked post about the windowed option as well as their working on post much earlier than they did, and on and on. They to need respect their customers.

 

I can assure you... people who WANT to take offense, will still take offense, no matter what they do. 

  • Like 2
Link to post
Share on other sites
1 hour ago, Blude.6812 said:

True, but posts saying we are aware and fixing well after the problems was being reported seems like an after thought on their part.


It’s been two days…

Actually I just checked and they responded Tuesday morning to the issue literally a few hours after the patch. So you’re making accusations without having all of the facts. 
 

 

 

Edited by mythical.6315
Link to post
Share on other sites

Ever since the new update, I haven't been able to get past the log in screen. Yesterday, I tried 5 separate times to get in. All I got was a shrunken mouse icon and the inability to select anything which resulted in having to do a hard shutdown on my computer (mashing the power button until it shut off). Today, I managed to get in and create a new character. Logged off, came back an hour later and it's doing the same thing. Three times I had to repeat what I did before. Please tell me this is getting fixed soon!

Link to post
Share on other sites

My g/f just got this as well have to keep closing..opening..closing opening have to alt ctrl delete to get task manager. To all having this issue when at the task manager you can't click on it hit tab button with it selected you'll notice the item selected moves. Move it till "Name" above the process list is highlighted then arrow button down till guild wars 2 is selected and then hit alt + e..but it eventually starts.

Edited by Rei Hino.5961
Link to post
Share on other sites
On 11/9/2021 at 1:21 PM, Brasetvik.1609 said:

I might have a fix, in windows 10 turn off "windows 10 game mode"

You can search for: Game mode
and should find it.

Still Anet should really fix this so we can run the game with Game Mode ON. ✌️

Yeah so I had the same issue as the above poster, but this post I quoted worked for me. GW2 would steal screen focus but I couldn't see anything, don't know if there was sound because my in game levels are turned down quite a bit. had to force quit using task manager. Tried disabling "game mode" and the game was able to launch successfully. Re-enabled game mode and the game launched properly yet again. Maybe give that a try, since it's easy to do and doesn't require any installations or file directory changes, etc.

  • Thanks 1
Link to post
Share on other sites
29 minutes ago, SovietSquid.3478 said:

Yeah so I had the same issue as the above poster, but this post I quoted worked for me. GW2 would steal screen focus but I couldn't see anything, don't know if there was sound because my in game levels are turned down quite a bit. had to force quit using task manager. Tried disabling "game mode" and the game was able to launch successfully. Re-enabled game mode and the game launched properly yet again. Maybe give that a try, since it's easy to do and doesn't require any installations or file directory changes, etc.


Also worked for me. Exactly same stuff. Now the game is working again.
The mouse issue (not clicking anything after logging in even after ctlr+alt+del) was also happening here.

Link to post
Share on other sites

Hi peeps,

 

Been having the same issue as of late.

So far I've done quite a few things that don't work but finally stumbled on a temporary fix. 

By changing my screen resolution I finally got my game to launch but with black screen still on it. For some that might work.

For me what really worked was changing my monitor refresh rate/or coincidence .. 

Updated video drivers, turned off third party software such as MSI, restarted PC. Tried creating a repair launcher but that didn't work. 

Soon a hot fix will be made by ArenaNet, so far I hope changing your resolution or refresh rate helps. 

Stay strong brothers.

Link to post
Share on other sites

Hi all,

 

I had the same issue and nothing worked for me. but i was finally able to run game after those changes :

  1. turn Game mode off 
  2. Run game as Administrator

When I tried after that to turn game mode on or did not run as Admin, game started, but not showed, only sound on background and screen frozen ... I was able to run command line (<Windows key> cmd -> click Run as Administrator) an then alt-tab to this console and write :

tasklist, search for row with Gw2-64.exe <number> and then write taskkill /F /PID <number> and it kills game.

 

i hope, that patch will be here soon ...

Link to post
Share on other sites
On 8/27/2018 at 1:57 PM, aandiarie.7195 said:

I don't know much about computer stuff, but my old computer used to not like gw2. How old is your computer and what are the specs on it? Are you using the 64 or 32 bit client thing? You can also try to repair the client. Google repair client gw2. https://help.guildwars2.com/hc/en-us/articles/201863008-Repairing-the-Game-Client

Repairing game client worked for me.  Thanks for reposting the steps

Link to post
Share on other sites
  • Issues and Mistakes tend to happen, for me it works fine, forcing the window mode. Make a Shortcut of your GW2.exe and right-click and go into properties. After that just add -windowed to Target. Looks something like this "E:\Games\Guild Wars 2\Gw2-64.exe" -windowed.  You can maximize in game again. Hope that works for you for now. 
Link to post
Share on other sites
16 minutes ago, yoni.7015 said:

It is really disappointing that they are not fixing it and their communication sucks 

There have been replies and an update thread about it.  They have a team working on it. TBH until they are 100% sure when it will be fixed that's all they really can say.

 

It didn't work at all for me just after the update, the next day it opened in a window. I'm looking forward to getting back to full screen but for now I'm happy knowing there's a team working on it. if somebody said, "It should all be fixed within the hour." We'd be disappointed if it wasn't.

  • Like 1
  • Confused 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...