Jump to content
  • Sign Up

Recommended Posts

I use 2 monitors.

When I use GW2 Full screen, it traps the cursor and that's a pain. Other games don't trap the cursor in this mode.

So in GW2 I've taking to using Window mode and then Hide the task bar. Which is a pain because then I have to change that setting every time I launch GW2. But at least I can move the cursor between monitors. No trapping.

I tried Window Full screen, but that does not trap the cursor, but it covers the task bar on the GW2 monitor.

So I guess I'm asking for Full Screen Window to not hide the task bar and to not trap cursor.

Am I missing something? Why can other games get this right?

Edited by windyweather.1238
  • Confused 1
Link to post
Share on other sites

I agree GW2 shouldn't lock the cursor to one screen, in any mode. That sounds annoying.

But I'm also confused; you don't like windowed full screen because it hides the task bar, so you play in windowed mode and manually hide the task bar? Why do you want it hidden in one version and not the other?

  • Like 2
Link to post
Share on other sites

I play on my laptop with an HDMI-connected larger monitor attached.  I set the larger monitor as the primary one when I'm playing.  I play in windowed fullscreen mode.  When I play, the cursor is not locked, and the game plays in full screen on the larger monitor.  On my laptop screen, I have the taskbar visible, and I can use a browser, a map jpg, or whatever I want.  Works for me.

  • Like 1
Link to post
Share on other sites
18 minutes ago, Danikat.8537 said:

I agree GW2 shouldn't lock the cursor to one screen, in any mode. That sounds annoying.

But I'm also confused; you don't like windowed full screen because it hides the task bar, so you play in windowed mode and manually hide the task bar? Why do you want it hidden in one version and not the other?

In window mode, the bottom of the GW2 game window is covered by the task bar oddly. Apparently GW2 sizes the window to the screen, so I have to "Auto Hide" the windows task bar to play. And since I'm not a fan of this task bar mode, I have to switch it on for GW2 and off for the other [shall rename mainless] game I play.

 

  • Confused 1
Link to post
Share on other sites
22 minutes ago, Joustix.3185 said:

 Works for me.

Yep. But I'm using a 32" monitor to my left about 2 arms lengths away at the end of the recliner and my main 23" monitor right in front of me on a monitor arm as I recline. So, my second monitor is not as easy to see as yours. Your solution Does not work for me. 😉

Link to post
Share on other sites

Fullscreen (aka exclusive full screen) is supposed to limit you to 1 screen, windowed full screen (aka borderless) is supposed to take up the full screen and windowed is supposed to be a window that the taskbar will display on top of.

Are you simply expecting windowed mode to display on top of the taskbar? You can achieve that by making GW2 top most, but you'll need a program to do that.

  • Like 1
Link to post
Share on other sites

 

18 minutes ago, windyweather.1238 said:

In window mode, the bottom of the GW2 game window is covered by the task bar oddly. Apparently GW2 sizes the window to the screen, so I have to "Auto Hide" the windows task bar to play. And since I'm not a fan of this task bar mode, I have to switch it on for GW2 and off for the other [shall rename mainless] game I play.

 

This happens occasionally to me (the taskbar obscuring the bottom of the game screen), and rebooting the computer fixes the problem.  Hope that helps you too.

Link to post
Share on other sites
Posted (edited)
5 minutes ago, Joustix.3185 said:

 

This happens occasionally to me (the taskbar obscuring the bottom of the game screen), and rebooting the computer fixes the problem.  Hope that helps you too.

Actually, no. Never helped to reboot. GW2 in windowed mode always hangs down over the task bar.

Edited by windyweather.1238
Link to post
Share on other sites
1 hour ago, windyweather.1238 said:

In window mode, the bottom of the GW2 game window is covered by the task bar oddly. Apparently GW2 sizes the window to the screen, so I have to "Auto Hide" the windows task bar to play. And since I'm not a fan of this task bar mode, I have to switch it on for GW2 and off for the other [shall rename mainless] game I play.

 

Are you running an app on the second screen by chance?  I have found that running a 'focused' app on the second screen can cause the Taskbar to stay on top of GW2.  In both the setups I can test here, neither had the issue as you describe with Windowed Fullscreen.  The mouse can freely roam across screens and the taskbar remains hidden unless another window is focused.  As soon as I alt+rab, hit windows key, click outside the game, the taskbar appears over GW2 as expected, and when I click back into GW2 the taskbar falls behind GW2 window.

 

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Well, I use two monitors and have set everything so that the cursor of the game can't go outside of it...nevertheless, someow my cursor finds a way to the other monitor, which causes my game window to close and, depending on the situation, my character to die. So there's hope I guess... also pls fix this ANet, it's anoying.

Link to post
Share on other sites
1 hour ago, The Greyhawk.9107 said:

This sounds like its going to be fun, as I'm planning to get a second monitor in the near future and have no idea how I'm going to manage this....

You may not have a problem at all.

I run two monitors, windowed fullscreen so I can easily click over to the wiki or a guide as neeeded. GW2 fills the entirety of the first screen, and I never have problems with my cursor flying off GW2. If I click on something like a web browser on the second screen, the task bar does show up over GW2 on the other, but as soon as I click back on GW2, it comes to the front and the taskbar disappears.

I'm totally not saying these problems don't happen for other people just because they don't happen for me. But no need to borrow trouble, as they say. Might work just fine for you.

Link to post
Share on other sites
25 minutes ago, Gibson.4036 said:

You may not have a problem at all.

I run two monitors, windowed fullscreen so I can easily click over to the wiki or a guide as neeeded. GW2 fills the entirety of the first screen, and I never have problems with my cursor flying off GW2. If I click on something like a web browser on the second screen, the task bar does show up over GW2 on the other, but as soon as I click back on GW2, it comes to the front and the taskbar disappears.

I'm totally not saying these problems don't happen for other people just because they don't happen for me. But no need to borrow trouble, as they say. Might work just fine for you.

Here's hoping.

  • Like 1
Link to post
Share on other sites

I play in windowed full screen, with browser and Discord etc over on the second monitor.  I drag the toolbar over to the second monitor and lock it there.  It lasts until something graphically affects my desktop (some games or driver updates like to temporarily change my resolution and shove everything to the main monitor).  My mouse cursor moves freely between monitors, which indeed is an issue during frantic combat, but I need to be able to interact with both monitors so I put up with the problems therein.

Win 11 reportedly doesn't let you move task bars so it may cause some issues with this setup.  But as long as you are in Win 10, you should be able to have your task bar on a different monitor from your game.

Link to post
Share on other sites
On 1/3/2022 at 12:24 AM, windyweather.1238 said:

When I use GW2 Full screen, it traps the cursor and that's a pain. Other games don't trap the cursor in this mode.

Yes, they do - unless you use Windowed Fullscreen, which is what you need to do in GW2 as well.

Link to post
Share on other sites
On 1/2/2022 at 4:05 PM, windyweather.1238 said:

In window mode, the bottom of the GW2 game window is covered by the task bar oddly. Apparently GW2 sizes the window to the screen, so I have to "Auto Hide" the windows task bar to play. And since I'm not a fan of this task bar mode, I have to switch it on for GW2 and off for the other [shall rename mainless] game I play.

 

It sounds like what you really want is for the Window mode to maximize to the size of the desktop work area, rather than the whole screen - which I would agree with, and I'm surprised it doesn't already do that. The current Fullscreen Window behavior is standard, though.

 

On 1/3/2022 at 3:51 AM, lokh.2695 said:

Well, I use two monitors and have set everything so that the cursor of the game can't go outside of it...nevertheless, someow my cursor finds a way to the other monitor, which causes my game window to close and, depending on the situation, my character to die. So there's hope I guess... also pls fix this ANet, it's anoying.

I've seen this. I switched to Fullscreen Window because it was driving me up the wall - yeah the mouse can (and often does) "escape" still, especially when I can't see the cursor due to visual noise, but it's better than minimizing the game.

I haven't been able to isolate the cause of it, but I have a suspicion Discord might be to blame - since I didn't see the issue when it wasn't running (and there are reports on the internet that Discord can steal focus when it shouldn't). But I have no proof, would need to somehow log Windows input/focus events to definitively root-cause it.

Link to post
Share on other sites
2 hours ago, Sirius.4510 said:

But I have no proof, would need to somehow log Windows input/focus events to definitively root-cause it.

https://www.softpedia.com/get/System/System-Info/Window-Focus-Logger.shtml

I didn't know about the above before the problem went away on its own but I used to randomly get alt+tab out of the game by something as well and that was just on a single monitor.

Link to post
Share on other sites

Not sure what to make of this. If I play windowed fullscreen, that's what I get, with no visible task bar. That's how it should work, and always works for me in all games that supports this. No issues mousing over to the other monitors either.

So, sounds like a bug on your part, or some settings you haven't set right.

Link to post
Share on other sites
On 1/3/2022 at 12:43 AM, Danikat.8537 said:

I agree GW2 shouldn't lock the cursor to one screen, in any mode. That sounds annoying.

For true fullscreen mode, that's normal behavior. Windowed fullscreen (or borderless if you will) on the other hand allows for moving the mousepointer to the other monitor.

Link to post
Share on other sites

Windowed Full Screen + Action cam, and you never have a problem of the cursor escaping the monitor you're playing the game on.

Bind a key to toggle Action Cam for those times you need a cursor.

Also, if you open a GUI window while Action Cam's active, it brings up the cursor.

 

As for the Taskbar, I play on the right hand monitor, and my taskbar runs vertically down the right side of my left hand monitor. Works well, and is always visible.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...