Jump to content
  • Sign Up

SoftTH broken for GW2

Recommended Posts

Hey all,

I was running into a problem setting up SoftTH with GW2, and hoped one of you could help me out.When I've added the d3d9.dll to GW2's bin64 folder, the game crashes on startup.For the crash report: pastebin.

What I've tried

  • Re-installing DirectX 9
  • Updating Visual C++ packages
  • Reinstalling GW2
  • Reinstalling Graphics drivers
  • Reinstalling Windows
  • Googling for hours and hours
  • Bashing my head against a wall

System InformationOperating System: Windows 10 x64Processor/CPU: Intel® Core i7-7700HQ @2.80GHz, 4 coresVideo Card/GPU: NVIDIA GTX 1050Memory/RAM: 16GB DDR4

All help in isolating and solving the issue is greatly appreciated.

Link to comment
Share on other sites

Thank you for your response.

There is no local.dat under ProgramData, but there is under Appdata\Guild Wars 2.I've deleted the local.dat and started the game again. It ran for a few seconds (regenerating the local.dat, I assume) and then crashed again, with the same error.Do you have any other ideas as to what might solve this issue?

Link to comment
Share on other sites

the bin64 folder within the gw2 folder is only for the coherent UI (which is the TP), and nothing to do with the actual game, so try putting the dll and config in the game folder outside of bin64. that could be what is causing the crash. not quite sure how SoftTH works.

also, are you using the 64 bit version of SoftTH?

I read back in 2012 you had to remove the dll and config, open the launcher and login, move the dll and config back (while the launcher was still open), then press play on the launcher. not sure if that will help, but it's worth a try.

Link to comment
Share on other sites

Thanks for the responses, much appreciated.

I have reinstalled Windows 10 (again) and installed GW2 clean, so the Coherent Host should be fresh 'n clean, but the same error is thrownI am using SoftTH "DX9 v2.08 alpha 64 bit", fetched from softth.net.

Normally, when you start an application after adding the SoftTH dll, a popup appears notifying you that SoftTH will generate a config file.After confirming this, a config file is generated. This doesn't happen when I put the dll in the main GW2 directory, indicating that it isn't being loaded.I remember putting the dll into the bin64 folder to have it be loaded, half a year ago or so, but I never got it to work correctly back then.

I've tried the workaround of removing the dll before starting the launcher and adding it before starting the game itself, but this results in the dll not being loaded.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...