Jump to content
  • Sign Up

2.13: error: couldn't find the attach point: X


Recommended Posts

I've launched the game after a few years break, gone through the updates, and on the character screen I get a System log console with ~20 lines like this :

2.13: error: couldn't find the attach point: 85

2.13: error: couldn't find the attach point: 82
...

Full window here

 

I relauched the game with the -repair flag but this window is still present.  So far, I can log into my character and it didn't crash yet.

 

Is there a "deep repair" option available to check all the 50GB files integrity ?

Link to post
Share on other sites

First make sure you don't have ANY add-ons installed. These are known to crash the game after updates or cause other problems. Things like ArcDPS are very specific for a certain build of the game.

 

Another part of a cleanup can be to delete your Guild Wars 2 local settings:

C:\Users\%your user name%\AppData\Roaming\Guild Wars 2

 

If you want to keep your settings you can make a backup of this folder before deleting.

Last option is to just delete GW2.dat and let everything download again. 50+ GB, so this may take long.

Edited by TheQuickFox.3826
Link to post
Share on other sites

Thanks Inculpatus,

 

I tried the flags -repair -verify -log to no avail. Then I noticed that in my install folder, every file had a "last modified" date of today, except for the d3d9_arcdps_buildtemplates.dll and d3d9.dll files which dated from 2019.

 

So I tried the -dx11 flag to bypass dx9 and that got rid of the nagging window ! Also, deleting the 2 dll above also worked without needing the -dx11.

 

TLDR : Got a bug? Delete old files not refreshed by an update, problem solved (YMMV).

 

Link to post
Share on other sites
12 hours ago, vinterberg.2783 said:

Those two files you mention are part of arcDPS, the issue here is that you didn't keep it up to date

Arg, I completely forgot about that addon. After 3 years, the re-learning curve of GW2 is pretty steep. Thanks for the info.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...