Jump to content
  • Sign Up

Salvaging Trophy's for Unbound Magic not working

Recommended Posts

I am going through the achievements for Vision and Aura and getting lots of trophy's as a result.  All of them say "salvage for unbound magic".  Yes, no kit or none of the "o-matics" seem to work.  The item shows up as salvageable but when used nothing returns and the items remain.  I probably have 2000 worth of unbound magic I would rather not loose.  I have tried double clicking and that does not work either.  For reference, the items are things like this.


Is this a bug or am I not doing something correctly.

Link to comment
Share on other sites

Cross-referencing bug reports for relevant information:

Person who cannot salvage Exotic Items. Keep in mind, all these trophies are Exotic items.

Aurora Collection trophies cannot be salvaged.

Salvaging Trophy's for Unbound Magic not working

Just before the EoD expansion, I was working on this, and it worked up until then. A few days after release, went back to these quests, and trophies cannot be salvaged now. 

1. Items still have description: Salvage for unbound magic.

2. Can use Salvage-O-Matic on them. Gives pop-up reminder:  This is a very valuable piece of equipment. Are you sure you want to salvage [name_of_item]?

3. Accept does nothing, and the mouse icon is still the Salvage-O-Matic and can click on other salvage items.

4. I do not wish to salvage my Exotic gear atm, so cannot test if other Exotic items are salvagable. Since all of these trophies are Exotic, I would hypothesize that the first link above is correct, they aren't salvageable because no Exotic gear is.

Link to comment
Share on other sites

  • 6 months later...
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...